summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-10-03 13:58:57 -0400
committerMatt Turner <mattst88@gentoo.org>2023-10-03 14:06:44 -0400
commit854b279c6a33f7cf5424e11ebedf53af20c6b8b7 (patch)
treef18bfdb6baed7e6710688c27a15dc2d05e8656ed /x11-misc
parentx11-libs/libX11: Version bump to 1.8.7 (diff)
downloadgentoo-854b279c6a33f7cf5424e11ebedf53af20c6b8b7.tar.gz
gentoo-854b279c6a33f7cf5424e11ebedf53af20c6b8b7.tar.bz2
gentoo-854b279c6a33f7cf5424e11ebedf53af20c6b8b7.zip
x11-misc/compose-tables: Version bump to 1.8.7
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/compose-tables/Manifest1
-rw-r--r--x11-misc/compose-tables/compose-tables-1.8.7.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/compose-tables/Manifest b/x11-misc/compose-tables/Manifest
index c97d7a096c7a..a1d5dbc479ee 100644
--- a/x11-misc/compose-tables/Manifest
+++ b/x11-misc/compose-tables/Manifest
@@ -1 +1,2 @@
DIST libX11-1.8.6.tar.xz 1859460 BLAKE2B 81af515e70e013e14c07f4ead34d130477b10e93f3b057cacac77991f9db488f9821b5473a28d141ffb8ddd4a4a77303bef1a748820ccfdebd7935b528223471 SHA512 b94a578003078a42cea43d80fae2c54a3aaa30f706088bb3546331e9abfc180131cafb37887117abcc5b6116992e299974981eef96ecfcf883cc8a1aba4d1ade
+DIST libX11-1.8.7.tar.xz 1859256 BLAKE2B 335d8af91c13aba11255c266c4687a7f66b021207a92485d723b4107601bbabb6a0e5535241a3bcff4ac9a99142730d2b3d2e2eaff86b507fee5b35a2590d792 SHA512 d53bfc18f38d339a6a695b09835b2ae96b323881678bfe7ddca697605e3bdf4102ff49cc3078880a6c55b5977fcdd0aadaf5429086132de3a5bda302f79a2fa6
diff --git a/x11-misc/compose-tables/compose-tables-1.8.7.ebuild b/x11-misc/compose-tables/compose-tables-1.8.7.ebuild
new file mode 100644
index 000000000000..07d749e49aed
--- /dev/null
+++ b/x11-misc/compose-tables/compose-tables-1.8.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MULTILIB=no
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+# Note: please bump this with x11-libs/libX11
+DESCRIPTION="X.Org Compose Key tables from libX11"
+# xorg-3.eclass would attempt to fetch a tarball with a matching name to this package
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/lib/libX11-${PV}.tar.${XORG_TARBALL_SUFFIX}"
+S="${WORKDIR}/libX11-${PV}/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# Only needed by configure
+DEPEND="
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.11.1
+ x11-libs/xtrans"
+RDEPEND=""
+
+XORG_CONFIGURE_OPTIONS=(
+ --without-xmlto
+ --without-fop
+ --disable-specs
+ --disable-xkb
+ --with-keysymdefdir="${ESYSROOT}/usr/include/X11"
+)
+
+src_compile() {
+ emake -C nls
+}
+
+src_test() {
+ :;
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C nls install
+}