summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2024-12-25 16:34:14 +0100
committerSebastian Pipping <sping@gentoo.org>2024-12-25 16:34:14 +0100
commit87de0e03ef38acf7788add669514654d65e6b0ea (patch)
treefc35907bcdfd014f04fe8c54831111140efb29e5 /x11-misc
parentx11-misc/safeeyes: Drop old (diff)
downloadgentoo-87de0e03ef38acf7788add669514654d65e6b0ea.tar.gz
gentoo-87de0e03ef38acf7788add669514654d65e6b0ea.tar.bz2
gentoo-87de0e03ef38acf7788add669514654d65e6b0ea.zip
x11-misc/safeeyes: 2.2.3
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/safeeyes/Manifest1
-rw-r--r--x11-misc/safeeyes/safeeyes-2.2.3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/Manifest b/x11-misc/safeeyes/Manifest
index 4eeba33f81b7..d814fa44c6d9 100644
--- a/x11-misc/safeeyes/Manifest
+++ b/x11-misc/safeeyes/Manifest
@@ -1 +1,2 @@
DIST safeeyes-2.2.2.tar.gz 312701 BLAKE2B 73e316c699bb1b6a1291bc2afefc228067d692352788cbd68904917bbea8d8d566e3a3b764d44cb8be37d75a89a97326f153be98b69b800c42f49b0e9668dfd5 SHA512 b84f3bdeae06bc0db88a7ef1c029f8896880bd4f0cdf624eb332eb974dbfca4ce766f13d41b275747098016b3b3dbe4f1fe4ac544448916a641913ddf0a18f77
+DIST safeeyes-2.2.3.tar.gz 319259 BLAKE2B 70eea85d1427bcde826890db770723564f601a6a7dfc04aee02d72fa43f1ed0e27acbef055f2acf27050a390cf079a817e978b5321982d9de172d39669c95f57 SHA512 4ecdf27527b81454c0f6f20c534634d7ed8f15c3903c1a39acf98eb97064ce33b6b7bb77ffa98e49520698335e9680130b701e215382565fca12f2608b71cd6f
diff --git a/x11-misc/safeeyes/safeeyes-2.2.3.ebuild b/x11-misc/safeeyes/safeeyes-2.2.3.ebuild
new file mode 100644
index 000000000000..ad0c9a25dafa
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.2.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="tk" # for site-packages/Xlib/ext/randr.py
+DISTUTILS_USE_PEP517=setuptools
+
+inherit xdg distutils-r1 pypi
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/libayatana-appindicator
+ dev-python/babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-misc/xprintidle
+ "
+
+python_install() {
+ distutils-r1_python_install
+
+ # Workaround for https://bugs.gentoo.org/926816
+ # Files were misplaced and also duplicate across Python slots.
+ local misplaced_usr="${D}/usr/lib/${EPYTHON}/site-packages/usr"
+ local i
+ for i in applications icons ; do
+ local source="${misplaced_usr}/share/${i}"
+ local target="${D}/usr/share/${i}"
+ if [[ ! -d "${target}" ]]; then
+ dodir /usr/share/
+ mv "${source}" "${target}" || die
+ fi
+ done
+ rm -R "${misplaced_usr}" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}