summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 08:08:44 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:35 +0100
commite58e641f0a7360aa2438ed3d39a369d806f8c6ad (patch)
tree12797dfdc9ba53ea09992d4063bdcdfd5c9bcfa2 /x11-plugins/wmclockmon/wmclockmon-0.8.1-r1.ebuild
parentx11-plugins/wmcalendar: clean up patches (diff)
downloadgentoo-e58e641f0a7360aa2438ed3d39a369d806f8c6ad.tar.gz
gentoo-e58e641f0a7360aa2438ed3d39a369d806f8c6ad.tar.bz2
gentoo-e58e641f0a7360aa2438ed3d39a369d806f8c6ad.zip
x11-plugins/wmclockmon: respect PKG_CONFIG, add pkgconfig BDEPEND
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins/wmclockmon/wmclockmon-0.8.1-r1.ebuild')
-rw-r--r--x11-plugins/wmclockmon/wmclockmon-0.8.1-r1.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/x11-plugins/wmclockmon/wmclockmon-0.8.1-r1.ebuild b/x11-plugins/wmclockmon/wmclockmon-0.8.1-r1.ebuild
index 830ad8041b50..6f42f7bf0fab 100644
--- a/x11-plugins/wmclockmon/wmclockmon-0.8.1-r1.ebuild
+++ b/x11-plugins/wmclockmon/wmclockmon-0.8.1-r1.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-DESCRIPTION="a nice digital clock with 7 different styles either in LCD or LED style"
+inherit toolchain-funcs
+
+DESCRIPTION="A nice digital clock with 7 different styles either in LCD or LED style"
HOMEPAGE="http://tnemeth.free.fr/projets/dockapps.html"
SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}-1.tar.gz"
@@ -17,16 +19,23 @@ RDEPEND="x11-libs/gtk+:2
x11-libs/libXpm
x11-libs/libICE"
DEPEND="${RDEPEND}
- virtual/pkgconfig
x11-base/xorg-proto
x11-libs/libXt"
+BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}"/${P}-gtk.patch
- "${FILESDIR}"/${P}-gcc-10.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-gtk.patch
+ "${FILESDIR}"/${P}-gcc-10.patch
+)
DOCS=( AUTHORS BUGS ChangeLog NEWS README THANKS TODO \
doc/sample2.wmclockmonrc doc/sample1.wmclockmonrc )
+src_configure() {
+ tc-export PKG_CONFIG
+ default
+}
+
src_install() {
default
newdoc debian/changelog ChangeLog.debian