summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-08-23 22:05:52 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2015-08-23 22:35:00 +0200
commitd66ef6a88c584bff501c8b49079ac6884c6d7edd (patch)
treed657aa5e8ac06fb7db78a850ce4b293cb66f7c93 /x11-plugins/wmdate
parentgames-fps/duke3d-data: add app-arch/unzip to DEPEND (diff)
downloadgentoo-d66ef6a88c584bff501c8b49079ac6884c6d7edd.tar.gz
gentoo-d66ef6a88c584bff501c8b49079ac6884c6d7edd.tar.bz2
gentoo-d66ef6a88c584bff501c8b49079ac6884c6d7edd.zip
x11-plugins/wmdate: EAPI bump, fix compilation with new libdockapp
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-plugins/wmdate')
-rw-r--r--x11-plugins/wmdate/Manifest2
-rw-r--r--x11-plugins/wmdate/wmdate-0.7-r1.ebuild43
-rw-r--r--x11-plugins/wmdate/wmdate-0.7.ebuild4
3 files changed, 46 insertions, 3 deletions
diff --git a/x11-plugins/wmdate/Manifest b/x11-plugins/wmdate/Manifest
index 22bb856c9c11..16415f4c05bc 100644
--- a/x11-plugins/wmdate/Manifest
+++ b/x11-plugins/wmdate/Manifest
@@ -1 +1 @@
-DIST wmdate-0.7.tar.gz 10645 SHA256 e246e38a7488470d271dc5262f526462821fa4337c3e07bda8b9b3f9e7b8d975
+DIST wmdate-0.7.tar.gz 10645 SHA256 e246e38a7488470d271dc5262f526462821fa4337c3e07bda8b9b3f9e7b8d975 SHA512 30cdcd92b1ff0aaf89f87e1e396c416b0dc295c0261eb5a3f260f80aaf84b73c860d5d27b796dda2b047e6fcce1d0362005f51585a415d48f4e8b54807b228fb WHIRLPOOL fca2b61495202949628b6548aaecacc3f65837e8e3c4a27286d2653b80218a3ec90d3e7b59580a3f69f6f9e465501db28ec2bef4d41a6a7db10845674bed79f6
diff --git a/x11-plugins/wmdate/wmdate-0.7-r1.ebuild b/x11-plugins/wmdate/wmdate-0.7-r1.ebuild
new file mode 100644
index 000000000000..e73dd873363d
--- /dev/null
+++ b/x11-plugins/wmdate/wmdate-0.7-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="yet another date-display dock application"
+HOMEPAGE="http://solfertje.student.utwente.nl/~dalroi/applications.php"
+SRC_URI="http://solfertje.student.utwente.nl/~dalroi/${PN}/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-misc/gccmakedep
+ x11-misc/imake"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-ComplexProgramTargetNoMan.patch
+
+ sed -e 's#<dockapp.h>#<libdockapp/dockapp.h>#' -i *.c || die
+}
+
+src_configure() {
+ xmkmf || die "xmkmf failed."
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" \
+ LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc Changelog README
+}
diff --git a/x11-plugins/wmdate/wmdate-0.7.ebuild b/x11-plugins/wmdate/wmdate-0.7.ebuild
index 06a3285036f5..f3c8d7caf1fb 100644
--- a/x11-plugins/wmdate/wmdate-0.7.ebuild
+++ b/x11-plugins/wmdate/wmdate-0.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
IUSE=""
-RDEPEND="x11-libs/libdockapp
+RDEPEND="<x11-libs/libdockapp-0.7
x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm"