summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmdf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmdf')
-rw-r--r--x11-plugins/wmdf/Manifest1
-rw-r--r--x11-plugins/wmdf/files/wmdf_cmd_line_args.patch11
-rw-r--r--x11-plugins/wmdf/files/wmdf_sys-fs.patch42
-rw-r--r--x11-plugins/wmdf/metadata.xml5
-rw-r--r--x11-plugins/wmdf/wmdf-0.1.6-r1.ebuild37
5 files changed, 96 insertions, 0 deletions
diff --git a/x11-plugins/wmdf/Manifest b/x11-plugins/wmdf/Manifest
new file mode 100644
index 000000000000..934d3b0918ea
--- /dev/null
+++ b/x11-plugins/wmdf/Manifest
@@ -0,0 +1 @@
+DIST wmdf-0.1.6.tar.gz 119388 SHA256 e732802a4597108089a6761afde150696f8841d968cd256364271b84562d103a SHA512 5b732f035862493dbc37608389f1c9ec0d5ec32de30650ca444ecf6e847b899aaa7a3f8153d11dbd66ac5e08c24b7d946819a3b48c29b8a3b03651e8c5f8b46d WHIRLPOOL 75e141fbe75d36a15bec8c487e3e4467d09ec9dfb74b4291d045de2c656112fb27e86dd3ecc8c772a98fe531e941b61e609a28210881fe5b8eea25d7b5868a1a
diff --git a/x11-plugins/wmdf/files/wmdf_cmd_line_args.patch b/x11-plugins/wmdf/files/wmdf_cmd_line_args.patch
new file mode 100644
index 000000000000..5c506d47d211
--- /dev/null
+++ b/x11-plugins/wmdf/files/wmdf_cmd_line_args.patch
@@ -0,0 +1,11 @@
+--- wmdf.c 2005-07-06 10:05:19.000000000 +0200
++++ wmdf.c.new 2005-07-06 10:06:24.000000000 +0200
+@@ -986,8 +986,6 @@
+ " -i, --interval <number> number of secs between updates (1 is default)\n"
+ " -h, --help show this help text and exit\n"
+ " -v, --version show program version and exit\n"
+- " -w, --windowed run the application in windowed mode\n"
+- " -bw, --broken-wm activate broken window manager fix\n"
+ " -at, --alarm_threshold set the disk usage percent to sound alarm at (95 is default)\n",
+ prog, prog);
+ /* OPTIONS SUPP :
diff --git a/x11-plugins/wmdf/files/wmdf_sys-fs.patch b/x11-plugins/wmdf/files/wmdf_sys-fs.patch
new file mode 100644
index 000000000000..eefa3f1301ce
--- /dev/null
+++ b/x11-plugins/wmdf/files/wmdf_sys-fs.patch
@@ -0,0 +1,42 @@
+--- wmdf.c.orig 2005-07-06 10:03:10.000000000 +0200
++++ wmdf.c 2005-07-06 10:05:19.000000000 +0200
+@@ -332,9 +332,10 @@
+ FILE *fp,*fd;
+ char mountpoint[255], dummy[255],devnme[255],fstype[255],options[255];
+ char s[255];
+-
++ char *ref[] ={"none","proc","sysfs","usbfs","udev","devpts"};
+ unsigned int rio = 0,wio = 0,temprio = 0,tempwio = 0;
+ int i = 0;
++ int j=0;
+ int pos = 0;
+ int x;
+
+@@ -342,13 +343,20 @@
+
+ if((fp = fopen("/etc/mtab","r")) != NULL) {
+
+- while(!feof(fp)) {
+- fscanf(fp,"%s %s %s %s %s %s\n",devnme,mountpoint,fstype,options,dummy,dummy);
+- if((x = strcmp("none",devnme)) != 0) {
+- add_disk(&cur_disk_infos,mountpoint,devnme,i);
+- i++;
+- }
+- }
++ while(!feof(fp)) {
++ x=0;
++ fscanf(fp,"%s %s %s %s %s %s\n",devnme,mountpoint,fstype,options,dummy,dummy);
++ for (j=0;j<6;j++){
++ if(strcmp(ref[j],devnme)==0) {
++ x=1;
++ break;
++ }
++ }
++ if(x==0) {
++ add_disk(&cur_disk_infos,mountpoint,devnme,i);
++ i++;
++ }
++ }
+ } else {
+ fprintf(stderr,"Error opening /etc/mtab\n");
+ return;
diff --git a/x11-plugins/wmdf/metadata.xml b/x11-plugins/wmdf/metadata.xml
new file mode 100644
index 000000000000..ebfeafcdb873
--- /dev/null
+++ b/x11-plugins/wmdf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmdf/wmdf-0.1.6-r1.ebuild b/x11-plugins/wmdf/wmdf-0.1.6-r1.ebuild
new file mode 100644
index 000000000000..2ff8d87df2b4
--- /dev/null
+++ b/x11-plugins/wmdf/wmdf-0.1.6-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="An app to monitor disk space on partitions"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/359/${P}.tar.gz"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/175"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-linux"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/src
+
+ # Remove special filesystem entries, see bug #97856
+ epatch "${FILESDIR}"/wmdf_sys-fs.patch
+
+ # Remove non-implemented command line args from 'wmdf -h' listing
+ epatch "${FILESDIR}"/wmdf_cmd_line_args.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc README AUTHORS ChangeLog NEWS THANKS TODO
+}