summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-terms/xvt/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-terms/xvt/files')
-rw-r--r--x11-terms/xvt/files/xvt-int-main.patch23
-rw-r--r--x11-terms/xvt/files/xvt-makefile.patch20
-rw-r--r--x11-terms/xvt/files/xvt-pts.patch12
-rw-r--r--x11-terms/xvt/files/xvt-ttyinit-svr4pty.diff63
4 files changed, 118 insertions, 0 deletions
diff --git a/x11-terms/xvt/files/xvt-int-main.patch b/x11-terms/xvt/files/xvt-int-main.patch
new file mode 100644
index 000000000000..81baa76ce5e0
--- /dev/null
+++ b/x11-terms/xvt/files/xvt-int-main.patch
@@ -0,0 +1,23 @@
+--- xvt-1.0/xvt.c.orig 2009-09-04 15:49:13.000000000 +0200
++++ xvt-1.0/xvt.c 2009-09-04 15:49:13.000000000 +0200
+@@ -41,9 +41,9 @@
+ #endif /* UKC_LOCATIONS */
+
+ #ifdef __STDC__
+-void main(int,char **);
++int main(int,char **);
+ #else
+-void main();
++int main();
+ #endif
+
+ extern int debugging;
+@@ -67,7 +67,7 @@
+ * master end of the pseudo-teletype pair with the command talking to
+ * the slave.
+ */
+-void
++int
+ main(argc,argv)
+ int argc;
+ char **argv;
diff --git a/x11-terms/xvt/files/xvt-makefile.patch b/x11-terms/xvt/files/xvt-makefile.patch
new file mode 100644
index 000000000000..368fdeeb00be
--- /dev/null
+++ b/x11-terms/xvt/files/xvt-makefile.patch
@@ -0,0 +1,20 @@
+--- xvt-1.0/Makefile.orig 2009-09-04 15:45:08.000000000 +0200
++++ xvt-1.0/Makefile 2009-09-04 15:46:00.000000000 +0200
+@@ -27,7 +27,7 @@
+ #ARCH=AIX3
+ #ARCH=ULTRIX
+ #ARCH=HPUX
+-#ARCH=LINUX
++ARCH=LINUX
+ #
+ #
+ # If this line is uncommented then `Make config' will unclude several options
+@@ -107,7 +107,7 @@
+ OBJ=xvt.o xsetup.o command.o screen.o sbar.o ttyinit.o
+ SRC=xvt.c xsetup.c command.c screen.c sbar.c ttyinit.c
+ #
+-CFLAGS=-O $(INCLUDE) $(OPTIONS) $(DEFS) -D$(ARCH)
++CFLAGS+= $(INCLUDE) $(OPTIONS) $(DEFS) -D$(ARCH)
+ #
+ xvt: $(OBJ)
+ $(CC) $(LDFLAGS) -o xvt $(OBJ) $(LIB) -lX11
diff --git a/x11-terms/xvt/files/xvt-pts.patch b/x11-terms/xvt/files/xvt-pts.patch
new file mode 100644
index 000000000000..a86504ad29e5
--- /dev/null
+++ b/x11-terms/xvt/files/xvt-pts.patch
@@ -0,0 +1,12 @@
+--- a/ttyinit.c
++++ b/ttyinit.c
+@@ -25,6 +25,9 @@
+
+ char xvt_ttyinit_c_sccsid[] = "@(#)ttyinit.c 1.3 11/1/94 (UKC)";
+
++#ifdef LINUX
++#define _XOPEN_SOURCE
++#endif
+ #ifdef __STDC__
+ #include <stdarg.h>
+ #else
diff --git a/x11-terms/xvt/files/xvt-ttyinit-svr4pty.diff b/x11-terms/xvt/files/xvt-ttyinit-svr4pty.diff
new file mode 100644
index 000000000000..a858250c1d8a
--- /dev/null
+++ b/x11-terms/xvt/files/xvt-ttyinit-svr4pty.diff
@@ -0,0 +1,63 @@
+--- ttyinit.c 2004-08-24 18:51:18.510722064 +0100
++++ ttyinit.c.new 2004-08-24 18:50:30.539014872 +0100
+@@ -46,6 +46,7 @@
+ #include <pwd.h>
+ #include <errno.h>
+ #include <string.h>
++#include <stropts.h>
+ #include "xvt.h"
+ #include "token.h"
+ #include "command.h"
+@@ -410,44 +411,6 @@
+ get_pseudo_tty(pmaster,pslave)
+ int *pmaster, *pslave;
+ {
+-#ifdef BSD_PTY
+- int mfd, sfd;
+- char *s3, *s4;
+- static char ptyc3[] = "pqrstuvwxyz";
+- static char ptyc4[] = "0123456789abcdef";
+- static char ptynam[] = "/dev/ptyxx";
+- static char ttynam[] = "/dev/ttyxx";
+-
+- /* First find a master pty that we can open.
+- */
+- mfd = -1;
+- for (s3 = ptyc3; *s3 != 0; s3++) {
+- for (s4 = ptyc4; *s4 != 0; s4++) {
+- ptynam[8] = ttynam[8] = *s3;
+- ptynam[9] = ttynam[9] = *s4;
+- if ((mfd = open(ptynam,O_RDWR)) >= 0) {
+- if (geteuid() == 0 || access(ttynam,R_OK|W_OK) == 0)
+- break;
+- else {
+- close(mfd);
+- mfd = -1;
+- }
+- }
+- }
+- if (mfd >= 0)
+- break;
+- }
+- if (mfd < 0) {
+- error("Can't open a pseudo teletype");
+- return(NULL);
+- }
+- if ((sfd = open(ttynam,O_RDWR)) < 0) {
+- error("could not open slave tty %s",ttynam);
+- return(NULL);
+- }
+-#endif /* BSD_PTY */
+-
+-#ifdef SVR4_PTY
+ char *ttynam;
+ int mfd, sfd;
+
+@@ -464,7 +427,6 @@
+ }
+ ioctl(sfd,I_PUSH,"ptem");
+ ioctl(sfd,I_PUSH,"ldterm");
+-#endif /* SVR4_PTY */
+
+ *pslave = sfd;
+ *pmaster = mfd;