summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-23 18:22:34 -0300
committerPacho Ramos <pacho@gentoo.org>2023-10-08 13:51:12 +0200
commitd1768badd81de9c795cc718c32ee4f9d4a24828b (patch)
tree1b9e9c14926a7b3cd2dbae77aa047a44f47d1fe4 /x11-terms
parentprofiles: unmask gnote-45 (diff)
downloadgentoo-d1768badd81de9c795cc718c32ee4f9d4a24828b.tar.gz
gentoo-d1768badd81de9c795cc718c32ee4f9d4a24828b.tar.bz2
gentoo-d1768badd81de9c795cc718c32ee4f9d4a24828b.zip
x11-terms/gnome-terminal: Version bump to 3.50.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33019 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/gnome-terminal/Manifest1
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.50.0.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/Manifest b/x11-terms/gnome-terminal/Manifest
index 9f9cd4c9daf8..a3f6823f836f 100644
--- a/x11-terms/gnome-terminal/Manifest
+++ b/x11-terms/gnome-terminal/Manifest
@@ -2,3 +2,4 @@ DIST gnome-terminal-3.44.0-cntr-ntfy-autottl-ts.patch.xz 37248 BLAKE2B b3599386e
DIST gnome-terminal-3.44.1.tar.xz 1813032 BLAKE2B 3e001139aa0516bd27f7215c692c048393d6ad41737b8817f212529d3c530f6417d05601f63e6265e3fb84e788322341c25784a0a26ee7434f1d4bccd31c1eea SHA512 afaa9a1b4fa86fea853a242f167d1ba3438efe4e049336bae138cb800d43c3325f624849463f16c9d4e34360916377c4edbfd2f3977212b51e35a41cca88b283
DIST gnome-terminal-3.48.1-cntr-ntfy-autottl-ts.patch.xz 37796 BLAKE2B 91a4d50a0b4bd412e9528ec165e173c22df11749d6a59a46b0e364b4d7f403f8fdd835c29585ab12a8a9a81da42e816fe3dacb3d9cb0c2739e123404d4b57792 SHA512 69e26b0795de566d425c5b4fd389a865aedf28d64d4ad1cced926eefd3177379bdc365cf9ef76773f21d32df24067e1966302ebcab235c63c191219705eb498e
DIST gnome-terminal-3.48.2.tar.bz2 1701232 BLAKE2B f076af2dbdd1afbdbb2c4ed9c63c8c65bf8e7346034f4c364a4c395439cf95040140380bc77735c326d17a6f7d68d031aaa608ca6e9e11daf2d5d308e19c3169 SHA512 e08dc462390a566dde215939a4a7a50a6f4b3a0d4b3749e6ba0f8de0d1da57e9761c8eb655ef86836b87e8f1da00735ed9b38afef85d766cbe6224ff2f243123
+DIST gnome-terminal-3.50.0.tar.bz2 1702629 BLAKE2B e8b1c7da15fb3b63ce4cc25f7aa76e656c588294fd5801aca108d84a08d981756ef832aa1673a9894a14fa564c664dd163dceec341bbbceba8052ca316bd0037 SHA512 cbbd5d3ff101603c2350bc04648ebf7a60e6365f2d4f6286acdcfb9ba1b4312b9bb779649ed3a403194de3a8febd9ab59fe77ee805e24434c48d8761c1ccae94
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.50.0.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.50.0.ebuild
new file mode 100644
index 000000000000..fff9c031e13a
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.50.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+inherit gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 xdg
+
+DESCRIPTION="A terminal emulator for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="debug +gnome-shell +nautilus vanilla"
+
+# Upstream is hostile and refuses to upload tarballs.
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.bz2"
+SRC_URI+=" !vanilla? ( https://dev.gentoo.org/~mattst88/distfiles/${PN}-3.48.1-cntr-ntfy-autottl-ts.patch.xz )"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+# FIXME: automagic dependency on gtk+[X], just transitive but needs proper control, bug 624960
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22.27:3
+ >=gui-libs/libhandy-1.6.0
+ >=x11-libs/vte-0.72.2:2.91[!vanilla?]
+ >=dev-libs/libpcre2-10
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ sys-apps/util-linux
+ gnome-shell? ( gnome-base/gnome-shell )
+ nautilus? ( >=gnome-base/nautilus-43.0 )
+"
+DEPEND="${RDEPEND}"
+# itstool required for help/* with non-en LINGUAS, see bug #549358
+# xmllint required for glib-compile-resources, see bug #549304
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To get previous working directory inherited in new opened tab, or
+ notifications of long-running commands finishing, you will need
+ to add the following line to your ~/.bashrc:\n
+ . /etc/profile.d/vte-2.91.sh"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-3.44.1-fix-missing-wexitcode.patch
+ if ! use vanilla; then
+ # https://bugzilla.gnome.org/show_bug.cgi?id=695371
+ # Fedora patches:
+ # Restore transparency support (with compositing WMs only)
+ # OSC 777 desktop notification support (notifications on tabs for long-running commands completing)
+ # Restore "Set title" support
+ # Automatic title updating based on currently running foreground process
+ # https://src.fedoraproject.org/rpms/gnome-terminal/raw/f31/f/gnome-terminal-cntr-ntfy-autottl-ts.patch
+ # Depends on vte[-vanilla] for OSC 777 and the preexec/precmd/etc patches in VTE
+ eapply "${WORKDIR}"/${PN}-3.48.1-cntr-ntfy-autottl-ts.patch
+ fi
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use debug dbg)
+ -Ddocs=false
+ $(meson_use nautilus nautilus_extension)
+ $(meson_use gnome-shell search_provider)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if ! use vanilla; then
+ # Separate "New Window/Tab" menu entries by default, instead of unified "New Terminal"
+ insinto /usr/share/glib-2.0/schemas
+ newins "${FILESDIR}"/separate-new-tab-window.gschema.override org.gnome.Terminal.gschema.override
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}