summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-02-20 21:51:48 +0100
committerDavid Seifert <soap@gentoo.org>2023-02-20 21:51:48 +0100
commit07eb6af542b96129564a9252af798048f8af80ae (patch)
treec0326da388524f9a470f279ce62e848c27595d1f /x11-themes
parentx11-themes/verne-backgrounds: update EAPI 6 -> 8 (diff)
downloadgentoo-07eb6af542b96129564a9252af798048f8af80ae.tar.gz
gentoo-07eb6af542b96129564a9252af798048f8af80ae.tar.bz2
gentoo-07eb6af542b96129564a9252af798048f8af80ae.zip
x11-themes/vertex-icon-theme: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/vertex-icon-theme/vertex-icon-theme-20150506-r1.ebuild34
-rw-r--r--x11-themes/vertex-icon-theme/vertex-icon-theme-20150506.ebuild58
2 files changed, 34 insertions, 58 deletions
diff --git a/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506-r1.ebuild b/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506-r1.ebuild
new file mode 100644
index 000000000000..f1a07a683543
--- /dev/null
+++ b/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+MY_PN="vertex-icons"
+EGIT_COMMIT="f27e47edf392596b7967b7d134d3c62ac3fda0c9"
+
+DESCRIPTION="Vertex icon theme"
+HOMEPAGE="https://github.com/horst3180/vertex-icons"
+SRC_URI="https://github.com/horst3180/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${EGIT_COMMIT}"
+
+LICENSE="|| ( GPL-3 GPL-2 LGPL-3 CC-BY-SA-3.0 )"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+RDEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ default
+ rm COPYING README.md || die
+
+ insinto /usr/share/icons/Vertex
+ doins -r .
+}
diff --git a/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506.ebuild b/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506.ebuild
deleted file mode 100644
index efa82421d755..000000000000
--- a/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit gnome2-utils
-
-MY_PN="vertex-icons"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/horst3180/${MY_PN}"
- SRC_URI=""
-else
- EGIT_COMMIT="f27e47edf392596b7967b7d134d3c62ac3fda0c9"
- SRC_URI="https://github.com/horst3180/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
- S="${WORKDIR}/${MY_PN}-${EGIT_COMMIT}"
-fi
-
-DESCRIPTION="Vertex icon theme"
-HOMEPAGE="https://github.com/horst3180/vertex-icons"
-
-LICENSE="|| ( GPL-3 GPL-2 LGPL-3 CC-BY-SA-3.0 )"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- >=x11-themes/hicolor-icon-theme-0.10
-"
-DEPEND=""
-
-# This ebuild does not install any binaries
-RESTRICT="binchecks strip"
-
-src_configure() { :; }
-
-src_compile() { :; }
-
-src_install() {
- default
- rm COPYING README.md || die
-
- insinto /usr/share/icons/Vertex
- doins -r *
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}