summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/matchbox-desktop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/matchbox-desktop')
-rw-r--r--x11-wm/matchbox-desktop/Manifest1
-rw-r--r--x11-wm/matchbox-desktop/files/matchbox-desktop-0.9.1-dlopen.patch11
-rw-r--r--x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild42
-rw-r--r--x11-wm/matchbox-desktop/metadata.xml8
4 files changed, 62 insertions, 0 deletions
diff --git a/x11-wm/matchbox-desktop/Manifest b/x11-wm/matchbox-desktop/Manifest
new file mode 100644
index 000000000000..399962591d09
--- /dev/null
+++ b/x11-wm/matchbox-desktop/Manifest
@@ -0,0 +1 @@
+DIST matchbox-desktop-0.9.1.tar.bz2 231962 SHA256 ecb025d3660d80a9850973111b4fdfffaa50b47cbf0c5467b508d28d65146793 SHA512 469d7c088405f627b571d0475e283e1dab2d74e10a58ab9d597cb8941a633f1993859234f9444d160257dade005ce3b325c5375fab2e5f4e30aa0048578853eb WHIRLPOOL 3ec33f322c06856d655e99a940384d5e666e1d87beab71ef8ab0a8a8aabe873de5508bb090be24a169396eaced08f9c342000997a1eb799fbbebce2b2ddfa47f
diff --git a/x11-wm/matchbox-desktop/files/matchbox-desktop-0.9.1-dlopen.patch b/x11-wm/matchbox-desktop/files/matchbox-desktop-0.9.1-dlopen.patch
new file mode 100644
index 000000000000..3c7c7037eedf
--- /dev/null
+++ b/x11-wm/matchbox-desktop/files/matchbox-desktop-0.9.1-dlopen.patch
@@ -0,0 +1,11 @@
+diff -uarN matchbox-desktop-0.9.1.orig/configure.ac matchbox-desktop-0.9.1/configure.ac
+--- matchbox-desktop-0.9.1.orig/configure.ac 2005-01-24 09:11:02.000000000 -0500
++++ matchbox-desktop-0.9.1/configure.ac 2014-10-29 14:08:54.882668438 -0400
+@@ -12,6 +12,7 @@
+ AC_PROG_CC
+ AC_LIBTOOL_DLOPEN
+ AC_PROG_LIBTOOL
++LT_LIB_DLLOAD
+
+ AC_HEADER_DIRENT
+ AC_HEADER_STDC
diff --git a/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild b/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild
new file mode 100644
index 000000000000..1651b6a9e6b6
--- /dev/null
+++ b/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit versionator autotools eutils
+
+DESCRIPTION="The Matchbox Desktop"
+HOMEPAGE="http://matchbox-project.org/"
+SRC_URI="http://matchbox-project.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="amd64 ~arm ~hppa ppc x86"
+IUSE="debug dnotify startup-notification"
+
+DEPEND=">=x11-libs/libmatchbox-1.5
+ startup-notification? ( x11-libs/startup-notification )"
+
+RDEPEND="${DEPEND}
+ x11-wm/matchbox-common"
+
+src_unpack() {
+ unpack ${A} || die "Failed to unpack"
+ cd "${S}" || die
+ epatch "${FILESDIR}/${P}-dlopen.patch" || die "Patch failed"
+ eautoreconf || die
+}
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable startup-notification) \
+ $(use_enable dnotify) \
+ || die "Configuration failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}
diff --git a/x11-wm/matchbox-desktop/metadata.xml b/x11-wm/matchbox-desktop/metadata.xml
new file mode 100644
index 000000000000..0c994964d804
--- /dev/null
+++ b/x11-wm/matchbox-desktop/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gpe</herd>
+ <use>
+ <flag name="dnotify">Use the linux kernel directory notification feature.</flag>
+ </use>
+</pkgmetadata>