summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-25 16:54:24 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-25 18:26:03 +0200
commit41eea6d10f96813a0dd9127b2643f2dd3380a6e8 (patch)
tree7b2d9b239f3d7f55e043e30efeb91b9293043165 /x11-wm
parentx11-wm/muffin: Drop old (diff)
downloadgentoo-41eea6d10f96813a0dd9127b2643f2dd3380a6e8.tar.gz
gentoo-41eea6d10f96813a0dd9127b2643f2dd3380a6e8.tar.bz2
gentoo-41eea6d10f96813a0dd9127b2643f2dd3380a6e8.zip
x11-wm/muffin: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/muffin/Manifest1
-rw-r--r--x11-wm/muffin/muffin-3.0.5.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/x11-wm/muffin/Manifest b/x11-wm/muffin/Manifest
index 4901e354adac..a8f1a6fe43cd 100644
--- a/x11-wm/muffin/Manifest
+++ b/x11-wm/muffin/Manifest
@@ -1 +1,2 @@
DIST muffin-2.8.5.tar.gz 2715965 SHA256 0ae19de74111f222b44f7bf8d159437a83c6ae2e7ce70b327c0296365d69aba4 SHA512 a285e076f27e3a52ba4c6d813578e780f7f900e0ed3fa009951d908ffef3b0ded3678f6d298dd08f80b1cd61f20c90b0acd8607d53ad2accc27e16bf1bc14221 WHIRLPOOL 6493050ea667b354324511818a692cf0fca33ef83701dfee38f3bf4cec738276f885cfbdf65efa769e5bd0c0870b6359acb3fd6de583e9ab66ef09daaeeba8ff
+DIST muffin-3.0.5.tar.gz 2717820 SHA256 11c27abedad6952aaa446d37ad23e910c3c51dc0dd8d29298cfae2c3ad917e64 SHA512 2d4d37099e33ee5b0817970f5f7e264d679752ef5a256916e54a7072419e8c75a67d8609c541238bd76c462a85c9841167e051b3ced968a557aa4a90f41b2d5c WHIRLPOOL e57f4ab9970cabae7039bdedeb3f02abfb1b4311824af39eb8022cff694f3c34d19183b133f81cc0663e195ea66b32602462e145f1ecb77c63d17d4ce2b065e7
diff --git a/x11-wm/muffin/muffin-3.0.5.ebuild b/x11-wm/muffin/muffin-3.0.5.ebuild
new file mode 100644
index 000000000000..3abdc5120f07
--- /dev/null
+++ b/x11-wm/muffin/muffin-3.0.5.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils gnome2
+
+DESCRIPTION="Compositing window manager forked from Mutter for use with Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/muffin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+introspection test xinerama"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ >=x11-libs/pango-1.2[X,introspection?]
+ >=x11-libs/cairo-1.14:=[X]
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.9.12:3[X,introspection?]
+ >=dev-libs/glib-2.37.3:2[dbus]
+ >=gnome-extra/cinnamon-desktop-2.4:0=[introspection?]
+ >=gnome-base/gsettings-desktop-schemas-3.3.0[introspection?]
+ >=media-libs/clutter-1.14.3:1.0=[introspection?]
+ >=media-libs/cogl-1.13.3:1.0=[introspection?]
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/libXcomposite-0.3
+ >=x11-libs/startup-notification-0.7:=
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ virtual/opengl
+
+ gnome-extra/zenity
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ xinerama? ( x11-libs/libXinerama )
+"
+# needs gtk-doc, not just -am, for gtk-doc.make
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ !x11-misc/expocity
+"
+
+src_prepare() {
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* *.txt doc/*.txt"
+ gnome2_src_configure \
+ --disable-static \
+ --enable-shape \
+ --enable-sm \
+ --enable-startup-notification \
+ --enable-xsync \
+ --enable-verbose-mode \
+ --with-libcanberra \
+ $(use_enable introspection) \
+ $(use_enable xinerama)
+}