summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-14 13:11:18 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-14 13:28:52 +0100
commitcda9fab6e1f136edbe2e388c1cac1f425b5f7190 (patch)
treeb2681749eca562f7408232e8f7177f0e366a8339 /xfce-base/libxfce4ui
parentsys-fs/xfsprogs: Bump to version 5.10.0 (diff)
downloadgentoo-cda9fab6e1f136edbe2e388c1cac1f425b5f7190.tar.gz
gentoo-cda9fab6e1f136edbe2e388c1cac1f425b5f7190.tar.bz2
gentoo-cda9fab6e1f136edbe2e388c1cac1f425b5f7190.zip
xfce-base/libxfce4ui: Bump to 4.15.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/libxfce4ui')
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.15.7.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index 7ae4e520ae39..2314b6bcc76f 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -3,3 +3,4 @@ DIST libxfce4ui-4.15.3.tar.bz2 756530 BLAKE2B ca2a9d5aae80d22a97b2fe932248756c9f
DIST libxfce4ui-4.15.4.tar.bz2 825895 BLAKE2B 46687dea72d17a3693c31f69bd4d1961397bf00d9395935778c8c5b90e6e56585fa2e64fe4be817ad44994841218d7cce98ade033914c56ea82a04ae7e1b70e7 SHA512 af2545f6d72df1a13d926a52b5124c52f34fbee0b2db6664292f74bcc3d93cb42263eab57beb9f882be42b6530649b2c7e42d496817f1b34b7d2b67b29e6deb1
DIST libxfce4ui-4.15.5.tar.bz2 813220 BLAKE2B 5925ea1e25abf485e04902b47da6e09d228297b7137dbeedb8c60655e2005ded37138d12482f8321928994f2bfb8d351bb18f2eb47f288d810f58ce75e378c06 SHA512 daa666826e2b4d876025a3c93b6caf40b063b456660116f5c4c8b2beb9a9eb26d6228785cc7e6435d2a38b68c15261fc872a8cf3e03af0969342e3396a6b2a49
DIST libxfce4ui-4.15.6.tar.bz2 823475 BLAKE2B 11193a72be188dc205ad24d7ea06ac21f93679d58bed273d78ff04180226eab14fd211bd2feba9b3ade20539364f90229bdfe226c2b1e4b6f6a17f7444feb26d SHA512 608daf350b8fb43ae4eb70b6d7e684528bcc90360f6d29b182da4f04bc51f5c191e27369dfa1554b6840dbdefbe132cfc66935b6f2d88dcc62f67f929b9423ec
+DIST libxfce4ui-4.15.7.tar.bz2 807676 BLAKE2B 0280d0e35244740d016fc4cd8afebb5a70348226011473117c3b7124abcc597baf8015754bb8aaa2fa3f0560d1a98d68f319c5b5870e1c8f5543c0a9458eb541 SHA512 0fd05bbaa42d3f3a0df552fb7419ebc390e6292f4bae58d4c9d6137421cdd55f17756e51c3adcd5ad6e7c92f277b9485ea1d791ef1295ac3d65d86201fc33a6a
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.15.7.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.15.7.ebuild
new file mode 100644
index 000000000000..5ec78d67a32b
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.15.7.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade introspection startup-notification system-info vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.15.6:=[introspection?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10 )
+ introspection? ( dev-libs/gobject-introspection:= )
+ startup-notification? ( x11-libs/startup-notification )
+ system-info? (
+ dev-libs/libgudev
+ gnome-base/libgtop
+ >=media-libs/libepoxy-1.2
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable system-info glibtop)
+ $(use_enable system-info epoxy)
+ $(use_enable system-info gudev)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}