summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-25 05:07:26 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-25 05:07:26 +0200
commitaa5f6479e104fa4a09b2b81f93bb1f52504d278a (patch)
tree2d005a1c450f48019e1a753fd30f7df6d2349562 /xfce-base
parentnet-im/zoom: add 6.0.12.5501 (diff)
downloadgentoo-aa5f6479e104fa4a09b2b81f93bb1f52504d278a.tar.gz
gentoo-aa5f6479e104fa4a09b2b81f93bb1f52504d278a.tar.bz2
gentoo-aa5f6479e104fa4a09b2b81f93bb1f52504d278a.zip
xfce-base/libxfce4ui: Bump to 4.19.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.19.6.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index b2894f8e5703..bd9c82a6d7d2 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4ui-4.18.6.tar.bz2 906477 BLAKE2B b9b1a6a3a82760147cdcf9cd462c58044f640bb0c6eaa96f1f56247d6d01ce3ca97d47f6ffa03206452d0501250d6c72fd0c018870ed2c679e9226f44e618ce4 SHA512 1c704dd26793a304fef98c48bc3ca860248e746e9e5c39f22e984439e1a20209763e80e40e6bffcf8f0d773b323b825ebd5da4d88352582e56dfeb7c9b2ca47c
DIST libxfce4ui-4.19.5.tar.bz2 1185047 BLAKE2B 3c05d0b4d7756699d0591154765f66ffae6e528d1e58963f182921e7070639e708fbbe924bd54d9cb76fca7423b56fe6938c669a8c6f2268831c97aa22158403 SHA512 c8db19e04e3c529c2374238444cc77ef9d3454de4734fff269c1e60c9d1011c0c66cadb926561c7f122485707c75d88835c7dbb4af674c1ad0ff772af50a38d5
+DIST libxfce4ui-4.19.6.tar.bz2 1200335 BLAKE2B ef69da03ba41615ee85c6fcaf623baa83b6f95aa70424ce5cbe133c0d7ff784088cf258296866b71840aff62b7fb6b55bb0f633fa7f8897f849e577fe80418e7 SHA512 35f0762cb7d53223b7b54e7f3c254db96b354f465b9a5c2af4469e51b31955d48027f7f45a060808c9ccfe5bddb29e2d0381489832203cae7f37a02cc2cc3121
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.19.6.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.19.6.ebuild
new file mode 100644
index 000000000000..ddabaac75c0d
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.19.6.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/libxfce4ui/start
+ https://gitlab.xfce.org/xfce/libxfce4ui/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="glade +introspection startup-notification system-info vala wayland X"
+REQUIRED_USE="
+ || ( wayland X )
+ vala? ( introspection )
+"
+
+DEPEND="
+ >=dev-libs/glib-2.72.0
+ >=x11-libs/gtk+-3.24.0:3[introspection?,wayland?,X?]
+ >=xfce-base/libxfce4util-4.17.2:=[introspection?,vala?]
+ >=xfce-base/xfconf-4.12.0:=
+ glade? ( >=dev-util/glade-3.5.0:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+ system-info? (
+ >=dev-libs/libgudev-232
+ >=gnome-base/libgtop-2.24.0
+ >=media-libs/libepoxy-1.2
+ )
+ X? (
+ >=x11-libs/libICE-1.0.10
+ >=x11-libs/libSM-1.2.3
+ >=x11-libs/libX11-1.6.7
+ startup-notification? ( >=x11-libs/startup-notification-0.4 )
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+DEPEND+="
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-lang/perl
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable glade gladeui2)
+ $(use_enable introspection)
+ $(use_enable system-info glibtop)
+ $(use_enable system-info epoxy)
+ $(use_enable system-info gudev)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ $(use_enable wayland)
+ $(use_enable X libsm)
+ $(use_enable X x11)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}