summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-25 12:25:04 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-25 13:57:00 +0200
commit368999b7f33ee5de5e0558c1c0920bcc4c21a3fd (patch)
treeab1693860dcdd6b7162dc7f7bdf836d83349af6d /xfce-extra/xfce4-dict
parentx11-terms/kitty: Stabilize 0.36.3 x86, #939464 (diff)
downloadgentoo-368999b7f33ee5de5e0558c1c0920bcc4c21a3fd.tar.gz
gentoo-368999b7f33ee5de5e0558c1c0920bcc4c21a3fd.tar.bz2
gentoo-368999b7f33ee5de5e0558c1c0920bcc4c21a3fd.zip
xfce-extra/xfce4-dict: Bump to 0.8.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-dict')
-rw-r--r--xfce-extra/xfce4-dict/Manifest1
-rw-r--r--xfce-extra/xfce4-dict/xfce4-dict-0.8.7.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-dict/Manifest b/xfce-extra/xfce4-dict/Manifest
index ed787198207a..97302b6117f9 100644
--- a/xfce-extra/xfce4-dict/Manifest
+++ b/xfce-extra/xfce4-dict/Manifest
@@ -1 +1,2 @@
DIST xfce4-dict-0.8.6.tar.bz2 542993 BLAKE2B acf378e985c23d46b7dce1a1f0feb13b2b86a9a67d1b6123f0073530181ecd796c8d19de6bb488bac6e14176c36976e49158b990bf9fd6966553ea1ed8451d12 SHA512 bbb5926121e31c5adbd8f4c3ceb479759ee07b902e690245087213668fade48b92f9ffc7f4cabdfaa3ee1c02db8847468dd0bbd11e240017cd3c2b9901b81485
+DIST xfce4-dict-0.8.7.tar.bz2 670207 BLAKE2B 8b6cd662493435db981dd6425541741e2e39c156f3ae6475ff24767599def4a5d2b1aa34beab99afa2e136b7d499fe31052f7216c998d7cb0008f42d8592d076 SHA512 607800a9a8b356b0257fbbd5a5b7933f7c23dc70dc60706f26528806e4d72d952b1e3e320be3dbeeccad5c4e8606e4e062f7bfd35e68396c73d726d02206cff7
diff --git a/xfce-extra/xfce4-dict/xfce4-dict-0.8.7.ebuild b/xfce-extra/xfce4-dict/xfce4-dict-0.8.7.ebuild
new file mode 100644
index 000000000000..95e8d0648f67
--- /dev/null
+++ b/xfce-extra/xfce4-dict/xfce4-dict-0.8.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A dict.org querying application and panel plug-in for the Xfce desktop"
+HOMEPAGE="
+ https://docs.xfce.org/apps/xfce4-dict/start
+ https://gitlab.xfce.org/apps/xfce4-dict/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.24.0
+ >=x11-libs/gtk+-3.22.0:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4util-4.10.0:=
+ >=xfce-base/libxfce4ui-4.12.0:=
+ >=xfce-base/xfce4-panel-4.10.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}