summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/trio-websocket/Manifest1
-rw-r--r--dev-python/trio-websocket/trio-websocket-0.11.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/trio-websocket/Manifest b/dev-python/trio-websocket/Manifest
index 202e44e0aea2..6c0455589ce0 100644
--- a/dev-python/trio-websocket/Manifest
+++ b/dev-python/trio-websocket/Manifest
@@ -1,2 +1,3 @@
DIST trio-websocket-0.10.3.gh.tar.gz 45109 BLAKE2B 7adad8bd59b2350d7b8e50e88710c8b9844e8b34c712615e058a6045d575671043c527ac4330941431502affc7c307d61c1f9c1b328c579a622ff11ea79fbeb6 SHA512 8ff50030c9616ea8baa9627f229304fbb72528fcc97d1e5ead90acc3c7d683751c0d98e9c4f779d4d65fc765b00b6ec93b6d3384070a76fe18d3318af7afa975
DIST trio-websocket-0.10.4.gh.tar.gz 45490 BLAKE2B d681cc3ec9537e3c3e943831405d45a226fe61aa2482d9c9944520d5a3ecc2bbe974e63e666a5117f6bcfca2240a4b1c22a3304e6bb15fc502154df22fdbde44 SHA512 30b6655120a0117cda9707b793bd8a00fe0e8a578450c7fcc8fba2bb505aaf898aee355cec5e1faf13ff7da791a793816c675c01ac0d7047dc0ac6734508fc6c
+DIST trio-websocket-0.11.1.gh.tar.gz 45682 BLAKE2B 0f926421828476c9e23cf962df7a17a2cf4470e0898dddbc4690497521205ea11973a188ca460685739d08c34be237682b0bbbbe2c279d35e5c2fdce9b3ce020 SHA512 4b0eb6f0c012cefedb69b97e9452ba979336fbe9f154799c4c68871b8013e728374e4872a2343ab4d27fa6e25e40c3063e681e80470123d37f13f531be4f6644
diff --git a/dev-python/trio-websocket/trio-websocket-0.11.1.ebuild b/dev-python/trio-websocket/trio-websocket-0.11.1.ebuild
new file mode 100644
index 000000000000..912e3a9e8237
--- /dev/null
+++ b/dev-python/trio-websocket/trio-websocket-0.11.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSocket client and server implementation for Python Trio"
+HOMEPAGE="
+ https://github.com/python-trio/trio-websocket/
+ https://pypi.org/project/trio-websocket/
+"
+SRC_URI="
+ https://github.com/python-trio/trio-websocket/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/trio-0.11[${PYTHON_USEDEP}]
+ >=dev-python/wsproto-0.14[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-trio-0.5.0[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p trio
+}