summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/bison/bison-2.7.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-devel/bison/bison-2.7.1.ebuild b/sys-devel/bison/bison-2.7.1.ebuild
index fd0e06aa878d..0472471de947 100644
--- a/sys-devel/bison/bison-2.7.1.ebuild
+++ b/sys-devel/bison/bison-2.7.1.ebuild
@@ -13,18 +13,21 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="nls static"
+IUSE="nls static test"
RDEPEND=">=sys-devel/m4-1.4.16"
DEPEND="${RDEPEND}
sys-devel/flex
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+ test? ( dev-lang/perl )"
DOCS="AUTHORS ChangeLog-2012 NEWS README THANKS TODO" # ChangeLog-1998 PACKAGING README-alpha README-release
src_configure() {
use static && append-ldflags -static
+ # We don't need perl unless we run tests.
+ use test || export ac_cv_path_PERL=true
econf \
$(use_enable nls)
}