summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/heaptrack/heaptrack-9999.ebuild31
-rw-r--r--games-puzzle/ksokoban/Manifest2
-rw-r--r--games-puzzle/ksokoban/ksokoban-0.5.0_pre20210905.ebuild (renamed from games-puzzle/ksokoban/ksokoban-0.5.0_pre20190225.ebuild)19
-rw-r--r--games-puzzle/ksokoban/ksokoban-9999.ebuild12
-rw-r--r--sci-visualization/labplot/labplot-9999.ebuild20
-rw-r--r--sci-visualization/labplot/metadata.xml3
-rw-r--r--sys-apps/accountsservice/Manifest1
-rw-r--r--sys-apps/accountsservice/accountsservice-0.6.50-r1.ebuild60
-rw-r--r--sys-apps/accountsservice/files/accountsservice-0.6.50-loaded-state.patch36
-rw-r--r--x11-themes/qtcurve/qtcurve-1.9.0_p20210412.ebuild15
-rw-r--r--x11-themes/qtcurve/qtcurve-9999.ebuild17
11 files changed, 62 insertions, 154 deletions
diff --git a/dev-util/heaptrack/heaptrack-9999.ebuild b/dev-util/heaptrack/heaptrack-9999.ebuild
index 626643eac8ca..cb0a7bdb8024 100644
--- a/dev-util/heaptrack/heaptrack-9999.ebuild
+++ b/dev-util/heaptrack/heaptrack-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake kde.org xdg-utils
+inherit cmake desktop kde.org xdg-utils
DESCRIPTION="Fast heap memory profiler"
-HOMEPAGE="https://apps.kde.org/en/heaptrack
+HOMEPAGE="https://apps.kde.org/heaptrack/
https://milianw.de/blog/heaptrack-a-heap-memory-profiler-for-linux"
LICENSE="LGPL-2.1+"
@@ -14,12 +14,11 @@ SLOT="0"
KEYWORDS=""
IUSE="+gui test zstd"
-BDEPEND="
- gui? ( kde-frameworks/extra-cmake-modules:5 )
-"
+RESTRICT="!test? ( test )"
+
DEPEND="
- dev-libs/boost:=
- sys-libs/libunwind
+ dev-libs/boost:=[zstd?]
+ sys-libs/libunwind:=
sys-libs/zlib
gui? (
dev-libs/kdiagram:5
@@ -40,26 +39,32 @@ DEPEND="
RDEPEND="${DEPEND}
gui? ( >=kde-frameworks/kf-env-4 )
"
+BDEPEND="
+ gui? ( kde-frameworks/extra-cmake-modules:5 )
+"
-RESTRICT+=" !test? ( test )"
+src_prepare() {
+ cmake_src_prepare
+ rm -rf 3rdparty/boost-zstd || die # ensure no bundling
+}
src_configure() {
local mycmakeargs=(
-DHEAPTRACK_BUILD_GUI=$(usex gui)
-DBUILD_TESTING=$(usex test)
- $(cmake_use_find_package zstd Zstd)
+ $(cmake_use_find_package zstd ZSTD)
)
cmake_src_configure
}
-xdg_pkg_postinst() {
+pkg_postinst() {
if use gui; then
xdg_desktop_database_update
xdg_icon_cache_update
fi
}
-xdg_pkg_postrm() {
+pkg_postrm() {
if use gui; then
xdg_desktop_database_update
xdg_icon_cache_update
diff --git a/games-puzzle/ksokoban/Manifest b/games-puzzle/ksokoban/Manifest
index d3d3fdc9e0cb..26f51c3919f7 100644
--- a/games-puzzle/ksokoban/Manifest
+++ b/games-puzzle/ksokoban/Manifest
@@ -1 +1 @@
-DIST ksokoban-0.5.0_pre20190225.tar.gz 433196 BLAKE2B 5c5c132b09165798042d1f41ffc282dc41e70bc1f0573bd55373c237dc7d8424119b2c78ae6bfb741193e3699d7120c952da66f579993189332da4104c8711d9 SHA512 3377a07f646501d37f30da66e70954894e39c8b5b948cd230263bfeeec4483b4fb2fec7d00aa020fff4459df5d376a1861dea63fc1b0a2a90757066a210a5be8
+DIST ksokoban-0.5.0_pre20210905-39b9d1c1.tar.gz 444752 BLAKE2B f68376081a1ac038b64438439b17028e573b70454d820fd08c265b4a70467a51d34ca0cdd2b490b04a98c5445bf3d18dd9f7ff319258eb2e13eaf94d9b8be09e SHA512 e8cb0096c826c82c2098832885e6fc1ef7e9eb7dfc518be7c7bc68ea4f0ad68b6f72db89822f47b6aad91cd8ab395340a42426bb4c6723ee51914cf13ce9a4d8
diff --git a/games-puzzle/ksokoban/ksokoban-0.5.0_pre20190225.ebuild b/games-puzzle/ksokoban/ksokoban-0.5.0_pre20210905.ebuild
index 08ededa85199..c4e8cfe2c492 100644
--- a/games-puzzle/ksokoban/ksokoban-0.5.0_pre20190225.ebuild
+++ b/games-puzzle/ksokoban/ksokoban-0.5.0_pre20210905.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-COMMIT="317b1e70a87224c94cac85955a3d666a43527812"
-ECM_HANDBOOK="forceoptional"
-KFMIN=5.60.0
-QTMIN=5.12.3
+ECM_HANDBOOK="optional"
+KDE_ORG_COMMIT=39b9d1c1702a21a6e0fae82876c29c1f6bb77fae
+KFMIN=5.82.0
+QTMIN=5.15.2
inherit ecm kde.org
-DESCRIPTION="The japanese warehouse keeper game"
+DESCRIPTION="The Japanese warehouse keeper game"
HOMEPAGE="https://invent.kde.org/games/ksokoban"
-SRC_URI="https://github.com/KDE/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -27,8 +26,4 @@ RDEPEND="
>=kde-frameworks/kwidgetsaddons-${KFMIN}:5
>=kde-frameworks/kxmlgui-${KFMIN}:5
"
-DEPEND="${RDEPEND}
- >=kde-frameworks/kiconthemes-${KFMIN}:5
-"
-
-S="${WORKDIR}/${PN}-${COMMIT}"
+DEPEND="${RDEPEND}"
diff --git a/games-puzzle/ksokoban/ksokoban-9999.ebuild b/games-puzzle/ksokoban/ksokoban-9999.ebuild
index c1fce45cc775..6659d8b4de5f 100644
--- a/games-puzzle/ksokoban/ksokoban-9999.ebuild
+++ b/games-puzzle/ksokoban/ksokoban-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
ECM_HANDBOOK="optional"
-KFMIN=5.60.0
-QTMIN=5.12.3
+KFMIN=5.82.0
+QTMIN=5.15.2
inherit ecm kde.org
DESCRIPTION="The Japanese warehouse keeper game"
@@ -25,6 +25,4 @@ RDEPEND="
>=kde-frameworks/kwidgetsaddons-${KFMIN}:5
>=kde-frameworks/kxmlgui-${KFMIN}:5
"
-DEPEND="${RDEPEND}
- >=kde-frameworks/kiconthemes-${KFMIN}:5
-"
+DEPEND="${RDEPEND}"
diff --git a/sci-visualization/labplot/labplot-9999.ebuild b/sci-visualization/labplot/labplot-9999.ebuild
index 03cc30d425b1..6f96d8bbb4d3 100644
--- a/sci-visualization/labplot/labplot-9999.ebuild
+++ b/sci-visualization/labplot/labplot-9999.ebuild
@@ -11,7 +11,7 @@ VIRTUALX_REQUIRED="test"
inherit ecm kde.org
DESCRIPTION="Scientific data analysis and visualisation based on KDE Frameworks"
-HOMEPAGE="https://labplot.kde.org/ https://apps.kde.org/en/labplot2"
+HOMEPAGE="https://labplot.kde.org/ https://apps.kde.org/labplot2/"
if [[ ${KDE_BUILD_TYPE} = release ]]; then
SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
@@ -19,13 +19,8 @@ fi
LICENSE="GPL-2"
SLOT="5"
-IUSE="cantor fftw fits hdf5 libcerf netcdf root serial telemetry"
+IUSE="cantor fftw fits hdf5 libcerf markdown matio netcdf origin root serial telemetry"
-# not packaged: dev-qt/qtmqtt, bug 683994
-BDEPEND="
- sys-devel/bison
- sys-devel/gettext
-"
DEPEND="
>=dev-qt/qtconcurrent-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5
@@ -58,7 +53,10 @@ DEPEND="
fits? ( sci-libs/cfitsio:= )
hdf5? ( sci-libs/hdf5:= )
libcerf? ( sci-libs/libcerf )
+ markdown? ( app-text/discount )
+ matio? ( sci-libs/matio:= )
netcdf? ( sci-libs/netcdf:= )
+ origin? ( sci-libs/liborigin:2 )
root? (
app-arch/lz4
sys-libs/zlib
@@ -67,6 +65,11 @@ DEPEND="
telemetry? ( dev-libs/kuserfeedback:5 )
"
RDEPEND="${DEPEND}"
+# not packaged: dev-qt/qtmqtt, bug 683994
+BDEPEND="
+ sys-devel/bison
+ sys-devel/gettext
+"
src_configure() {
local mycmakeargs=(
@@ -77,7 +80,10 @@ src_configure() {
-DENABLE_FITS=$(usex fits)
-DENABLE_HDF5=$(usex hdf5)
-DENABLE_LIBCERF=$(usex libcerf)
+ -DENABLE_DISCOUNT=$(usex markdown)
+ -DENABLE_MATIO=$(usex matio)
-DENABLE_NETCDF=$(usex netcdf)
+ -DENABLE_LIBORIGIN=$(usex origin)
-DENABLE_ROOT=$(usex root)
-DENABLE_QTSERIALPORT=$(usex serial)
$(cmake_use_find_package telemetry KUserFeedback)
diff --git a/sci-visualization/labplot/metadata.xml b/sci-visualization/labplot/metadata.xml
index 44b4cb39dc37..1625558de1ee 100644
--- a/sci-visualization/labplot/metadata.xml
+++ b/sci-visualization/labplot/metadata.xml
@@ -20,6 +20,9 @@
<flag name="cantor">Enable support for different open-source computer algebra systems via <pkg>kde-apps/cantor</pkg></flag>
<flag name="fits">Enable support for NASA's <pkg>sci-libs/cfitsio</pkg> library</flag>
<flag name="libcerf">Enable special functions from <pkg>sci-libs/libcerf</pkg></flag>
+ <flag name="markdown">Enable Markdown support via <pkg>app-text/discount</pkg></flag>
+ <flag name="matio">Enable support for matio (<pkg>sci-libs/matio</pkg>)</flag>
+ <flag name="origin">Enable support for reading OriginLab OPJ project files through <pkg>sci-libs/liborigin</pkg></flag>
<flag name="root">Enable support for CERN's ROOT file type</flag>
<flag name="serial">Enable support for RS232 serial ports using <pkg>dev-qt/qtserialport</pkg></flag>
</use>
diff --git a/sys-apps/accountsservice/Manifest b/sys-apps/accountsservice/Manifest
index 5962483b5243..d02ee74804b3 100644
--- a/sys-apps/accountsservice/Manifest
+++ b/sys-apps/accountsservice/Manifest
@@ -1,2 +1 @@
-DIST accountsservice-0.6.50.tar.xz 384484 BLAKE2B 52c06ba85498f292204834f967211d8f0940786dc2ea3070124d3aecccd551375bfbc8fc31f23a2c3c86e23359294307656c3b927c4e819fc102d8626ae0dd82 SHA512 6e07cd318452b1cbedeacd729f0ebb200525caf1b09981abb2bac16fd90756a790ebec08aca0a0cea016f14ab27c159a68fe1332ef4bc636c5863b8c61040f64
DIST accountsservice-0.6.55.tar.xz 97972 BLAKE2B aba3adfeb53e64455ce8e672b9db754bae4af6b4de0823cc021d0311a381ec40af04371e78f7c84eab7fb72356b26e22db78aad0343d57f65ea71a7742b51fc7 SHA512 c12e6a8e80f9b087f97238da4734d2d3a14a7c5cbd870a32a04b00116f176c818c39fb886f6dc72c3e93c136b0c2074ddf8f77e20431fa3bd54f138bea9d262d
diff --git a/sys-apps/accountsservice/accountsservice-0.6.50-r1.ebuild b/sys-apps/accountsservice/accountsservice-0.6.50-r1.ebuild
deleted file mode 100644
index 11a90ec3611e..000000000000
--- a/sys-apps/accountsservice/accountsservice-0.6.50-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-GNOME2_EAUTORECONF="yes"
-
-inherit gnome2 systemd
-
-DESCRIPTION="D-Bus interfaces for querying and manipulating user account information"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/AccountsService/"
-SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 ~sparc x86"
-
-IUSE="doc elogind +introspection selinux systemd"
-REQUIRED_USE="^^ ( elogind systemd )"
-
-CDEPEND="
- >=dev-libs/glib-2.44:2
- sys-auth/polkit
- elogind? ( >=sys-auth/elogind-229.4 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
- systemd? ( >=sys-apps/systemd-186:0= )
-"
-DEPEND="${CDEPEND}
- dev-libs/libxslt
- dev-util/gdbus-codegen
- >=dev-util/gtk-doc-am-1.15
- >=dev-util/intltool-0.40
- sys-devel/gettext
- virtual/pkgconfig
- doc? (
- app-text/docbook-xml-dtd:4.1.2
- app-text/xmlto )
-"
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-accountsd )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.6.35-gentoo-system-users.patch
-
- # lib: don't set loaded state until seat is fetched (from 'master')
- "${FILESDIR}"/${P}-loaded-state.patch
-)
-
-src_configure() {
- gnome2_src_configure \
- --disable-static \
- --disable-more-warnings \
- --localstatedir="${EPREFIX}"/var \
- --enable-admin-group="wheel" \
- --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
- $(use_enable doc docbook-docs) \
- $(use_enable elogind) \
- $(use_enable introspection) \
- $(use_enable systemd)
-}
diff --git a/sys-apps/accountsservice/files/accountsservice-0.6.50-loaded-state.patch b/sys-apps/accountsservice/files/accountsservice-0.6.50-loaded-state.patch
deleted file mode 100644
index 901704bc601f..000000000000
--- a/sys-apps/accountsservice/files/accountsservice-0.6.50-loaded-state.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From c7fa612023a163e8b2352e1170c6df3fceb19b27 Mon Sep 17 00:00:00 2001
-From: Ray Strode <rstrode@redhat.com>
-Date: Thu, 19 Jul 2018 13:14:09 -0400
-Subject: lib: don't set loaded state until seat is fetched
-
-At the moment we set is-loaded on the user-manager
-object as soon as we start fetching the seat, but
-we should waiting until the seat is fetched, so
-that can_switch() will return the correct value
-if the caller waited until the loaded signal
-to use it.
-
-This commit changes the >= to > which I believe
-was the original intention anyway.
-
-https://bugs.freedesktop.org/show_bug.cgi?id=107298
----
- src/libaccountsservice/act-user-manager.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/libaccountsservice/act-user-manager.c b/src/libaccountsservice/act-user-manager.c
-index 325421b..e7e26b1 100644
---- a/src/libaccountsservice/act-user-manager.c
-+++ b/src/libaccountsservice/act-user-manager.c
-@@ -2382,7 +2382,7 @@ maybe_set_is_loaded (ActUserManager *manager)
- /* Don't set is_loaded yet unless the seat is already loaded enough
- * or failed to load.
- */
-- if (manager->priv->seat.state >= ACT_USER_MANAGER_SEAT_STATE_GET_ID) {
-+ if (manager->priv->seat.state > ACT_USER_MANAGER_SEAT_STATE_GET_ID) {
- g_debug ("ActUserManager: Seat loaded, so now setting loaded property");
- } else if (manager->priv->seat.state == ACT_USER_MANAGER_SEAT_STATE_UNLOADED) {
- g_debug ("ActUserManager: Seat wouldn't load, so giving up on it and setting loaded property");
---
-cgit v1.1
-
diff --git a/x11-themes/qtcurve/qtcurve-1.9.0_p20210412.ebuild b/x11-themes/qtcurve/qtcurve-1.9.0_p20210412.ebuild
index 766354270641..58d90fe254c0 100644
--- a/x11-themes/qtcurve/qtcurve-1.9.0_p20210412.ebuild
+++ b/x11-themes/qtcurve/qtcurve-1.9.0_p20210412.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
KDE_ORG_COMMIT=be78a85b627e90d854da0de1049e8f191e67f228
inherit cmake kde.org
@@ -18,12 +18,8 @@ REQUIRED_USE="gtk? ( X )
|| ( gtk qt5 )
plasma? ( qt5 )
"
+RESTRICT="test"
-BDEPEND="
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- plasma? ( kde-frameworks/extra-cmake-modules:5 )
-"
DEPEND="
gtk? ( x11-libs/gtk+:2 )
plasma? (
@@ -56,8 +52,11 @@ DEPEND="
)
"
RDEPEND="${DEPEND}"
-
-RESTRICT+=" test"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ plasma? ( kde-frameworks/extra-cmake-modules:5 )
+"
DOCS=( AUTHORS ChangeLog.md README.md TODO.md )
diff --git a/x11-themes/qtcurve/qtcurve-9999.ebuild b/x11-themes/qtcurve/qtcurve-9999.ebuild
index 09458a9e5a49..0d206bafd695 100644
--- a/x11-themes/qtcurve/qtcurve-9999.ebuild
+++ b/x11-themes/qtcurve/qtcurve-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake kde.org
@@ -22,12 +22,8 @@ REQUIRED_USE="gtk? ( X )
|| ( gtk qt5 )
plasma? ( qt5 )
"
+RESTRICT="test"
-BDEPEND="
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- plasma? ( kde-frameworks/extra-cmake-modules:5 )
-"
DEPEND="
gtk? ( x11-libs/gtk+:2 )
plasma? (
@@ -60,8 +56,11 @@ DEPEND="
)
"
RDEPEND="${DEPEND}"
-
-RESTRICT+=" test"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ plasma? ( kde-frameworks/extra-cmake-modules:5 )
+"
DOCS=( AUTHORS ChangeLog.md README.md TODO.md )