summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/mrouted/files/mrouted.rc4
-rw-r--r--net-misc/mrouted/mrouted-3.9.5-r1.ebuild41
2 files changed, 43 insertions, 2 deletions
diff --git a/net-misc/mrouted/files/mrouted.rc b/net-misc/mrouted/files/mrouted.rc
index fa47acbd6eff..ac76f639bb13 100644
--- a/net-misc/mrouted/files/mrouted.rc
+++ b/net-misc/mrouted/files/mrouted.rc
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-misc/mrouted/mrouted-3.9.5-r1.ebuild b/net-misc/mrouted/mrouted-3.9.5-r1.ebuild
new file mode 100644
index 000000000000..53de0f007b71
--- /dev/null
+++ b/net-misc/mrouted/mrouted-3.9.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="IP multicast routing daemon"
+HOMEPAGE="http://troglobit.com/mrouted.shtml"
+SRC_URI="ftp://ftp.vmlinux.org/pub/People/jocke/${PN}/${P}.tar.bz2"
+LICENSE="Stanford GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="|| ( dev-util/yacc sys-devel/bison )"
+RDEPEND=""
+
+src_prepare() {
+ # Respect user CFLAGS, remove upstream optimisation and -Werror
+ sed -i Makefile \
+ -e '/^CFLAGS/{s|[[:space:]]=| +=|g;s|-O2||g;s|-Werror||g}' \
+ || die
+ default
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin mrouted
+ dosbin mtrace mrinfo map-mbone
+ doman mrouted.8 mtrace.8 mrinfo.8 map-mbone.8
+
+ insinto /etc
+ doins mrouted.conf
+ newinitd "${FILESDIR}"/mrouted.rc mrouted
+}