summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/bash/bash-5.2_p15.ebuild4
-rw-r--r--app-shells/bash/bash-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/app-shells/bash/bash-5.2_p15.ebuild b/app-shells/bash/bash-5.2_p15.ebuild
index a1a2a14ae0e4..9dbde4810a73 100644
--- a/app-shells/bash/bash-5.2_p15.ebuild
+++ b/app-shells/bash/bash-5.2_p15.ebuild
@@ -246,7 +246,9 @@ src_compile() {
emake CFLAGS="${CFLAGS} -fprofile-generate=${T}/pgo -fprofile-dir=${T}/pgo" -k check
- tc-is-clang && llvm-profdata merge "${T}"/pgo --output="${T}"/pgo/default.profdata || die
+ if tc-is-clang; then
+ llvm-profdata merge "${T}"/pgo --output="${T}"/pgo/default.profdata || die
+ fi
# Rebuild Bash using the profiling data we just generated.
emake clean
diff --git a/app-shells/bash/bash-9999.ebuild b/app-shells/bash/bash-9999.ebuild
index b0207e51036e..b491dd7b04e3 100644
--- a/app-shells/bash/bash-9999.ebuild
+++ b/app-shells/bash/bash-9999.ebuild
@@ -246,7 +246,9 @@ src_compile() {
emake CFLAGS="${CFLAGS} -fprofile-generate=${T}/pgo -fprofile-dir=${T}/pgo" -k check
- tc-is-clang && llvm-profdata merge "${T}"/pgo --output="${T}"/pgo/default.profdata || die
+ if tc-is-clang; then
+ llvm-profdata merge "${T}"/pgo --output="${T}"/pgo/default.profdata || die
+ fi
# Rebuild Bash using the profiling data we just generated.
emake clean