summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-process/btop/btop-1.2.7-r1.ebuild8
-rw-r--r--sys-process/btop/files/btop-1.2.7-respect-cxx-var-839318.patch17
2 files changed, 23 insertions, 2 deletions
diff --git a/sys-process/btop/btop-1.2.7-r1.ebuild b/sys-process/btop/btop-1.2.7-r1.ebuild
index d1f846282f44..a3ce23678bf2 100644
--- a/sys-process/btop/btop-1.2.7-r1.ebuild
+++ b/sys-process/btop/btop-1.2.7-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit xdg-utils
+inherit toolchain-funcs xdg-utils
DESCRIPTION="A monitor of resources"
HOMEPAGE="https://github.com/aristocratos/btop"
@@ -13,6 +13,10 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
+PATCHES=(
+ "${FILESDIR}/${P}-respect-cxx-var-839318.patch"
+)
+
src_prepare() {
default
# btop installs README.md to /usr/share/btop by default
@@ -21,7 +25,7 @@ src_prepare() {
src_compile() {
# Disable btop optimization flags, since we have our flags in CXXFLAGS
- emake OPTFLAGS=""
+ emake OPTFLAGS="" CXX="$(tc-getCXX)"
}
src_install() {
diff --git a/sys-process/btop/files/btop-1.2.7-respect-cxx-var-839318.patch b/sys-process/btop/files/btop-1.2.7-respect-cxx-var-839318.patch
new file mode 100644
index 000000000000..5ec7dca45c1e
--- /dev/null
+++ b/sys-process/btop/files/btop-1.2.7-respect-cxx-var-839318.patch
@@ -0,0 +1,17 @@
+--- a/Makefile
++++ b/Makefile
+@@ -55,11 +55,11 @@ endif
+
+ #? Compiler and Linker
+ ifeq ($(shell command -v g++-11 >/dev/null; echo $$?),0)
+- CXX := g++-11
++ CXX ?= g++-11
+ else ifeq ($(shell command -v g++11 >/dev/null; echo $$?),0)
+- CXX := g++11
++ CXX ?= g++11
+ else ifeq ($(shell command -v g++ >/dev/null; echo $$?),0)
+- CXX := g++
++ CXX ?= g++
+ endif
+ override CXX_VERSION := $(shell $(CXX) -dumpfullversion -dumpversion || echo 0)
+