summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/charm/charm-6.8.2.ebuild38
1 files changed, 3 insertions, 35 deletions
diff --git a/sys-cluster/charm/charm-6.8.2.ebuild b/sys-cluster/charm/charm-6.8.2.ebuild
index 22e45cc25928..225db6dd57f6 100644
--- a/sys-cluster/charm/charm-6.8.2.ebuild
+++ b/sys-cluster/charm/charm-6.8.2.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
FORTRAN_STANDARD="90"
-PYTHON_COMPAT=( python2_7 )
-inherit eutils flag-o-matic fortran-2 multilib multiprocessing python-any-r1 toolchain-funcs
+inherit eutils flag-o-matic fortran-2 multilib multiprocessing toolchain-funcs
DESCRIPTION="Message-passing parallel language and runtime system"
HOMEPAGE="http://charm.cs.uiuc.edu/"
@@ -15,22 +14,11 @@ SRC_URI="http://charm.cs.uiuc.edu/distrib/${P}.tar.gz"
LICENSE="charm"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="charmdebug charmtracing charmproduction cmkopt doc examples mlogft mpi ampi numa smp static-libs syncft tcp"
+IUSE="charmdebug charmtracing charmproduction cmkopt examples mlogft mpi ampi numa smp static-libs syncft tcp"
RDEPEND="mpi? ( virtual/mpi )"
DEPEND="
${RDEPEND}
- doc? (
- >=app-text/poppler-0.12.3-r3[utils]
- dev-tex/latex2html
- virtual/tex-base
- $(python_gen_any_dep '
- >=dev-python/beautifulsoup-4[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- ')
- media-libs/netpbm
- ${PYTHON_DEPS}
- )
net-libs/libtirpc
"
@@ -40,10 +28,6 @@ REQUIRED_USE="
S="${WORKDIR}/${PN}-v${PV}"
-pkg_setup() {
- use doc && python-any-r1_pkg_setup
-}
-
get_opts() {
local CHARM_OPTS
@@ -129,11 +113,6 @@ src_compile() {
einfo "running ./build AMPI ${build_commandline}"
./build AMPI ${build_commandline} || die "Failed to build charm++"
fi
-
- # make pdf/html docs
- if use doc; then
- emake -j1 -C doc/charm++
- fi
}
src_test() {
@@ -198,17 +177,6 @@ src_install() {
doins -r examples/charm++/*
docompress -x /usr/share/doc/${PF}/examples
fi
-
- # Install pdf/html docs
- if use doc; then
- cd "${S}/doc/charm++"
- # Install pdfs.
- insinto /usr/share/doc/${PF}/pdf
- doins *.pdf
- # Install html.
- docinto html
- dohtml -r manual/*
- fi
}
pkg_postinst() {