summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libbytesize/files/libbytesize-2.4-no_Werror.patch24
-rw-r--r--dev-libs/libbytesize/libbytesize-2.3.ebuild11
-rw-r--r--dev-libs/libbytesize/libbytesize-2.4.ebuild11
3 files changed, 44 insertions, 2 deletions
diff --git a/dev-libs/libbytesize/files/libbytesize-2.4-no_Werror.patch b/dev-libs/libbytesize/files/libbytesize-2.4-no_Werror.patch
new file mode 100644
index 000000000000..827bebe3ec93
--- /dev/null
+++ b/dev-libs/libbytesize/files/libbytesize-2.4-no_Werror.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/744286
+
+--- libbytesize-2.4/configure.ac
++++ libbytesize-2.4/configure.ac
+@@ -6,7 +6,7 @@
+ # This needs to be set before initializing automake
+ AC_DISABLE_STATIC
+
+-AM_INIT_AUTOMAKE([foreign -Wall -Werror -Wno-syntax -Wno-portability])
++AM_INIT_AUTOMAKE([foreign -Wall -Wno-syntax -Wno-portability])
+ AC_CONFIG_MACRO_DIR([m4])
+
+ # Check for the gettext programs
+--- libbytesize-2.4/src/Makefile.am
++++ libbytesize-2.4/src/Makefile.am
+@@ -2,7 +2,7 @@
+ LDADD = $(LIBINTL)
+
+ lib_LTLIBRARIES = libbytesize.la
+-libbytesize_la_CFLAGS = -Wall -Wextra -Werror -Wno-overflow -D_GNU_SOURCE
++libbytesize_la_CFLAGS = -Wall -Wextra -Wno-overflow -D_GNU_SOURCE
+ libbytesize_la_LIBADD = -lgmp -lmpfr $(PCRE2_LIBS)
+ libbytesize_la_LDFLAGS = -version-info 1:0:0
+ libbytesize_la_SOURCES = bs_size.c bs_size.h gettext.h
diff --git a/dev-libs/libbytesize/libbytesize-2.3.ebuild b/dev-libs/libbytesize/libbytesize-2.3.ebuild
index bdb2d302c576..e63686f19435 100644
--- a/dev-libs/libbytesize/libbytesize-2.3.ebuild
+++ b/dev-libs/libbytesize/libbytesize-2.3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-r1
+inherit autotools python-r1
DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
HOMEPAGE="https://github.com/storaged-project/libbytesize"
@@ -42,6 +42,10 @@ DOCS=( README.md )
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4-no_Werror.patch"
+)
+
python_do() {
if use python; then
python_foreach_impl run_in_build_dir "$@"
@@ -50,6 +54,11 @@ python_do() {
fi
}
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local myeconfargs=(
$(use_with doc gtk-doc)
diff --git a/dev-libs/libbytesize/libbytesize-2.4.ebuild b/dev-libs/libbytesize/libbytesize-2.4.ebuild
index 0d91bc5f9998..7f18f969f367 100644
--- a/dev-libs/libbytesize/libbytesize-2.4.ebuild
+++ b/dev-libs/libbytesize/libbytesize-2.4.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-r1
+inherit autotools python-r1
DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
HOMEPAGE="https://github.com/storaged-project/libbytesize"
@@ -42,6 +42,10 @@ DOCS=( README.md )
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4-no_Werror.patch"
+)
+
python_do() {
if use python; then
python_foreach_impl run_in_build_dir "$@"
@@ -50,6 +54,11 @@ python_do() {
fi
}
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local myeconfargs=(
$(use_with doc gtk-doc)