summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/firefox/firefox-128.1.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/www-client/firefox/firefox-128.1.0.ebuild b/www-client/firefox/firefox-128.1.0.ebuild
index 38d8c7ad75b7..f88b0ca744a5 100644
--- a/www-client/firefox/firefox-128.1.0.ebuild
+++ b/www-client/firefox/firefox-128.1.0.ebuild
@@ -854,9 +854,10 @@ src_configure() {
mozconfig_add_options_ac '' --enable-sandbox
fi
- # Enable JIT on riscv64 explicitly
- # Can be removed once upstream enable it by default in the future.
- use riscv && mozconfig_add_options_ac 'Enable JIT for RISC-V 64' --enable-jit
+ # Enable JIT on riscv64 explicitly, since it's not activated automatically via "known arches" list.
+ # Update 128.1.0: Disable jit on riscv (this line can be blanked to disable by default),
+ # bgo#937867.
+ use riscv && mozconfig_add_options_ac 'Disable JIT for RISC-V 64' --disable-jit
if [[ -s "${S}/api-google.key" ]] ; then
local key_origin="Gentoo default"