summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pysmi/pysmi-0.3.4.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/pysmi/pysmi-0.3.4.ebuild b/dev-python/pysmi/pysmi-0.3.4.ebuild
index a25f52054908..b28efec48ddd 100644
--- a/dev-python/pysmi/pysmi-0.3.4.ebuild
+++ b/dev-python/pysmi/pysmi-0.3.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2017-2020 Gentoo Authors
+# Copyright 2017-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="Python Lex & Yacc"
@@ -15,4 +15,5 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest