summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-laptop/tuxedo-keyboard/Manifest1
-rw-r--r--app-laptop/tuxedo-keyboard/metadata.xml9
-rw-r--r--app-laptop/tuxedo-keyboard/tuxedo-keyboard-2.0.5.ebuild23
3 files changed, 33 insertions, 0 deletions
diff --git a/app-laptop/tuxedo-keyboard/Manifest b/app-laptop/tuxedo-keyboard/Manifest
new file mode 100644
index 000000000000..6f792af44007
--- /dev/null
+++ b/app-laptop/tuxedo-keyboard/Manifest
@@ -0,0 +1 @@
+DIST tuxedo-keyboard-2.0.5.tar.gz 31001 BLAKE2B 931d011e2ac521cef1670a8952886c1ac9b2476c6227c2b3cfce28d52622d3869f3c55773279eea3cbcc94d7c5b12d5d5653a8e2f9c142d0c044fa23fddd958c SHA512 3b7a9331d04e2918f3452f9561b05f39ea458960c2ade299a368899638987178cfd33fa066a0835f88b14c240d7937692d7994ccf978749ea7fdc428e587e06a
diff --git a/app-laptop/tuxedo-keyboard/metadata.xml b/app-laptop/tuxedo-keyboard/metadata.xml
new file mode 100644
index 000000000000..e42604230c16
--- /dev/null
+++ b/app-laptop/tuxedo-keyboard/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/app-laptop/tuxedo-keyboard/tuxedo-keyboard-2.0.5.ebuild b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-2.0.5.ebuild
new file mode 100644
index 000000000000..52e9192e8a9b
--- /dev/null
+++ b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-2.0.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod toolchain-funcs
+
+DESCRIPTION="Kernel Module for Tuxedo Keyboard"
+HOMEPAGE="https://github.com/tuxedocomputers/tuxedo-keyboard"
+SRC_URI="https://github.com/tuxedocomputers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BUILD_TARGETS="all"
+MODULE_NAMES="tuxedo_keyboard(tuxedo:${S}:src)"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KERN_DIR=${KV_DIR} KERN_VER=${KV_FULL} O=${KV_OUT_DIR} V=1 KBUILD_VERBOSE=1"
+}