summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/camlpdf/camlpdf-2.1.1.ebuild6
-rw-r--r--dev-ml/camlpdf/files/ocaml43.patch13
2 files changed, 18 insertions, 1 deletions
diff --git a/dev-ml/camlpdf/camlpdf-2.1.1.ebuild b/dev-ml/camlpdf/camlpdf-2.1.1.ebuild
index 83226661473c..8ba49799866b 100644
--- a/dev-ml/camlpdf/camlpdf-2.1.1.ebuild
+++ b/dev-ml/camlpdf/camlpdf-2.1.1.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit findlib
+inherit findlib eutils
DESCRIPTION="OCaml library for reading, writing, and modifying PDF files"
HOMEPAGE="https://github.com/johnwhitington/camlpdf/"
@@ -19,6 +19,10 @@ IUSE="doc examples"
RDEPEND="dev-lang/ocaml:="
DEPEND="${RDEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}/ocaml43.patch"
+}
+
src_compile() {
# parallel make bugs
emake -j1
diff --git a/dev-ml/camlpdf/files/ocaml43.patch b/dev-ml/camlpdf/files/ocaml43.patch
new file mode 100644
index 000000000000..86ffbe23eb14
--- /dev/null
+++ b/dev-ml/camlpdf/files/ocaml43.patch
@@ -0,0 +1,13 @@
+Index: camlpdf-2.1.1/flatestubs.c
+===================================================================
+--- camlpdf-2.1.1.orig/flatestubs.c
++++ camlpdf-2.1.1/flatestubs.c
+@@ -170,7 +170,7 @@ value camlzip_inflateEnd(value vzs)
+
+ value camlzip_update_crc32(value crc, value buf, value pos, value len)
+ {
+- return copy_int32(crc32((uint32) Int32_val(crc),
++ return copy_int32(crc32((uint32_t) Int32_val(crc),
+ &Byte_u(buf, Long_val(pos)),
+ Long_val(len)));
+ }