summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libmowgli/libmowgli-1.0.0-r1.ebuild15
-rw-r--r--dev-libs/libmowgli/libmowgli-9999.ebuild17
2 files changed, 25 insertions, 7 deletions
diff --git a/dev-libs/libmowgli/libmowgli-1.0.0-r1.ebuild b/dev-libs/libmowgli/libmowgli-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..f6bf87c430b5
--- /dev/null
+++ b/dev-libs/libmowgli/libmowgli-1.0.0-r1.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Useful set of performance and usability-oriented extensions to C"
+HOMEPAGE="http://atheme.org/projects/libmowgli.html"
+SRC_URI="http://distfiles.atheme.org/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DOCS=( AUTHORS README doc/BOOST )
diff --git a/dev-libs/libmowgli/libmowgli-9999.ebuild b/dev-libs/libmowgli/libmowgli-9999.ebuild
index 5450f37c16c5..bae567fb341c 100644
--- a/dev-libs/libmowgli/libmowgli-9999.ebuild
+++ b/dev-libs/libmowgli/libmowgli-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,18 +6,21 @@ EAPI=6
inherit git-r3
DESCRIPTION="Useful set of performance and usability-oriented extensions to C"
-HOMEPAGE="http://atheme.org/projects/libmowgli.html"
+HOMEPAGE="https://github.com/atheme/libmowgli-2"
EGIT_REPO_URI="https://github.com/atheme/libmowgli-2.git"
-IUSE="libressl ssl"
LICENSE="BSD-2"
SLOT="2"
KEYWORDS=""
-RDEPEND="ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
-)"
+IUSE="libressl ssl"
+
+RDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
DEPEND="${RDEPEND}"
+
DOCS=( AUTHORS README doc/BOOST doc/design-concepts.txt )
src_configure() {