summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/kadu/files/kadu-4.3-gcc7.patch10
-rw-r--r--net-im/kadu/kadu-4.3-r1.ebuild3
2 files changed, 12 insertions, 1 deletions
diff --git a/net-im/kadu/files/kadu-4.3-gcc7.patch b/net-im/kadu/files/kadu-4.3-gcc7.patch
new file mode 100644
index 000000000000..097157f98c77
--- /dev/null
+++ b/net-im/kadu/files/kadu-4.3-gcc7.patch
@@ -0,0 +1,10 @@
+--- a/kadu-core/plugin/dependency-graph/plugin-dependency-graph-builder.h
++++ b/kadu-core/plugin/dependency-graph/plugin-dependency-graph-builder.h
+@@ -20,6 +20,7 @@
+ #pragma once
+
+ #include <QtCore/QObject>
++#include <functional>
+ #include <map>
+ #include <set>
+
diff --git a/net-im/kadu/kadu-4.3-r1.ebuild b/net-im/kadu/kadu-4.3-r1.ebuild
index 64b44fa43c1a..5e1f571bbf74 100644
--- a/net-im/kadu/kadu-4.3-r1.ebuild
+++ b/net-im/kadu/kadu-4.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -103,6 +103,7 @@ word_fix
PATCHES=(
"${FILESDIR}/${PN}-4.3-do-not-force-ccache.patch"
"${FILESDIR}/${PN}-4.3-fix-plugins-rpath.patch"
+ "${FILESDIR}/${PN}-4.3-gcc7.patch"
)
src_configure() {