summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild
index c853264cb3dd..931329d094c9 100644
--- a/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit meson
+inherit flag-o-matic meson
DESCRIPTION="EGLStream-based Wayland external platform (for NVIDIA)"
HOMEPAGE="https://github.com/NVIDIA/egl-wayland"
@@ -26,6 +26,13 @@ PATCHES=(
"${FILESDIR}"/${P}-remove-werror.patch
)
+src_configure() {
+ # EGLStream is not intended for X11, always build without (bug #777558)
+ append-cppflags -DEGL_NO_X11
+
+ meson_src_configure
+}
+
src_install() {
meson_src_install