summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ada/xmlada/xmlada-23.0.0-r1.ebuild2
-rw-r--r--dev-ada/xmlada/xmlada-23.0.0.ebuild86
-rw-r--r--dev-python/Faker/Faker-18.2.0.ebuild34
-rw-r--r--dev-python/Faker/Manifest1
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/imageio-2.26.1.ebuild82
-rw-r--r--dev-python/pychromecast/pychromecast-13.0.4.ebuild17
-rw-r--r--dev-python/sh/Manifest1
-rw-r--r--dev-python/sh/sh-2.0.3.ebuild21
-rw-r--r--dev-python/zc-lockfile/zc-lockfile-3.0_p1.ebuild4
-rw-r--r--dev-python/zope-component/zope-component-5.1.0.ebuild4
-rw-r--r--dev-python/zope-configuration/zope-configuration-4.4.1-r2.ebuild4
-rw-r--r--dev-python/zope-deprecation/zope-deprecation-4.4.0-r2.ebuild4
-rw-r--r--dev-python/zope-event/zope-event-4.6.ebuild4
-rw-r--r--dev-python/zope-exceptions/zope-exceptions-4.6.ebuild4
-rw-r--r--dev-python/zope-hookable/zope-hookable-5.4.ebuild8
-rw-r--r--dev-python/zope-i18nmessageid/zope-i18nmessageid-5.1.1.ebuild4
-rw-r--r--dev-python/zope-interface/zope-interface-6.0.ebuild4
-rw-r--r--dev-python/zope-schema/zope-schema-7.0.1.ebuild4
-rw-r--r--dev-python/zope-testing/zope-testing-5.0.1.ebuild4
20 files changed, 174 insertions, 119 deletions
diff --git a/dev-ada/xmlada/xmlada-23.0.0-r1.ebuild b/dev-ada/xmlada/xmlada-23.0.0-r1.ebuild
index 67a8de7968c3..328b20e285c9 100644
--- a/dev-ada/xmlada/xmlada-23.0.0-r1.ebuild
+++ b/dev-ada/xmlada/xmlada-23.0.0-r1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
LICENSE="GPL-3"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="+shared static-libs static-pic"
REQUIRED_USE="|| ( shared static-libs static-pic )
${ADA_REQUIRED_USE}"
diff --git a/dev-ada/xmlada/xmlada-23.0.0.ebuild b/dev-ada/xmlada/xmlada-23.0.0.ebuild
deleted file mode 100644
index 6b274fccb9df..000000000000
--- a/dev-ada/xmlada/xmlada-23.0.0.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ADA_COMPAT=( gnat_2021 gcc_12_2_0 )
-inherit ada multiprocessing
-
-DESCRIPTION="Set of modules that provide a simple manipulation of XML streams"
-HOMEPAGE="http://libre.adacore.com/"
-SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0/${PV}"
-KEYWORDS="amd64 x86"
-IUSE="+shared static-libs static-pic"
-REQUIRED_USE="|| ( shared static-libs static-pic )
- ${ADA_REQUIRED_USE}"
-
-RDEPEND="${ADA_DEPS}"
-DEPEND="${RDEPEND}
- dev-ada/gprbuild[${ADA_USEDEP}]"
-
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
-
-src_compile() {
- build () {
- gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=$1 \
- -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
- -largs ${LDFLAGS} \
- -cargs ${ADAFLAGS} || die "gprbuild failed"
- }
- if use shared; then
- build relocatable
- fi
- if use static-libs; then
- build static
- fi
- if use static-pic; then
- build static-pic
- fi
-}
-
-src_test() {
- GPR_PROJECT_PATH=schema:input_sources:dom:sax:unicode \
- gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=static \
- -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
- -XTESTS_ACTIVATED=Only \
- -largs ${LDFLAGS} \
- -cargs ${ADAFLAGS} || die "gprbuild failed"
- emake --no-print-directory -C tests tests | tee xmlada.testLog
- grep -q DIFF xmlada.testLog && die
-}
-
-src_install() {
- build () {
- gprinstall -XLIBRARY_TYPE=$1 -f -p -XBUILD=Production \
- -XPROCESSORS=$(makeopts_jobs) --prefix="${D}"/usr \
- --install-name=xmlada --build-var=LIBRARY_TYPE \
- --build-var=XMLADA_BUILD \
- --build-name=$1 xmlada.gpr || die "gprinstall failed"
- }
- if use shared; then
- build relocatable
- fi
- if use static-libs; then
- build static
- fi
- if use static-pic; then
- build static-pic
- fi
-
- einstalldocs
- dodoc xmlada-roadmap.txt
- rm -rf "${D}"/usr/share/gpr/manifests
- rm -f "${D}"/usr/share/examples/xmlada/*/b__*
- rm -f "${D}"/usr/share/examples/xmlada/*/*.adb.std*
- rm -f "${D}"/usr/share/examples/xmlada/*/*.ali
- rm -f "${D}"/usr/share/examples/xmlada/*/*.bexch
- rm -f "${D}"/usr/share/examples/xmlada/*/*.o
- rm -f "${D}"/usr/share/examples/xmlada/*/*example
- rm -f "${D}"/usr/share/examples/xmlada/dom/domexample2
- rm -f "${D}"/usr/share/examples/xmlada/sax/saxexample_main
- mv "${D}"/usr/share/examples/xmlada "${D}"/usr/share/doc/"${PF}"/examples || die
-}
diff --git a/dev-python/Faker/Faker-18.2.0.ebuild b/dev-python/Faker/Faker-18.2.0.ebuild
new file mode 100644
index 000000000000..f1e5f5fe409a
--- /dev/null
+++ b/dev-python/Faker/Faker-18.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 210e578b64ed..f6c88f162f61 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1 +1,2 @@
DIST Faker-17.6.0.tar.gz 1654373 BLAKE2B 69a1d3bcd12188f7d9c0af61d57c62489434fc2fb6a4fea3c45a98d7395c3df83926d260672790d3b88f4b6bcf780e5b842e10b7efb500d503159869505bf4b2 SHA512 a879fb7e0c82693d4d3062b32382eb6d1f3c556c7d2e4c28168cba43c560bf17ebb84b94692ba7db738871251990feca8ccbf271c6e08c61847b76b84deb9680
+DIST Faker-18.2.0.tar.gz 1661956 BLAKE2B e8d7f9cc7cb5d5fd8fe9400311a54613557e072d504bd34944cffa777720484ec950854a6f7ddac8193afec560beaee86661a83a80b10de329db038f5a302d13 SHA512 799251ed4cffa0af3159856846f376bd0c0bb0233188cdcf72e7e5fdbb60841a56ca6ccd696c6a79d13f3dfb7a17e95b904c467d49d02eac4d1eeec6c89ef9f1
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index 7cfb08a63516..bd8c8d32b18e 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1,3 +1,4 @@
DIST imageio-2.26.0.gh.tar.gz 403652 BLAKE2B 2f1948b1cee03ef4fdd71489923a1ea5b0c364fb5f000d79e1d309042184a6bb267a323bd19fce85bf47857245eb4be5283f0b3df65857d7cac57c24930ea409 SHA512 6ad8ce0395033571c0d918dbe03ffeab0e43b29d402bc91a229d3ffd689eae3d01aa09dec386d03fe028f6138887883cfda4e0a769f523ba9f6c3e3041a0cb7f
+DIST imageio-2.26.1.gh.tar.gz 404916 BLAKE2B 683ffb38c089e691c9647785f28fed616e8b60795a05fa29a684d30fff35e6021888b4f4ea75d8035dbfc3c3f5e84c241eefdf7d4a08555bdf78de7433a1fc11 SHA512 90976423d967b7cd0874fcf6ed3c7d51db6fea450859a1a1a302aabb7d971b65cceec0fdaf8e23f99a3fcceaea827c090e01b4b7ad8e7813e8db33150c14ba29
DIST imageio-chelsea.png 221294 BLAKE2B 58537d7a1678fa5be4cc899e5bacd925bfc180eb4ae691330a53749a49ff544e979609b529ed27e5c1fc9efe4bc050ca1ce49b777f4016fb1d66affd926ef9d3 SHA512 48470cdb843eed4dfa6673811c09c5aac9869ee23dd36be0c6b653d9f108d61d21b148c2a4435aaa6604887ba030e5bbc5e35d378da876366445dfc2d0ba4e27
DIST imageio-cockatoo.mp4 728751 BLAKE2B 45b22cd517c1cb7c0cd12f8865facaca6a847047aea716e49633cf2b1dc13826f94787c8a8f9dd5f48c6a896f5d37794c0058da1bde9e1469f196916476dbfa2 SHA512 e9cb7c25de8019c59ba4090cf10ab29f2b5d62ada37a877081ca07d2ecfe010036222ae843b41bbcc843130d97fa5e14421de252639e9481df1d1c27b19add49
diff --git a/dev-python/imageio/imageio-2.26.1.ebuild b/dev-python/imageio/imageio-2.26.1.ebuild
new file mode 100644
index 000000000000..30875e33909b
--- /dev/null
+++ b/dev-python/imageio/imageio-2.26.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+BIN_COMMIT=224074bca448815e421a59266864c23041531a42
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="
+ https://imageio.readthedocs.io/en/stable/
+ https://github.com/imageio/imageio/
+ https://pypi.org/project/imageio/
+"
+SRC_URI="
+ https://github.com/imageio/imageio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/imageio/imageio-binaries/raw/${BIN_COMMIT}/images/chelsea.png
+ -> ${PN}-chelsea.png
+ https://github.com/imageio/imageio-binaries/raw/${BIN_COMMIT}/images/cockatoo.mp4
+ -> ${PN}-cockatoo.mp4
+ )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# over 50% of tests rely on Internet
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+# requests for fsspec[github]
+BDEPEND="
+ test? (
+ dev-python/fsspec[${PYTHON_USEDEP}]
+ dev-python/imageio-ffmpeg[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tifffile[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ local PATCHES=(
+ # block silently downloading vulnerable libraries from the Internet
+ "${FILESDIR}"/imageio-2.22.0-block-download.patch
+ )
+
+ if use test; then
+ mkdir -p "${HOME}"/.imageio/images || die
+ local i
+ for i in chelsea.png cockatoo.mp4; do
+ cp "${DISTDIR}/${PN}-${i}" "${HOME}/.imageio/images/${i}" || die
+ done
+ fi
+
+ distutils-r1_src_prepare
+}
+
+EPYTEST_DESELECT=(
+ # Fails because of system installed freeimage
+ tests/test_core.py::test_findlib2
+ # Tries to download ffmpeg binary ?!
+ tests/test_ffmpeg.py::test_get_exe_installed
+ # blocked by our patch
+ tests/test_core.py::test_fetching
+ tests/test_core.py::test_request
+ # known broken
+ # https://github.com/imageio/imageio/issues/890
+ tests/test_freeimage.py::test_exr_write
+)
diff --git a/dev-python/pychromecast/pychromecast-13.0.4.ebuild b/dev-python/pychromecast/pychromecast-13.0.4.ebuild
index 60fbf00b21ea..bd0d54534c96 100644
--- a/dev-python/pychromecast/pychromecast-13.0.4.ebuild
+++ b/dev-python/pychromecast/pychromecast-13.0.4.ebuild
@@ -3,14 +3,18 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
+PYPI_NO_NORMALIZE=1
+PYPI_PN=PyChromecast
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1 pypi
DESCRIPTION="Python module to talk to Google Chromecast"
-HOMEPAGE="https://github.com/home-assistant-libs/pychromecast"
-S="${WORKDIR}/PyChromecast-${PV}"
-SRC_URI="mirror://pypi/P/PyChromecast/PyChromecast-${PV}.tar.gz"
+HOMEPAGE="
+ https://github.com/home-assistant-libs/pychromecast/
+ https://pypi.org/project/PyChromecast/
+"
LICENSE="MIT"
SLOT="0"
@@ -19,4 +23,5 @@ KEYWORDS="amd64 x86"
RDEPEND="
>=dev-python/casttube-0.2.0[${PYTHON_USEDEP}]
>=dev-python/protobuf-python-3.19.1[${PYTHON_USEDEP}]
- >=dev-python/zeroconf-0.25.1[${PYTHON_USEDEP}]"
+ >=dev-python/zeroconf-0.25.1[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/sh/Manifest b/dev-python/sh/Manifest
index 8148c073e766..8d9b3d0d8a3d 100644
--- a/dev-python/sh/Manifest
+++ b/dev-python/sh/Manifest
@@ -1 +1,2 @@
DIST sh-2.0.2.tar.gz 345351 BLAKE2B 7b1cd213f097b0893b96fbe7c5dd96a3716b6e8fcac5da49a091bbeb4f75ea2c9f7a23237d91e1a6df9fe2c1ba8ea778dad505981cfcc1ef1893404cdb030500 SHA512 dc02a69366d1140112ccf26093bbfd7d719671caf5dd6e093a5f7ef9de3428b44e9aa539e857ef72981a688cb4b40eb47aa2060c18e6074b614a1a5c2c430d83
+DIST sh-2.0.3.tar.gz 345365 BLAKE2B f818f84c71992fcfb653b757872da89a0007a873c639b3b0438a794bdfbd455e2ac22ef035b657b35da23e6890761ce7f161a02e3e0f847ee5209cec5fe911a4 SHA512 4d3bc20b2175b2507f0081af0b83faaf5eb97d131a24abaafb333a56e45d2cdb9167c3568bb40c6a6ea79b9836e335cb0d5bec2d036ce619eb312916d69fa72d
diff --git a/dev-python/sh/sh-2.0.3.ebuild b/dev-python/sh/sh-2.0.3.ebuild
new file mode 100644
index 000000000000..e05aec059c1e
--- /dev/null
+++ b/dev-python/sh/sh-2.0.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="
+ https://github.com/amoffat/sh/
+ https://pypi.org/project/sh/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests unittest
diff --git a/dev-python/zc-lockfile/zc-lockfile-3.0_p1.ebuild b/dev-python/zc-lockfile/zc-lockfile-3.0_p1.ebuild
index db027ffcd598..7a435eac5dfe 100644
--- a/dev-python/zc-lockfile/zc-lockfile-3.0_p1.ebuild
+++ b/dev-python/zc-lockfile/zc-lockfile-3.0_p1.ebuild
@@ -4,6 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
PYTHON_COMPAT=( python3_{9..11} pypy3 )
inherit distutils-r1 pypi
@@ -13,8 +15,6 @@ HOMEPAGE="
https://github.com/zopefoundation/zc.lockfile/
https://pypi.org/project/zc.lockfile/
"
-SRC_URI="$(pypi_sdist_url --no-normalize "${PN/-/.}")"
-S=${WORKDIR}/${PN/-/.}-${PV/_p/.post}
LICENSE="ZPL"
SLOT="0"
diff --git a/dev-python/zope-component/zope-component-5.1.0.ebuild b/dev-python/zope-component/zope-component-5.1.0.ebuild
index 62c89b36eddd..ce60a9d8260d 100644
--- a/dev-python/zope-component/zope-component-5.1.0.ebuild
+++ b/dev-python/zope-component/zope-component-5.1.0.ebuild
@@ -4,6 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 pypi
@@ -13,8 +15,6 @@ HOMEPAGE="
https://pypi.org/project/zope.component/
https://github.com/zopefoundation/zope.component/
"
-SRC_URI="$(pypi_sdist_url --no-normalize "${PN/-/.}")"
-S=${WORKDIR}/${P/-/.}
LICENSE="ZPL"
SLOT="0"
diff --git a/dev-python/zope-configuration/zope-configuration-4.4.1-r2.ebuild b/dev-python/zope-configuration/zope-configuration-4.4.1-r2.ebuild
index 429f753d9587..8da5c016419b 100644
--- a/dev-python/zope-configuration/zope-configuration-4.4.1-r2.ebuild
+++ b/dev-python/zope-configuration/zope-configuration-4.4.1-r2.ebuild
@@ -4,6 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 pypi
@@ -14,8 +16,6 @@ HOMEPAGE="
https://github.com/zopefoundation/zope.configuration/
https://zopeconfiguration.readthedocs.io/en/latest/
"
-SRC_URI="$(pypi_sdist_url --no-normalize "${PN/-/.}")"
-S=${WORKDIR}/${P/-/.}
LICENSE="ZPL"
SLOT="0"
diff --git a/dev-python/zope-deprecation/zope-deprecation-4.4.0-r2.ebuild b/dev-python/zope-deprecation/zope-deprecation-4.4.0-r2.ebuild
index 5204ed4ef0c0..65881298bae8 100644
--- a/dev-python/zope-deprecation/zope-deprecation-4.4.0-r2.ebuild
+++ b/dev-python/zope-deprecation/zope-deprecation-4.4.0-r2.ebuild
@@ -4,6 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
PYTHON_COMPAT=( python3_{9..11} pypy3 )
inherit distutils-r1 pypi
@@ -13,8 +15,6 @@ HOMEPAGE="
https://pypi.org/project/zope.deprecation/
https://github.com/zopefoundation/zope.deprecation/
"
-SRC_URI="$(pypi_sdist_url --no-normalize "${PN/-/.}")"
-S=${WORKDIR}/${P/-/.}
LICENSE="ZPL"
SLOT="0"
diff --git a/dev-python/zope-event/zope-event-4.6.ebuild b/dev-python/zope-event/zope-event-4.6.ebuild
index 18e2eec4af9a..3f9089dc2625 100644
--- a/dev-python/zope-event/zope-event-4.6.ebuild
+++ b/dev-python/zope-event/zope-event-4.6.ebuild
@@ -4,6 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
PYTHON_COMPAT=( python3_{9..11} pypy3 )
inherit distutils-r1 pypi
@@ -13,8 +15,6 @@ HOMEPAGE="
https://pypi.org/project/zope.event/
https://github.com/zopefoundation/zope.event/
"
-SRC_URI="$(pypi_sdist_url --no-normalize "${PN/-/.}")"
-S=${WORKDIR}/${P/-/.}
LICENSE="ZPL"
SLOT="0"
diff --git a/dev-python/zope-exceptions/zope-exceptions-4.6.ebuild b/dev-python/zope-exceptions/zope-exceptions-4.6.ebuild
index 55d8d703c531..dfe63480f383 100644
--- a/dev-python/zope-exceptions/zope-exceptions-4.6.ebuild
+++ b/dev-python/zope-exceptions/zope-exceptions-4.6.ebuild
@@ -4,6 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
PYTHON_COMPAT=( python3_{9..11} pypy3 )
inherit distutils-r1 pypi
@@ -13,8 +15,6 @@ HOMEPAGE="
https://pypi.org/project/zope.exceptions/
https://github.com/zopefoundation/zope.exceptions/
"
-SRC_URI="$(pypi_sdist_url --no-normalize "${PN/-/.}")"
-S=${WORKDIR}/${P/-/.}
LICENSE="ZPL"
SLOT="0"
diff --git a/dev-python/zope-hookable/zope-hookable-5.4.ebuild b/dev-python/zope-hookable/zope-hookable-5.4.ebuild
index 79b926d6e252..98c7d3214033 100644
--- a/dev-python/zope-hookable/zope-hookable-5.4.ebuild
+++ b/dev-python/zope-hookable/zope-hookable-5.4.ebuild
@@ -4,6 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 pypi
@@ -13,12 +15,6 @@ HOMEPAGE="
https://pypi.org/project/zope.hookable/
https://github.com/zopefoundation/zope.hookable/
"
-SRC_URI="
- https://github.com/zopefoundation/zope.hookable/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-SRC_URI="$(pypi_sdist_url --no-normalize "${PN/-/.}")"
-S=${WORKDIR}/${P/-/.}
LICENSE="ZPL"
SLOT="0"
diff --git a/dev-python/zope-i18nmessageid/zope-i18nmessageid-5.1.1.ebuild b/dev-python/zope-i18nmessageid/zope-i18nmessageid-5.1.1.ebuild
index a8dfb51618a9..0e68b5c7c893 100644
--- a/dev-python/zope-i18nmessageid/zope-i18nmessageid-5.1.1.ebuild
+++ b/dev-python/zope-i18nmessageid/zope-i18nmessageid-5.1.1.ebuild
@@ -4,6 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
PYTHON_COMPAT=( python3_{9..11} pypy3 )
inherit distutils-r1 pypi
@@ -13,8 +15,6 @@ HOMEPAGE="
https://pypi.org/project/zope.i18nmessageid/
https://github.com/zopefoundation/zope.i18nmessageid/
"
-SRC_URI="$(pypi_sdist_url --no-normalize "${PN/-/.}")"
-S=${WORKDIR}/${P/-/.}
LICENSE="ZPL"
SLOT="0"
diff --git a/dev-python/zope-interface/zope-interface-6.0.ebuild b/dev-python/zope-interface/zope-interface-6.0.ebuild
index 71c1fab1a966..9e89f69efab2 100644
--- a/dev-python/zope-interface/zope-interface-6.0.ebuild
+++ b/dev-python/zope-interface/zope-interface-6.0.ebuild
@@ -4,6 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
PYTHON_COMPAT=( python3_{9..11} pypy3 )
inherit distutils-r1 pypi
@@ -13,8 +15,6 @@ HOMEPAGE="
https://github.com/zopefoundation/zope.interface/
https://pypi.org/project/zope.interface/
"
-SRC_URI="$(pypi_sdist_url --no-normalize "${PN/-/.}")"
-S=${WORKDIR}/${P/-/.}
LICENSE="ZPL"
SLOT="0"
diff --git a/dev-python/zope-schema/zope-schema-7.0.1.ebuild b/dev-python/zope-schema/zope-schema-7.0.1.ebuild
index 9bc480a73519..6ff494d3e0f2 100644
--- a/dev-python/zope-schema/zope-schema-7.0.1.ebuild
+++ b/dev-python/zope-schema/zope-schema-7.0.1.ebuild
@@ -4,6 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
PYTHON_COMPAT=( python3_{9..11} pypy3 )
inherit distutils-r1 pypi
@@ -13,8 +15,6 @@ HOMEPAGE="
https://pypi.org/project/zope.schema/
https://github.com/zopefoundation/zope.schema/
"
-SRC_URI="$(pypi_sdist_url --no-normalize "${PN/-/.}")"
-S=${WORKDIR}/${P/-/.}
LICENSE="ZPL"
SLOT="0"
diff --git a/dev-python/zope-testing/zope-testing-5.0.1.ebuild b/dev-python/zope-testing/zope-testing-5.0.1.ebuild
index 0111e1a87bf7..e73c26009fbb 100644
--- a/dev-python/zope-testing/zope-testing-5.0.1.ebuild
+++ b/dev-python/zope-testing/zope-testing-5.0.1.ebuild
@@ -4,6 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
PYTHON_COMPAT=( python3_{9..11} pypy3 )
inherit distutils-r1 pypi
@@ -13,8 +15,6 @@ HOMEPAGE="
https://pypi.org/project/zope.testing/
https://github.com/zopefoundation/zope.testing/
"
-SRC_URI="$(pypi_sdist_url --no-normalize "${PN/-/.}")"
-S=${WORKDIR}/${P/-/.}
LICENSE="ZPL"
SLOT="0"