summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/virtualbox/virtualbox-6.1.32-r3.ebuild (renamed from app-emulation/virtualbox/virtualbox-6.1.32-r2.ebuild)17
-rw-r--r--app-emulation/virtualbox/virtualbox-6.1.34-r7.ebuild (renamed from app-emulation/virtualbox/virtualbox-6.1.34-r6.ebuild)17
-rw-r--r--app-emulation/virtualbox/virtualbox-6.1.36.ebuild17
-rw-r--r--dev-cpp/valijson/Manifest2
-rw-r--r--dev-cpp/valijson/valijson-0.7.ebuild (renamed from dev-cpp/valijson/valijson-0.6.ebuild)4
-rw-r--r--dev-java/commons-codec/commons-codec-1.15.ebuild50
-rw-r--r--dev-java/commons-collections/commons-collections-4.4.ebuild67
-rw-r--r--dev-java/commons-io/commons-io-2.11.0.ebuild55
-rw-r--r--dev-java/commons-math/Manifest1
-rw-r--r--dev-java/commons-math/commons-math-3.6.1-r1.ebuild24
-rw-r--r--dev-java/jackson-module-jakarta-xmlbind/jackson-module-jakarta-xmlbind-2.13.3.ebuild81
-rw-r--r--dev-java/jnr-netdb/Manifest1
-rw-r--r--dev-java/jnr-netdb/files/jnr-netdb_maven-build.xml231
-rw-r--r--dev-java/jnr-netdb/jnr-netdb-1.1.4-r1.ebuild55
-rw-r--r--dev-java/poi/Manifest1
-rw-r--r--dev-java/poi/poi-5.0.0.ebuild64
-rw-r--r--dev-java/typesafe-config/Manifest1
-rw-r--r--dev-java/typesafe-config/typesafe-config-1.3.0-r3.ebuild21
18 files changed, 35 insertions, 674 deletions
diff --git a/app-emulation/virtualbox/virtualbox-6.1.32-r2.ebuild b/app-emulation/virtualbox/virtualbox-6.1.32-r3.ebuild
index 96494cca02e5..722a6987c670 100644
--- a/app-emulation/virtualbox/virtualbox-6.1.32-r2.ebuild
+++ b/app-emulation/virtualbox/virtualbox-6.1.32-r3.ebuild
@@ -21,7 +21,7 @@ LICENSE="GPL-2 dtrace? ( CDDL )"
SLOT="0/$(ver_cut 1-2)"
[[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
KEYWORDS="amd64"
-IUSE="alsa debug doc dtrace headless java lvm +opus pam pax-kernel pch pulseaudio +opengl python +qt5 +sdk +udev vboxwebsrv vnc"
+IUSE="alsa debug doc dtrace headless java lvm +opus pam pax-kernel pch pulseaudio +opengl python +qt5 +sdk +sdl +udev vboxwebsrv vnc"
COMMON_DEPEND="
${PYTHON_DEPS}
@@ -36,7 +36,7 @@ COMMON_DEPEND="
media-libs/libvpx:0=
sys-libs/zlib:=
!headless? (
- media-libs/libsdl:0[X,video]
+ sdl? ( media-libs/libsdl:0[X,video] )
x11-libs/libX11
x11-libs/libxcb:=
x11-libs/libXcursor
@@ -253,6 +253,7 @@ src_configure() {
if ! use headless ; then
myconf+=(
$(usex opengl '' --disable-opengl)
+ $(usex sdl '' --disable-sdl)
$(usex qt5 '' --disable-qt)
)
else
@@ -360,12 +361,14 @@ src_install() {
if ! use headless ; then
vbox_inst rdesktop-vrdp
- vbox_inst VBoxSDL 4750
- pax-mark -m "${ED}"${vbox_inst_path}/VBoxSDL
+ if use sdl ; then
+ vbox_inst VBoxSDL 4750
+ pax-mark -m "${ED}"${vbox_inst_path}/VBoxSDL
- for each in vboxsdl VBoxSDL ; do
- dosym ${vbox_inst_path}/VBox /usr/bin/${each}
- done
+ for each in vboxsdl VBoxSDL ; do
+ dosym ${vbox_inst_path}/VBox /usr/bin/${each}
+ done
+ fi
if use qt5 ; then
vbox_inst VirtualBox
diff --git a/app-emulation/virtualbox/virtualbox-6.1.34-r6.ebuild b/app-emulation/virtualbox/virtualbox-6.1.34-r7.ebuild
index 7e63e28a4679..b18a640616f9 100644
--- a/app-emulation/virtualbox/virtualbox-6.1.34-r6.ebuild
+++ b/app-emulation/virtualbox/virtualbox-6.1.34-r7.ebuild
@@ -36,7 +36,7 @@ SLOT="0/$(ver_cut 1-2)"
if [[ ${PV} != *_beta* ]] && [[ ${PV} != *_rc* ]] ; then
KEYWORDS="amd64"
fi
-IUSE="alsa debug doc dtrace headless java lvm +opus pam pax-kernel pch pulseaudio +opengl python +qt5 +sdk +udev vboxwebsrv vnc"
+IUSE="alsa debug doc dtrace headless java lvm +opus pam pax-kernel pch pulseaudio +opengl python +qt5 +sdk +sdl +udev vboxwebsrv vnc"
REQUIRED_USE="
java? ( sdk )
@@ -58,7 +58,7 @@ COMMON_DEPEND="
media-libs/libvpx:0=
sys-libs/zlib:=
!headless? (
- media-libs/libsdl:0[X,video]
+ sdl? ( media-libs/libsdl:0[X,video] )
x11-libs/libX11
x11-libs/libxcb:=
x11-libs/libXcursor
@@ -287,6 +287,7 @@ src_configure() {
if ! use headless ; then
myconf+=(
$(usex opengl '' --disable-opengl)
+ $(usex sdl '' --disable-sdl)
$(usex qt5 '' --disable-qt)
)
else
@@ -475,12 +476,14 @@ src_install() {
if ! use headless ; then
vbox_inst rdesktop-vrdp
- vbox_inst VBoxSDL 4750
- pax-mark -m "${ED}"${vbox_inst_path}/VBoxSDL
+ if use sdl ; then
+ vbox_inst VBoxSDL 4750
+ pax-mark -m "${ED}"${vbox_inst_path}/VBoxSDL
- for each in vboxsdl VBoxSDL ; do
- dosym ${vbox_inst_path}/VBox /usr/bin/${each}
- done
+ for each in vboxsdl VBoxSDL ; do
+ dosym ${vbox_inst_path}/VBox /usr/bin/${each}
+ done
+ fi
if use qt5 ; then
vbox_inst VirtualBox
diff --git a/app-emulation/virtualbox/virtualbox-6.1.36.ebuild b/app-emulation/virtualbox/virtualbox-6.1.36.ebuild
index 19b363fc34f3..db6bcc8ca893 100644
--- a/app-emulation/virtualbox/virtualbox-6.1.36.ebuild
+++ b/app-emulation/virtualbox/virtualbox-6.1.36.ebuild
@@ -36,7 +36,7 @@ SLOT="0/$(ver_cut 1-2)"
if [[ ${PV} != *_beta* ]] && [[ ${PV} != *_rc* ]] ; then
KEYWORDS="~amd64"
fi
-IUSE="alsa debug doc dtrace headless java lvm +opus pam pax-kernel pch pulseaudio +opengl python +qt5 +sdk +udev vboxwebsrv vnc"
+IUSE="alsa debug doc dtrace headless java lvm +opus pam pax-kernel pch pulseaudio +opengl python +qt5 +sdk +sdl +udev vboxwebsrv vnc"
unset WATCOM #856769
@@ -52,7 +52,7 @@ COMMON_DEPEND="
media-libs/libvpx:0=
sys-libs/zlib:=
!headless? (
- media-libs/libsdl:0[X,video]
+ sdl? ( media-libs/libsdl:0[X,video] )
x11-libs/libX11
x11-libs/libxcb:=
x11-libs/libXcursor
@@ -285,6 +285,7 @@ src_configure() {
if ! use headless ; then
myconf+=(
$(usex opengl '' --disable-opengl)
+ $(usex sdl '' --disable-sdl)
$(usex qt5 '' --disable-qt)
)
else
@@ -480,12 +481,14 @@ src_install() {
if ! use headless ; then
vbox_inst rdesktop-vrdp
- vbox_inst VBoxSDL 4750
- pax-mark -m "${ED}"${vbox_inst_path}/VBoxSDL
+ if use sdl ; then
+ vbox_inst VBoxSDL 4750
+ pax-mark -m "${ED}"${vbox_inst_path}/VBoxSDL
- for each in vboxsdl VBoxSDL ; do
- dosym ${vbox_inst_path}/VBox /usr/bin/${each}
- done
+ for each in vboxsdl VBoxSDL ; do
+ dosym ${vbox_inst_path}/VBox /usr/bin/${each}
+ done
+ fi
if use qt5 ; then
vbox_inst VirtualBox
diff --git a/dev-cpp/valijson/Manifest b/dev-cpp/valijson/Manifest
index ab196e007f5b..7c45f2998533 100644
--- a/dev-cpp/valijson/Manifest
+++ b/dev-cpp/valijson/Manifest
@@ -1 +1 @@
-DIST valijson-0.6.tar.gz 1881386 BLAKE2B 1dd7783e10f7d362673bd2b80920c911cca194068078ac1411897b212600032bc15ffe10dbb62c27e54d168a1c634d73ee40b394e4d534e72224694ec662e0a6 SHA512 a493d17159e479be7fe29d45c610c7d4fdd2c2f9ba897923129734fb07257dbb41fddde4c4263dbf0aa5c7101cd1555568a048beba2f60d2b32e625dd9690749
+DIST valijson-0.7.tar.gz 2060214 BLAKE2B d2e1c58e37213e44d7d6af173691cad3853e87648948c229ea683bfcba8b19256b0230852b0537c2dbdd7084fcf1ac068e320c5f59a69e446610390b82e76474 SHA512 662e53bf1cac4def19792392cda7cbfe2cbadf77b768eb69b2dec693b16f85f32fa2e9b97eae36569cfcc9ac45f1e6338967423cf415d6bcd90372bc49793a2d
diff --git a/dev-cpp/valijson/valijson-0.6.ebuild b/dev-cpp/valijson/valijson-0.7.ebuild
index 879b255f1760..52fc96a2bad8 100644
--- a/dev-cpp/valijson/valijson-0.6.ebuild
+++ b/dev-cpp/valijson/valijson-0.7.ebuild
@@ -21,11 +21,15 @@ src_configure() {
)
if use test; then
+ # Fix relative paths to test data
sed -i -e "s:../tests/data/documents/:../${P}/tests/data/documents/:" tests/test_adapter_comparison.cpp || die
sed -i -e "s:../tests/data:../${P}/tests/data:" tests/test_validation_errors.cpp || die
sed -i -e "s:../thirdparty/:../${P}/thirdparty/:" -e "s:../doc/schema/:../${P}/doc/schema/:" tests/test_validator.cpp || die
fi
+ # -Werror is too aggressive due to false positives with gcc-12, see bug #866153
+ sed -i -e 's/-Werror//g' ../${P}/CMakeLists.txt || die
+
cmake_src_configure
}
diff --git a/dev-java/commons-codec/commons-codec-1.15.ebuild b/dev-java/commons-codec/commons-codec-1.15.ebuild
deleted file mode 100644
index 88e15404828e..000000000000
--- a/dev-java/commons-codec/commons-codec-1.15.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom commons-codec-1.15-src/pom.xml --download-uri https://apache.osuosl.org/commons/codec/source/commons-codec-1.15-src.tar.gz --slot 0 --keywords "~amd64 ~ppc64 ~x86" --ebuild commons-codec-1.15.ebuild
-
-EAPI=7
-
-JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="commons-codec:commons-codec:1.15"
-JAVA_TESTING_FRAMEWORKS="junit-4"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Implementations of common encoders and decoders in Java"
-HOMEPAGE="https://commons.apache.org/proper/commons-codec/"
-SRC_URI="mirror://apache/commons/codec/source/${P}-src.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86 ~amd64-linux ~x86-linux"
-
-# Compile dependencies
-# POM: ${P}-src/pom.xml
-# test? junit:junit:4.13 -> >=dev-java/junit-4.13.1:4
-# test? org.apache.commons:commons-lang3:3.8 -> >=dev-java/commons-lang-3.11:3.6
-
-DEPEND="
- >=virtual/jdk-1.8:*
- test? (
- >=dev-java/commons-lang-3.11:3.6
- )
-"
-
-RDEPEND="
- >=virtual/jre-1.8:*
-"
-
-S="${WORKDIR}/${P}-src"
-
-JAVA_SRC_DIR="src/main/java"
-JAVA_RESOURCE_DIRS=(
- "src/main/resources"
-)
-
-JAVA_TEST_GENTOO_CLASSPATH="junit-4,commons-lang-3.6"
-JAVA_TEST_SRC_DIR="src/test/java"
-JAVA_TEST_RESOURCE_DIRS=(
- "src/test/resources"
-)
diff --git a/dev-java/commons-collections/commons-collections-4.4.ebuild b/dev-java/commons-collections/commons-collections-4.4.ebuild
deleted file mode 100644
index b843e427b13b..000000000000
--- a/dev-java/commons-collections/commons-collections-4.4.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri mirror://apache/commons/collections/source/commons-collections4-4.4-src.tar.gz --slot 4 --keywords "~amd64 ~arm64 ~ppc64 ~x86" --ebuild commons-collections-4.4.ebuild
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="org.apache.commons:commons-collections4:4.4"
-JAVA_TESTING_FRAMEWORKS="junit-4"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Extends the JCF classes with new interfaces, implementations and utilities"
-HOMEPAGE="https://commons.apache.org/proper/commons-collections/"
-SRC_URI="mirror://apache/commons/collections/source/${PN}4-${PV}-src.tar.gz -> ${P}-src.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="4"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-
-# Compile dependencies
-# POM: pom.xml
-# test? junit:junit:4.12 -> >=dev-java/junit-4.13.2:4
-# test? org.apache.commons:commons-lang3:3.9 -> >=dev-java/commons-lang-3.12.0:3.6
-# test? org.easymock:easymock:4.0.2 -> !!!suitable-mavenVersion-not-found!!!
-
-DEPEND="
- >=virtual/jdk-1.8:*
- test? (
- dev-java/easymock:3.2
- dev-java/commons-lang:3.6
- )
-"
-
-RDEPEND="
- >=virtual/jre-1.8:*
-"
-
-DOCS=( {CONTRIBUTING,README}.md {LICENSE,NOTICE,RELEASE-NOTES}.txt )
-HTML_DOCS=( {DEVELOPERS-GUIDE,PROPOSAL}.html )
-
-S="${WORKDIR}/commons-collections4-${PV}-src"
-
-JAVA_SRC_DIR="src/main/java"
-
-JAVA_TEST_GENTOO_CLASSPATH="junit-4,commons-lang-3.6,easymock-3.2"
-JAVA_TEST_SRC_DIR="src/test/java"
-JAVA_TEST_RESOURCE_DIRS="src/test/resources"
-
-src_test() {
- # https://github.com/apache/commons-collections/blob/cab58b3a8093a2f6b84f12783a3fb358747310f7/pom.xml#L542-L550
- pushd src/test/java || die
- local TESTS=$(find * -name "*Test.java" ! -name "TestUtils.java" ! -name "Abstract*.java" ! -name "BulkTest.java")
- TESTS="${TESTS//.java}"
- TESTS="${TESTS//\//.}"
- popd
-
- JAVA_TEST_RUN_ONLY=( "${TESTS}" )
- java-pkg-simple_src_test
-}
-
-src_install() {
- default # https://bugs.gentoo.org/789582
- java-pkg-simple_src_install
-}
diff --git a/dev-java/commons-io/commons-io-2.11.0.ebuild b/dev-java/commons-io/commons-io-2.11.0.ebuild
deleted file mode 100644
index f6f4b5f8feb0..000000000000
--- a/dev-java/commons-io/commons-io-2.11.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://mirror.dkm.cz/apache//commons/io/source/commons-io-2.11.0-src.tar.gz --slot 0 --keywords "~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris" --ebuild commons-io-2.11.0.ebuild
-
-EAPI=7
-
-JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="commons-io:commons-io:2.11.0"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Utility classes, stream implementations, file filters, and much more"
-HOMEPAGE="https://commons.apache.org/proper/commons-io/"
-SRC_URI="mirror://apache/commons/io/source/${P}-src.tar.gz -> ${P}-sources.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="1"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-
-# Compile dependencies
-# POM: pom.xml
-# test? com.google.jimfs:jimfs:1.2 -> !!!groupId-not-found!!!
-# test? org.apache.commons:commons-lang3:3.12.0 -> >=dev-java/commons-lang-3.12.0:3.6
-# test? org.junit-pioneer:junit-pioneer:1.4.2 -> !!!groupId-not-found!!!
-# test? org.junit.jupiter:junit-jupiter:5.7.2 -> !!!groupId-not-found!!!
-# test? org.mockito:mockito-inline:3.11.2 -> !!!artifactId-not-found!!!
-# test? org.openjdk.jmh:jmh-core:1.32 -> !!!groupId-not-found!!!
-# test? org.openjdk.jmh:jmh-generator-annprocess:1.32 -> !!!groupId-not-found!!!
-
-DEPEND="
- >=virtual/jdk-1.8:*
- test? (
- >=dev-java/commons-lang-3.12.0:3.6
- )
-"
-
-RDEPEND="
- >=virtual/jre-1.8:*
-"
-
-# some test dependencies are missing
-RESTRICT="test"
-
-S="${WORKDIR}/${P}-src"
-
-JAVA_ENCODING="iso-8859-1"
-
-JAVA_SRC_DIR="src/main/java"
-
-JAVA_TEST_GENTOO_CLASSPATH="commons-lang-3.6"
-JAVA_TEST_SRC_DIR="src/test/java"
-JAVA_TEST_RESOURCE_DIRS=(
- "src/test/resources"
-)
diff --git a/dev-java/commons-math/Manifest b/dev-java/commons-math/Manifest
index 6e97211d4920..bf6297cec518 100644
--- a/dev-java/commons-math/Manifest
+++ b/dev-java/commons-math/Manifest
@@ -1,2 +1 @@
DIST commons-math3-3.6.1-sources.jar 2514690 BLAKE2B ce5dc1a5bdccf85aa780dd648b64c0ed78b4d5a36d15d9737f661135f4f1ec962c3c44a0c4d8fc7d12c667e62b19860cb2a47f507c8c3e6da6cce57e1b9caf54 SHA512 eab6003834c0f1b7e67eee242d33db43f85d388ac32e37caa6bd16d74340db5c189ff5c7fd112ef13b9009d2fbcf2bad6650b6e5d9124316b59493b2d07d065d
-DIST commons-math3-3.6.1.jar 2514690 BLAKE2B ce5dc1a5bdccf85aa780dd648b64c0ed78b4d5a36d15d9737f661135f4f1ec962c3c44a0c4d8fc7d12c667e62b19860cb2a47f507c8c3e6da6cce57e1b9caf54 SHA512 eab6003834c0f1b7e67eee242d33db43f85d388ac32e37caa6bd16d74340db5c189ff5c7fd112ef13b9009d2fbcf2bad6650b6e5d9124316b59493b2d07d065d
diff --git a/dev-java/commons-math/commons-math-3.6.1-r1.ebuild b/dev-java/commons-math/commons-math-3.6.1-r1.ebuild
deleted file mode 100644
index 45de2587390c..000000000000
--- a/dev-java/commons-math/commons-math-3.6.1-r1.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-JAVA_PKG_IUSE="doc examples source"
-MAVEN_ID="org.apache.commons:commons-math3:3.6.1"
-
-inherit java-pkg-2 java-pkg-simple
-
-MY_PN="${PN}3"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
-HOMEPAGE="https://commons.apache.org/math/"
-SRC_URI="https://repo1.maven.org/maven2/org/apache/commons/${MY_PN}/${PV}/${MY_P}-sources.jar
--> ${MY_P}.jar"
-
-DEPEND=">=virtual/jdk-1.8:*"
-RDEPEND=">=virtual/jre-1.8:*"
-
-LICENSE="Apache-2.0"
-SLOT="3"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
diff --git a/dev-java/jackson-module-jakarta-xmlbind/jackson-module-jakarta-xmlbind-2.13.3.ebuild b/dev-java/jackson-module-jakarta-xmlbind/jackson-module-jakarta-xmlbind-2.13.3.ebuild
deleted file mode 100644
index b8c68c4cebaa..000000000000
--- a/dev-java/jackson-module-jakarta-xmlbind/jackson-module-jakarta-xmlbind-2.13.3.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/FasterXML/jackson-modules-base/archive/jackson-modules-base-2.13.3.tar.gz --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild jackson-module-jakarta-xmlbind-2.13.3.ebuild
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="com.fasterxml.jackson.module:jackson-module-jakarta-xmlbind-annotations:2.13.3"
-JAVA_TESTING_FRAMEWORKS="junit-4"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Support for using Jakarta XML Bind (aka JAXB 3.0) annotations"
-HOMEPAGE="https://github.com/FasterXML/jackson-modules-base"
-SRC_URI="https://github.com/FasterXML/jackson-modules-base/archive/jackson-modules-base-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-
-# We don't have jaxb-runtime:3.0.1
-RESTRICT="test"
-
-# Common dependencies
-# POM: pom.xml
-# com.fasterxml.jackson.core:jackson-annotations:2.13.3 -> >=dev-java/jackson-annotations-2.13.3:2
-# com.fasterxml.jackson.core:jackson-core:2.13.3 -> >=dev-java/jackson-core-2.13.3:0
-# com.fasterxml.jackson.core:jackson-databind:2.13.3 -> >=dev-java/jackson-databind-2.13.3:0
-# com.sun.activation:jakarta.activation:2.0.1 -> >=dev-java/jakarta-activation-2.0.1:2
-# jakarta.xml.bind:jakarta.xml.bind-api:3.0.1 -> >=dev-java/jaxb-api-3.0.1:3
-
-CP_DEPEND="
- ~dev-java/jackson-annotations-${PV}:2
- ~dev-java/jackson-core-${PV}:0
- ~dev-java/jackson-databind-${PV}:0
- dev-java/jakarta-activation:1
- dev-java/jaxb-api:3
-"
-
-# Compile dependencies
-# POM: pom.xml
-# test? junit:junit:4.13.1 -> >=dev-java/junit-4.13.2:4
-# test? org.glassfish.jaxb:jaxb-runtime:3.0.1 -> !!!groupId-not-found!!!
-
-DEPEND="
- >=virtual/jdk-11:*
- ${CP_DEPEND}"
-# test? (
-# !!!groupId-not-found!!!
-# )
-#"
-
-RDEPEND="
- >=virtual/jre-1.8:*
- ${CP_DEPEND}"
-
-S="${WORKDIR}/jackson-modules-base-jackson-modules-base-${PV}/jakarta-xmlbind/"
-
-JAVA_SRC_DIR=( "src/main/java" "src/moditect" )
-JAVA_RESOURCE_DIRS="src/main/resources"
-
-# JAVA_TEST_GENTOO_CLASSPATH="junit-4,!!!groupId-not-found!!!"
-# JAVA_TEST_SRC_DIR="src/test/java"
-
-src_prepare() {
- java-pkg-2_src_prepare
-
- sed -e 's:@package@:com.fasterxml.jackson.module.jakarta.xmlbind:g' \
- -e "s:@projectversion@:${PV}:g" \
- -e 's:@projectgroupid@:com.fasterxml.jackson.module:g' \
- -e "s:@projectartifactid@:jackson-module-jakarta-xmlbind-annotations:g" \
- "${JAVA_SRC_DIR}/com/fasterxml/jackson/module/jakarta/xmlbind/PackageVersion.java.in" \
- > "${JAVA_SRC_DIR}/com/fasterxml/jackson/module/jakarta/xmlbind/PackageVersion.java" || die
-}
-
-src_install() {
- default # https://bugs.gentoo.org/789582
- java-pkg-simple_src_install
-}
diff --git a/dev-java/jnr-netdb/Manifest b/dev-java/jnr-netdb/Manifest
index 9ac877e87be7..e22f9d59deea 100644
--- a/dev-java/jnr-netdb/Manifest
+++ b/dev-java/jnr-netdb/Manifest
@@ -1,2 +1 @@
-DIST jnr-netdb-1.1.4.tar.gz 648347 BLAKE2B 08953f93fe4a6146dfc77c463e07a8b9f6e784ffc26165d7409a623756733a7598b4d0a3fa55302b5f9b01c870cee3062f310c74e20f6a8a11ff1b41d38a0d7a SHA512 949a744b1d443cde564a2582baf7b4323c721417f32a45fd7413f791823cac5877bef62ed0d3079345631b908a581a1acf83dd00a926f87ebbd8e61d38a20195
DIST jnr-netdb-1.2.0.tar.gz 649059 BLAKE2B 660074d3a0d201784bddb259796ee4bb87a3579d6ffffcb5c3bf171d34e525c768c8c9282d8a99c250282d108011c0cf4bc9b8cf32dc7f3edc7e0a2b1cbaf9d4 SHA512 6eeb21d42b1eb7c0beed4f263c3440c7e5ae15f76365fb189fc8727c824e01d92662564ae641e1233ec0df68f6761c3c31a8a61891de59a524c213959bd32856
diff --git a/dev-java/jnr-netdb/files/jnr-netdb_maven-build.xml b/dev-java/jnr-netdb/files/jnr-netdb_maven-build.xml
deleted file mode 100644
index 9f4dfef15335..000000000000
--- a/dev-java/jnr-netdb/files/jnr-netdb_maven-build.xml
+++ /dev/null
@@ -1,231 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 5/28/12 5:31 PM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="jnr-netdb-from-maven" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="jnr-netdb"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/resources"/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath">
- </path>
- <path id="build.test.classpath">
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" depends="get-deps" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.1"
- verbose="false"
- fork="false"
- source="1.3">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- <javac destdir="${maven.build.testOutputDir}"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.1"
- verbose="false"
- fork="false"
- source="1.3">
- <src>
- <pathelement location="${maven.build.testDir.0}"/>
- </src>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- </classpath>
- </javac>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests, junit-missing"
- unless="junit.skipped"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java"/>
- <include name="**/*Test.java"/>
- <include name="**/*TestCase.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <target name="junit-missing"
- depends="test-junit-status"
- if="junit.missing">
- <echo>=================================== WARNING ===================================</echo>
- <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- linksource="false"
- breakiterator="false"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile,test" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
- <target name="test-offline">
- <condition property="maven.mode.offline">
- <equals arg1="${maven.settings.offline}" arg2="true"/>
- </condition>
- </target>
-
- <target name="get-deps"
- depends="test-offline"
- description="Download all dependencies"
- unless="maven.mode.offline">
- </target>
-
-</project>
diff --git a/dev-java/jnr-netdb/jnr-netdb-1.1.4-r1.ebuild b/dev-java/jnr-netdb/jnr-netdb-1.1.4-r1.ebuild
deleted file mode 100644
index 2a7af0818eb5..000000000000
--- a/dev-java/jnr-netdb/jnr-netdb-1.1.4-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Network services database access for java"
-HOMEPAGE="https://github.com/jnr/jnr-netdb"
-SRC_URI="https://github.com/jnr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="1.0"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-
-COMMON_DEP="
- dev-java/jnr-ffi:2"
-
-RDEPEND="${COMMON_DEP}
- >=virtual/jre-1.8:*"
-
-DEPEND="${COMMON_DEP}
- >=virtual/jdk-1.8:*
- test? (
- dev-java/ant-junit
- dev-java/junit:4
- )"
-
-src_prepare() {
- default
- find -name '*.jar' -exec rm -v {} + || die
-
- cp "${FILESDIR}"/${PN}_maven-build.xml build.xml || die
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-JAVA_ANT_CLASSPATH_TAGS="${JAVA_ANT_CLASSPATH_TAGS} javadoc"
-JAVA_ANT_ENCODING="UTF-8"
-
-EANT_GENTOO_CLASSPATH="jnr-ffi-2"
-EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},junit-4"
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_dojar target/${PN}.jar
- dodoc README
-
- use doc && java-pkg_dojavadoc target/site/apidocs
- use source && java-pkg_dosrc src/main/java/*
-}
diff --git a/dev-java/poi/Manifest b/dev-java/poi/Manifest
index be75761a39eb..446c7ed3e502 100644
--- a/dev-java/poi/Manifest
+++ b/dev-java/poi/Manifest
@@ -1,2 +1 @@
-DIST poi-5.0.0.tar.gz 111429369 BLAKE2B b29e754fb709d01ff4d68e9227f4c4739384bd02934b6860e8a0e96552d9e9ff1c5c665bc0b701f79226505fd98373fe6ad160c72735903eae388f0cd6618337 SHA512 e79d15b42d8ec389fd15b7714faf7b49b9fb4d57014cb341fff0f061393f4ea7dfcbd3810a6ec19539eabddbb1d0690aa56de4a1a412d05a527e11797047023a
DIST poi-src-5.2.2-20220312.tgz 117042913 BLAKE2B ef2ab433158ac51fc163e9bfa65268d246a686c7892234cdd2332bef526c69b59dd0959bdabc6a486a99e20dfcc144ff6aff775a6412136112bb6a36f10968d3 SHA512 858d6c1af8a29a22aa24bef0422b3c8329141ff026131b8354a97c87acc31ef06c91f1b9cabeb71738b3687ddc8283f19b2ac42865b7e98e91cb0d5aa6b89b40
diff --git a/dev-java/poi/poi-5.0.0.ebuild b/dev-java/poi/poi-5.0.0.ebuild
deleted file mode 100644
index 2996e53accbc..000000000000
--- a/dev-java/poi/poi-5.0.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom poi-5.0.0/sonar/main/pom.xml --download-uri https://archive.apache.org/dist/poi/release/src/poi-src-5.0.0-20210120.tar.gz --slot 0 --keywords "~amd64 ~arm64 ~ppc64 ~x86" --ebuild poi-5.0.0.ebuild
-
-EAPI=7
-
-JAVA_PKG_IUSE="doc source"
-MAVEN_ID="org.apache.poi:poi-main:5.0.0"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Maven build of Apache POI for Sonar checks"
-HOMEPAGE="https://poi.apache.org/"
-SRC_URI="https://archive.apache.org/dist/${PN}/release/src/${PN}-src-${PV}-20210120.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-
-# Common dependencies
-# POM: ${P}/sonar/main/pom.xml
-# com.zaxxer:SparseBitSet:1.2 -> >=dev-java/sparsebitset-1.2:0
-# commons-codec:commons-codec:1.15 -> >=dev-java/commons-codec-1.11:0
-# org.apache.commons:commons-collections4:4.4 -> >=dev-java/commons-collections-4.1:4
-# org.apache.commons:commons-math3:3.6.1 -> >=dev-java/commons-math-3.6.1:3
-# org.slf4j:jcl-over-slf4j:1.7.30 -> !!!artifactId-not-found!!!
-# org.slf4j:slf4j-api:1.7.30 -> >=dev-java/slf4j-api-1.7.30:0
-
-# CDEPEND="
-# !!!artifactId-not-found!!!
-# >=dev-java/commons-codec-1.11:0
-# >=dev-java/commons-collections-4.1:4
-# >=dev-java/commons-math-3.6.1:3
-# >=dev-java/slf4j-api-1.7.30:0
-# >=dev-java/sparsebitset-1.2:0
-# "
-CDEPEND="
- >=dev-java/commons-codec-1.11:0
- >=dev-java/commons-collections-4.1:4
- >=dev-java/commons-math-3.6.1:3
- >=dev-java/slf4j-api-1.7.30:0
- >=dev-java/sparsebitset-1.2:0
- dev-java/commons-logging:0
-"
-
-DEPEND="
- >=virtual/jdk-1.8:*
- ${CDEPEND}
-"
-
-RDEPEND="
- >=virtual/jre-1.8:*
- ${CDEPEND}"
-
-S="${WORKDIR}/${P}"
-
-JAVA_GENTOO_CLASSPATH="sparsebitset,commons-codec,commons-collections-4,commons-logging,commons-math-3,slf4j-api"
-JAVA_SRC_DIR="src/java"
-
-src_prepare() {
- default
- java-pkg_clean
-}
diff --git a/dev-java/typesafe-config/Manifest b/dev-java/typesafe-config/Manifest
index a1d35ff20838..0d612a396e83 100644
--- a/dev-java/typesafe-config/Manifest
+++ b/dev-java/typesafe-config/Manifest
@@ -1,2 +1 @@
-DIST typesafe-config-1.3.0.tar.gz 257311 BLAKE2B 6df016ef84f8e3f717ac22ea3a8a66ad54ab378645e853fbb5fbb3316dde56e4cf6ba7a256f38d8912514321060290a92c412ad9753c0244b35c20bb0a9e4950 SHA512 e8c0e3100b9e7c50ddd19285a3e33cc708711d0007719bb191012d88ddbd0286529172fce54a369c0dd86ced1c61807f40d5334a69b2c8bc6865a8b65740798e
DIST typesafe-config-1.4.2.tar.gz 278098 BLAKE2B 65e3ffb4e9a4a7c33344c7f26ac28f6321c83621865db7812c09e7908e10f110bcfab4eca66577d6495f94da6a11b8877920e87afa6976c25852c5ec08aa1148 SHA512 85bc28987a6998a5ce6e0bb0996d853b534fc870e44abaeb3df31e53a2da39a350aecbd8f8849f4d4340a7e5da1c44882eb8c8ba58233c9af2a0e575f2c2c6db
diff --git a/dev-java/typesafe-config/typesafe-config-1.3.0-r3.ebuild b/dev-java/typesafe-config/typesafe-config-1.3.0-r3.ebuild
deleted file mode 100644
index af9df09e8936..000000000000
--- a/dev-java/typesafe-config/typesafe-config-1.3.0-r3.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="A library of arguably useful Java utilities"
-HOMEPAGE="https://lightbend.github.io/config/"
-SRC_URI="https://github.com/lightbend/config/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ppc64 x86"
-IUSE="doc source"
-
-RDEPEND=">=virtual/jre-1.8:*"
-
-DEPEND=">=virtual/jdk-1.8:*"