summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/ledger/Manifest1
-rw-r--r--app-office/ledger/ledger-3.2.0.ebuild113
-rw-r--r--app-office/ledger/ledger-3.2.1.ebuild4
-rw-r--r--dev-util/cppunit/cppunit-1.15.1-r2.ebuild (renamed from dev-util/cppunit/cppunit-1.15.1-r1.ebuild)10
-rw-r--r--dev-util/cppunit/files/cppunit-1.15.1-slibtool.patch12
-rw-r--r--eclass/dune.eclass3
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.25.1-r1.ebuild171
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.25.1-r100.ebuild4
-rw-r--r--media-sound/sc2mpd/Manifest6
-rw-r--r--media-sound/sc2mpd/sc2mpd-1.1.5.ebuild115
-rw-r--r--media-sound/sc2mpd/sc2mpd-1.1.7.ebuild4
-rw-r--r--media-sound/upmpdcli/Manifest1
-rw-r--r--media-sound/upmpdcli/upmpdcli-1.5.2.ebuild49
-rw-r--r--media-sound/upmpdcli/upmpdcli-1.5.5.ebuild4
14 files changed, 14 insertions, 483 deletions
diff --git a/app-office/ledger/Manifest b/app-office/ledger/Manifest
index 9e2188a1bb44..7a65150ea97c 100644
--- a/app-office/ledger/Manifest
+++ b/app-office/ledger/Manifest
@@ -1,2 +1 @@
-DIST ledger-3.2.0.tar.gz 790404 BLAKE2B 081ca5d857238aecbeae5a0ba3267864442a8c1772a71b1894f5a9fb33173f9a0bd488ad4db3844fce8172268e516ebb92ba0556ced6e67b2a089fbb5adfde36 SHA512 580f4f39d7c3cd2bd1d05bcc36b127cfb311219f39fe50dbf23f582f73dd986729d4b5fa76bfd89cd5db9bfdfcdd5dca5b9d6b24766650040e45b881726e65ea
DIST ledger-3.2.1.tar.gz 790959 BLAKE2B a25b08f37c6bcf409fb60e0bcc6e11021515fe17f7eb6f23781bd7a7c16b58ac92d4684e5936901ed87f2f5be4df427bd95fe856f8e7eff1e2609329866de71a SHA512 526c60cee354c9d2ead38cef3b89b349467e41fa3ec0927b51e7246a3352f19f0f81574211f20ba9bac5915590b870b9f9478a103ab661d3d9a10f41c52f4512
diff --git a/app-office/ledger/ledger-3.2.0.ebuild b/app-office/ledger/ledger-3.2.0.ebuild
deleted file mode 100644
index d9edbeb5e8be..000000000000
--- a/app-office/ledger/ledger-3.2.0.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-CMAKE_REMOVE_MODULES_LIST=( FindPython Support )
-inherit bash-completion-r1 check-reqs cmake python-single-r1
-
-DESCRIPTION="Double-entry accounting system with a command-line reporting interface"
-HOMEPAGE="https://www.ledger-cli.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug doc python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RESTRICT="test"
-
-CHECKREQS_MEMORY=8G
-
-RDEPEND="
- dev-libs/boost:=[python?]
- dev-libs/gmp:0=
- dev-libs/mpfr:0=
- python? (
- $(python_gen_cond_dep '
- dev-libs/boost:=[${PYTHON_USEDEP}]
- dev-python/cheetah3:=[${PYTHON_USEDEP}]
- ')
- ${PYTHON_DEPS}
- )
-"
-DEPEND="${RDEPEND}
- dev-libs/utfcpp
- doc? (
- dev-texlive/texlive-fontsrecommended
- sys-apps/texinfo
- virtual/texi2dvi
- )
-"
-
-pkg_pretend() {
- if use python; then
- check-reqs_pkg_pretend
- fi
-}
-
-pkg_setup() {
- if use python; then
- check-reqs_pkg_setup
- python-single-r1_pkg_setup
- fi
-}
-
-src_prepare() {
- cmake_src_prepare
-
- # Want to type "info ledger" not "info ledger3"
- sed -i -e 's/ledger3/ledger/g' \
- doc/{CMakeLists.txt,ledger3.texi} test/CheckTexinfo.py \
- tools/{cleanup.sh,gendocs.sh,prepare-commit-msg,spellcheck.sh} \
- || die "Failed to update info file name in file contents"
-
- mv doc/ledger{3,}.texi || die "Failed to rename info file name"
-
- rm -r lib/utfcpp || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_DOCS="$(usex doc)"
- -DBUILD_WEB_DOCS="$(usex doc)"
- -DUSE_PYTHON="$(usex python)"
- -DCMAKE_INSTALL_DOCDIR="/usr/share/doc/${PF}"
- -DCMAKE_BUILD_WITH_INSTALL_RPATH:BOOL=ON
- -DBUILD_DEBUG="$(usex debug)"
- -DUTFCPP_PATH="${ESYSROOT}/usr/include/utf8cpp"
- )
- if use python; then
- mycmakeargs+=(
- -DPython_EXECUTABLE="${PYTHON}"
- -DPython_INCLUDE_DIR="$(python_get_includedir)"
- )
- fi
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- use doc && cmake_src_compile doc
-}
-
-src_install() {
- cmake_src_install
-
- newbashcomp contrib/${PN}-completion.bash ${PN}
-}
-
-pkg_postinst() {
- elog
- elog "Since version 3, vim support is released separately."
- elog "See https://github.com/ledger/vim-ledger"
- elog
- elog "For Emacs mode, emerge app-emacs/ledger-mode"
-}
-
-# rainy day TODO:
-# - IUSE test
diff --git a/app-office/ledger/ledger-3.2.1.ebuild b/app-office/ledger/ledger-3.2.1.ebuild
index 04e737f4bf0e..285a750b03b1 100644
--- a/app-office/ledger/ledger-3.2.1.ebuild
+++ b/app-office/ledger/ledger-3.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="debug doc python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
diff --git a/dev-util/cppunit/cppunit-1.15.1-r1.ebuild b/dev-util/cppunit/cppunit-1.15.1-r2.ebuild
index 8d7448313a9c..09eb8d15a46b 100644
--- a/dev-util/cppunit/cppunit-1.15.1-r1.ebuild
+++ b/dev-util/cppunit/cppunit-1.15.1-r2.ebuild
@@ -3,12 +3,12 @@
EAPI=7
-inherit autotools flag-o-matic multilib-minimal
+inherit flag-o-matic multilib-minimal
DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/cppunit"
if [[ "${PV}" == *9999 ]] ; then
- inherit git-r3
+ inherit autotools git-r3
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/cppunit.git"
else
SRC_URI="https://dev-www.libreoffice.org/src/${P}.tar.gz"
@@ -30,13 +30,9 @@ BDEPEND="
DOCS=( AUTHORS BUGS NEWS README THANKS TODO doc/FAQ )
[[ "${PV}" == 9999 ]] || DOCS+=( ChangeLog )
-PATCHES=(
- "${FILESDIR}/${PN}-1.15.1-slibtool.patch"
-)
-
src_prepare() {
default
- eautoreconf
+ [[ "${PV}" == 9999 ]] && eautoreconf
}
src_configure() {
diff --git a/dev-util/cppunit/files/cppunit-1.15.1-slibtool.patch b/dev-util/cppunit/files/cppunit-1.15.1-slibtool.patch
deleted file mode 100644
index d5bfcb2b7489..000000000000
--- a/dev-util/cppunit/files/cppunit-1.15.1-slibtool.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-This fixes build with sys-devel/slibtool
-
---- cppunit-1.15.1/src/cppunit/Makefile.am
-+++ cppunit-1.15.1/src/cppunit/Makefile.am
-@@ -62,6 +62,6 @@
-
- libcppunit_la_LDFLAGS= \
- -no-undefined -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
-- -release $(LT_RELEASE) $(LIBADD_DL)
-+ $(LIBADD_DL)
-
- libcppunit_la_LIBADD = $(LIBADD_DL)
diff --git a/eclass/dune.eclass b/eclass/dune.eclass
index 334fbfbf7910..da1813def533 100644
--- a/eclass/dune.eclass
+++ b/eclass/dune.eclass
@@ -23,6 +23,9 @@ case ${EAPI:-0} in
*) die "${ECLASS}: EAPI ${EAPI} not supported" ;;
esac
+# Do not complain about CFLAGS etc since ml projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
EXPORT_FUNCTIONS src_compile src_test src_install
RDEPEND=">=dev-lang/ocaml-4:=[ocamlopt?]"
diff --git a/games-roguelike/stone-soup/stone-soup-0.25.1-r1.ebuild b/games-roguelike/stone-soup/stone-soup-0.25.1-r1.ebuild
deleted file mode 100644
index 0c8a1930f33d..000000000000
--- a/games-roguelike/stone-soup/stone-soup-0.25.1-r1.ebuild
+++ /dev/null
@@ -1,171 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# TODO
-# - attempt +test, linked bug claims to be fixed
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-VIRTUALX_REQUIRED="manual"
-inherit desktop python-any-r1 eutils xdg-utils toolchain-funcs
-
-MY_P="stone_soup-${PV}"
-DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
-HOMEPAGE="https://crawl.develz.org"
-SRC_URI="
- https://github.com/crawl/crawl/releases/download/${PV}/${PN/-/_}-${PV}.zip
- https://dev.gentoo.org/~hasufell/distfiles/${PN}.png
- https://dev.gentoo.org/~hasufell/distfiles/${PN}.svg
-"
-
-# 3-clause BSD: mt19937ar.cc, MSVC/stdint.h
-# 2-clause BSD: all contributions by Steve Noonan and Jesse Luehrs
-# Public Domain|CC0: most of tiles
-# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
-LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug ncurses sound test +tiles"
-# test is broken
-# see https://crawl.develz.org/mantis/view.php?id=6121
-RESTRICT="test"
-
-RDEPEND="
- dev-db/sqlite:3
- =dev-lang/lua-5.1*:0=
- sys-libs/zlib
- !ncurses? ( !tiles? ( sys-libs/ncurses:0 ) )
- ncurses? ( sys-libs/ncurses:0 )
- tiles? (
- media-fonts/dejavu
- media-libs/freetype:2
- media-libs/libpng:0
- sound? (
- media-libs/libsdl2[X,opengl,sound,video]
- media-libs/sdl2-mixer
- )
- !sound? ( media-libs/libsdl2[X,opengl,video] )
- media-libs/sdl2-image[png]
- virtual/glu
- virtual/opengl
- )"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-lang/perl
- ${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
- sys-devel/flex
- tiles? (
- app-arch/advancecomp
- media-gfx/pngcrush
- sys-libs/ncurses:0
- )
- virtual/pkgconfig
- virtual/yacc
- "
-
-S=${WORKDIR}/${MY_P}/source
-S_TEST=${WORKDIR}/${MY_P}_test/source
-PATCHES=(
- "${FILESDIR}"/fixed-font-path.patch
- "${FILESDIR}"/gitless-1.patch
- "${FILESDIR}"/rltiles-ldflags-libs.patch
-)
-
-python_check_deps() {
- has_version "dev-python/pyyaml[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
-
- python-any-r1_pkg_setup
-
- if use !ncurses && use !tiles ; then
- ewarn "Neither ncurses nor tiles frontend"
- ewarn "selected, choosing ncurses only."
- ewarn "Note that you can also enable both."
- fi
-
- if use sound && use !tiles ; then
- ewarn "Sound support is only available with tiles."
- fi
-}
-
-src_prepare() {
- default
- python_fix_shebang "${S}/util/species-gen.py"
-}
-
-src_compile() {
-
- # Insurance that we're not using bundled lib sources
- rm -rf contrib || die "Couldn't delete contrib directory"
-
- export HOSTCXX=$(tc-getBUILD_CXX)
-
- # leave DATADIR at the top
- myemakeargs=(
- $(usex debug "FULLDEBUG=y DEBUG=y" "")
- BUILD_LUA=
- AR="$(tc-getAR)"
- CFOPTIMIZE=''
- CFOTHERS="${CXXFLAGS}"
- CONTRIBS=
- DATADIR="/usr/share/${PN}"
- GCC="$(tc-getCC)"
- GXX="$(tc-getCXX)"
- LDFLAGS="${LDFLAGS}"
- MAKEOPTS="${MAKEOPTS}"
- PKGCONFIG="$(tc-getPKG_CONFIG)"
- RANLIB="$(tc-getRANLIB)"
- SAVEDIR="~/.crawl"
- SOUND=$(usex sound "y" "")
- STRIP=touch
- USE_LUAJIT=
- V=1
- prefix="/usr"
- )
-
- if use ncurses || (use !ncurses && use !tiles) ; then
- emake "${myemakeargs[@]}"
- # move it in case we build both variants
- use tiles && { mv crawl "${WORKDIR}"/crawl-ncurses || die ;}
- fi
-
- if use tiles ; then
- emake clean
- emake "${myemakeargs[@]}" "TILES=y"
- fi
-}
-
-src_install() {
- emake "${myemakeargs[@]}" $(usex tiles "TILES=y" "") DESTDIR="${D}" prefix_fp="" bin_prefix="${D}/usr/bin" install
- [[ -e "${WORKDIR}"/crawl-ncurses ]] && dobin "${WORKDIR}"/crawl-ncurses
-
- # don't relocate docs, needed at runtime
- rm -rf "${D}/usr/share/${PN}"/docs/license
-
- doman "${WORKDIR}/${MY_P}"/docs/crawl.6
-
- # icons and menu for graphical build
- if use tiles ; then
- doicon -s 48 "${DISTDIR}"/${PN}.png
- doicon -s scalable "${DISTDIR}"/${PN}.svg
- make_desktop_entry crawl
- fi
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-
- if use tiles && use ncurses ; then
- elog "Since you have enabled both tiles and ncurses frontends"
- elog "the ncurses binary is called 'crawl-ncurses' and the"
- elog "tiles binary is called 'crawl'."
- fi
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/games-roguelike/stone-soup/stone-soup-0.25.1-r100.ebuild b/games-roguelike/stone-soup/stone-soup-0.25.1-r100.ebuild
index fd7baf97c0e4..6c1832ac297d 100644
--- a/games-roguelike/stone-soup/stone-soup-0.25.1-r100.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.25.1-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# TODO
@@ -26,7 +26,7 @@ SRC_URI="
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="debug ncurses sound test +tiles"
# test is broken
# see https://crawl.develz.org/mantis/view.php?id=6121
diff --git a/media-sound/sc2mpd/Manifest b/media-sound/sc2mpd/Manifest
index 285545a43d17..752ca377b0e9 100644
--- a/media-sound/sc2mpd/Manifest
+++ b/media-sound/sc2mpd/Manifest
@@ -1,8 +1,2 @@
-DIST ohdevtools.d35861.tar.gz 1187475 BLAKE2B 82138d9b64f3172d540402e99b716e9b56bde2133b2565b442bfe6ae6b0e2235226027c4b43b17e3eb005b6f52a4d6a278e0895d267222a63f910ea556e4d76c SHA512 25188c3ae837db12e5c7f349ab01a315f8c68909e3eaa530dc9ba09fb2bcb3cd0a671676b3dd4902ef019b7e331d2acac0978649bce29df585e54d13158ff162
-DIST ohnet.1dd641.tar.gz 20831753 BLAKE2B 82724b7f2cd5cd0dcaa54786394a2560b965f5f16df7bb84037795f1334b8052a4cfeff8f5f39bdc5d7a0ccb2093190c38de987957463d10cac407d9694a6a92 SHA512 67ccdbee6d909df30acb7c89aeba75d3accdbb533dda5abc02c66f867e2fad9a360696d5e28dd1decdc575a1396d026824329450e85e3a3b3e4f7af2e144140a
-DIST ohnetgenerated.e3edb9.tar.gz 1887473 BLAKE2B 1b878dd743f0b45f69c3eb018ddbd64db60285ee8743bb039f9a794a9e0ecdb516e1138ac622fc7cde3462fe5c3cfc006d71d0b22048496c1bc190cc4f34a906 SHA512 9b48d0ff496acfa4313c1efc90e73f1050fee011b1ab301b9268ba4009fca9a47978cbe2f1f0a1d05d7c939f95b4a38560b9f63464305032c20d36af3ade8811
-DIST ohsongcast.3299ea.tar.gz 831313 BLAKE2B aaa5590af288bbf2b358bad613b983418f6648219bba046113a8c712f3a369fee2894c8aa42f96ead16582b96b982d1696b478950e0e3d0ef6c8e3325e5a3214 SHA512 ac1e81166e5b73a943f78c930ef89fc5b71447c7eb8c4cc509c50c686a360a25f75f1651061a653bf995c15377bee4cb98a97665bf27f04f947940a249e12661
-DIST ohtopology.cc09c0.tar.gz 118703 BLAKE2B ef5b560cb2a272586e8755117b5021d67562bda962b0c6240072ad42876ae71f21c81611521d31b01212d2175637244b8513332858aec3d7e713546587111ed0 SHA512 46f1e4ba6b7553b81c939c2ae691ab89e0bf9b565820e8c65b14b6534f3a9240580cb9fd69f46568c5f0c8d105da825b6f9abbf61a64289a4f553a47902b38d4
DIST openhome-sc2-20200704.tar.gz 22352681 BLAKE2B a5131f3b5c3400ff0ca58f0ce9b45c25db6fc13dcf6827ed9e4531effd3b35026d59495adf690ba65c09624c12f7755b9373ec4e4309de73f17fdeb866beeba7 SHA512 04586fbfd8053c7f01d2c3dbf421f75d0d93ac179cf5f58bc7966d364a3477a87985a1a2db1b35018aa5193a07977b7b4be60d317e7c10b275234adf9a2bd5d2
-DIST sc2mpd-1.1.5.tar.gz 219031 BLAKE2B ac8a3b4da6caff58db4948c32d643bf9244efa4ad77e29c18aa7e10036715a9a84c9f69478f5a2eabf6769112fb61ea15e1d7e8e613fbae05794cef609f21247 SHA512 8ea47b8bda62b8e97b95b0ddf0ab7979a54ae8bc599c67ef7bdd16ea876254446c8be440fade7355be93742c94c6f20b56e40a5756cc3c0dbe0409612dc3788e
DIST sc2mpd-1.1.7.tar.gz 238674 BLAKE2B 35fd57797612e3883ad5cc04be3f5328dbf4ec9aedb0461a801fe79566ef20de4026ad653eec6e7d932ffcd0385bb618331a519ec54838fd856d09c20f1971b8 SHA512 0b39e200f013602c851bec1ba41210c40d1a984638c86bd8dd5d61286aff19b315f282182753426e4470c8e6ccb60265b16dc6ba2e5117f59a3d40194464b4b3
diff --git a/media-sound/sc2mpd/sc2mpd-1.1.5.ebuild b/media-sound/sc2mpd/sc2mpd-1.1.5.ebuild
deleted file mode 100644
index dd5733ae60e6..000000000000
--- a/media-sound/sc2mpd/sc2mpd-1.1.5.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils
-
-DESCRIPTION="Implements the SongCast protocol for use by upmpdcli and mpd"
-HOMEPAGE="https://www.lesbonscomptes.com/upmpdcli/index.html"
-
-sha_net="1dd6411ffbe59fe09517162fb88e2405adb4990f"
-sha_netgenerated="e3edb912410d4c5a4d5323bb1e9c27660a42d78f"
-sha_topology="cc09c09da4be8d3d04adae5b8f0daaf8450906a3"
-sha_songcast="3299eaedfea34993b79e6d30444792d4fb12a110"
-sha_devtools="d3586187dfa5f0a8b0f3e35e3d1dc50d1c34943d"
-
-SRC_URI="
- https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz
- https://codeload.github.com/openhome/ohNet/tar.gz/${sha_net}
- -> ohnet.${sha_net:0:6}.tar.gz
- https://codeload.github.com/openhome/ohNetGenerated/tar.gz/${sha_netgenerated}
- -> ohnetgenerated.${sha_netgenerated:0:6}.tar.gz
- https://codeload.github.com/openhome/ohTopology/tar.gz/${sha_topology}
- -> ohtopology.${sha_topology:0:6}.tar.gz
- https://codeload.github.com/openhome/ohSongcast/tar.gz/${sha_songcast}
- -> ohsongcast.${sha_songcast:0:6}.tar.gz
- https://codeload.github.com/openhome/ohdevtools/tar.gz/${sha_devtools}
- -> ohdevtools.${sha_devtools:0:6}.tar.gz
-"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64"
-
-DEPEND="
- media-libs/alsa-lib
- media-libs/libsamplerate
- net-libs/libmicrohttpd
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- cd "${WORKDIR}" || die "Couldn't cd to WORKDIR"
- mkdir openhome || die "Couldn't mkdir openhome"
- mv ohNet-${sha_net} openhome/ohNet || die "Couldn't mv ohNet"
- mv ohNetGenerated-${sha_netgenerated} openhome/ohNetGenerated || die "Couldn't mv ohNetGenerated"
- mv ohdevtools-${sha_devtools} openhome/ohdevtools || die "Couldn't mv ohdevtools"
- mv ohTopology-${sha_topology} openhome/ohTopology || die "Couldn't mv ohTopology"
- mv ohSongcast-${sha_songcast} openhome/ohSongcast || die "Couldn't mv ohSongcast"
-
- eapply "${FILESDIR}/${P}-werror.patch"
-
- cd "${WORKDIR}/openhome/ohNet" || die "Couldn't cd to ohNet dir"
- epatch "${FILESDIR}/ohnet.makefile.patch"
- epatch "${FILESDIR}/ohnet.optionparser.patch"
- sed -i -e 's/ bundle-after-build//' UserTargets.mak || die "Couldn't patch UserTargets.mak"
-
- cd "${WORKDIR}/openhome/ohNetGenerated" || die "Couldn't cd to ohNetGenerated dir"
- epatch "${FILESDIR}/ohnetgenerated.makefile.patch"
- epatch "${FILESDIR}/ohnetgenerated.commonmk.patch"
- sed -i -e 's/ bundle-after-build//' UserTargets.mak \
- || die "Couldn't patch generated UserTargets.mak"
-
- eapply_user
-}
-
-src_configure() {
- econf "--with-openhome=${WORKDIR}/openhome"
-}
-
-src_compile() {
- # Begin ohbuild.sh reverse engineer
-
- cd "${WORKDIR}/openhome/ohNet" || die "Couldn't cd to ohNet dir"
- make native_only=yes || die "ohnet make failed"
-
- cd "${WORKDIR}/openhome/ohNetGenerated" || die "Couldn't cd to ohNetGenerated dir"
- # TODO: get from environment/make target
- deps="${WORKDIR}/openhome/ohNetGenerated/dependencies/Linux-x64/ohNet-Linux-x64-Release"
- mkdir -p $deps/{include/ohnet,lib/{ohnet,t4,ui,PyOhNet}} || die "Couldn't mkdir deps"
- cd $deps || die "Couldn't cd to deps dir"
-
- ohnet="${WORKDIR}/openhome/ohNet"
- find "$ohnet/Build" \( -name '*.a' -o -name '*.so' \) \
- -exec cp '{}' lib ';' \
- || die "Couldn't cp binary libs"
-
- cd "$ohnet/Build/Include" || die "Couldn't cd to include"
- cp -R * "${deps}/include/ohnet" || die "Couldn't cp include"
- # cd "$ohnet/Build/Tools" || die "Couldn't cd to tools"
- # cp -R * "${deps}/lib/t4" || die "Couldn't cp tools"
- cd "$ohnet/OpenHome/Net/T4/Templates" || die "Couldn't cd to templates"
- cp -R * "${deps}/lib/t4" || die "Couldn't cp templates"
- cd "$ohnet/OpenHome/Net/Bindings/Js/ControlPoint" || die "Couldn't cd to ui"
- cp -R * "${deps}/lib/ui" || die "Couldn't cp ui"
- cd "$ohnet/OpenHome/Net/Bindings/Python/PyOhNet" || die "Couldn't cd to py"
- cp -R * "${deps}/lib/PyOhNet" || die "Couldn't cp py"
-
- cd "${WORKDIR}/openhome/ohNetGenerated" || die "Couldn't cd later to ohNetGenerated dir"
- make native_only=yes || die "ohnetgenerated make failed"
-
- cd "Build/Include" || die "Couldn't cd later to include"
- cp -R * "$ohnet/Build/Include" || die "Couldn't cp generated includes"
-
- cd "${WORKDIR}/openhome/ohTopology" || die "Couldn't cd to ohTopology dir"
- mkdir -p build/Include/OpenHome/Av || die "Couldn't mkdir av"
- cp -p OpenHome/Av/*.h build/Include/OpenHome/Av/ || die "Couldn't cp to av"
-
- cd "${WORKDIR}/openhome/ohSongcast" || die "Couldn't cd to ohSongcast dir"
- make release=1 Receiver WavSender || die "Failed to build ohSongcast"
-
- # End ohbuild.sh reverse engineer
-
- cd "${S}" || die "Failed to cd to source directory"
- make || die "Failed to make sc2mpd"
-}
diff --git a/media-sound/sc2mpd/sc2mpd-1.1.7.ebuild b/media-sound/sc2mpd/sc2mpd-1.1.7.ebuild
index 5e598bc0f586..e8dba6b2c3a3 100644
--- a/media-sound/sc2mpd/sc2mpd-1.1.7.ebuild
+++ b/media-sound/sc2mpd/sc2mpd-1.1.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ SRC_URI="
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64 x86"
DEPEND="
dev-libs/expat
diff --git a/media-sound/upmpdcli/Manifest b/media-sound/upmpdcli/Manifest
index 12761f4fa0a5..84cb47b61768 100644
--- a/media-sound/upmpdcli/Manifest
+++ b/media-sound/upmpdcli/Manifest
@@ -1,3 +1,2 @@
-DIST upmpdcli-1.5.2.tar.gz 550460 BLAKE2B e9905fb2f6c07d7374651fd0a9d7ec821d6ea25d4debe1b6e69bbf7def8b75d0b35b245a5e4ca2477832f71a9fe950f7f7635d1b6fc29add0e59405c0c69b338 SHA512 4d6cd44b64637c5a07996a416f0cf15e27e24b84aa04ee3ee9f6f5eda3164a5b964915587a4342cc0a8f95fa175dd106b99242de5c50d3cb603e48450694009e
DIST upmpdcli-1.5.5.tar.gz 550726 BLAKE2B 1a32f5a3126e037f6663ab60244d7af3fd7aeb79c5878ba1ca4d8029b97917a70f5b06a82e6006fcf14642b96cb5539488b3bba03860a2dd23e6bce0efe54bdc SHA512 90ce69b4ef004e1b5db3229b3bc99637ecba0f5f7e82d0e9f567da163295b4a572d059accbeb679194d1846eb822d48378acc743ee334ffd9859f3e025f6a0f3
DIST upmpdcli-1.5.7.tar.gz 552203 BLAKE2B fe8e8aa3f4c777925dce2a143aec201462cb2da9e33f604d48848f27acc51fad42e1c626c17b5325918f0d1de1b37c1c456240f811af118b83bc7ce3260e0687 SHA512 ce86b8f9b4e7614433ab542facbf7452426b66bf026bb21ea0e868cde9b492b09a86ee8aa259a9353f2ede6a22d1055987986747aa8e284714c5e60f73a3a55a
diff --git a/media-sound/upmpdcli/upmpdcli-1.5.2.ebuild b/media-sound/upmpdcli/upmpdcli-1.5.2.ebuild
deleted file mode 100644
index a3c936e6337c..000000000000
--- a/media-sound/upmpdcli/upmpdcli-1.5.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd
-
-DESCRIPTION="UPnP Media Renderer front-end for MPD, the Music Player Daemon"
-HOMEPAGE="https://www.lesbonscomptes.com/upmpdcli/index.html"
-LICENSE="GPL-2"
-
-SRC_URI="https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="thirdparty"
-
-DEPEND="
- dev-libs/jsoncpp
- media-libs/libmpdclient
- net-libs/libmicrohttpd
- >=net-libs/libupnpp-0.20.0-r1
-"
-RDEPEND="
- ${DEPEND}
- acct-group/upmpdcli
- acct-user/upmpdcli
- app-misc/recoll
- thirdparty? ( dev-python/requests )
-"
-
-src_install() {
- default
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
- systemd_dounit systemd/upmpdcli.service
-}
-
-pkg_postinst() {
- einfo
- einfo "This package no longer assumes that upmpdcli is driving an"
- einfo "mpd instance on the same host (https://bugs.gentoo.org/670130)."
- einfo "Probably it is though, so be sure your mpd is built with"
- einfo "USE=curl."
- einfo
- einfo "Consider installing media-sound/sc2mpd. If upmpdcli"
- einfo "detects sc2mpd at run-time, capabilities are added"
- einfo "including internet radio support. See upstream docs"
- einfo "for more information."
-}
diff --git a/media-sound/upmpdcli/upmpdcli-1.5.5.ebuild b/media-sound/upmpdcli/upmpdcli-1.5.5.ebuild
index 0eb2b288b4ea..32fbe2a26ccc 100644
--- a/media-sound/upmpdcli/upmpdcli-1.5.5.ebuild
+++ b/media-sound/upmpdcli/upmpdcli-1.5.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,7 +11,7 @@ LICENSE="GPL-2"
SRC_URI="https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="thirdparty"
DEPEND="