summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/webapp-config/webapp-config-1.55-r3.ebuild87
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild27
-rw-r--r--dev-python/ntlm-auth/Manifest1
-rw-r--r--dev-python/ntlm-auth/metadata.xml17
-rw-r--r--dev-python/ntlm-auth/ntlm-auth-1.5.0.ebuild23
-rw-r--r--media-gfx/mcomix/files/mcomix-2.1.1-pillow_version.patch15
-rw-r--r--media-gfx/mcomix/mcomix-2.1.1-r1.ebuild47
-rw-r--r--profiles/package.mask5
8 files changed, 170 insertions, 52 deletions
diff --git a/app-admin/webapp-config/webapp-config-1.55-r3.ebuild b/app-admin/webapp-config/webapp-config-1.55-r3.ebuild
new file mode 100644
index 000000000000..76caefb23e6d
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.55-r3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 prefix
+
+if [[ ${PV} = 9999* ]]
+then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~ceamac/${CATEGORY}/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="https://sourceforge.net/projects/webapp-config/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+portage"
+
+DEPEND="app-text/xmlto
+ sys-apps/gentoo-functions"
+RDEPEND="
+ portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # make the source from svn mirror the one in the tarball
+ if [[ ${PV} == 9999* ]]; then
+ mkdir ../webapp-config || die "Cannot create temp directory."
+ cp -r * ../webapp-config || die "Cannot copy all into the temp directory."
+ mv ../webapp-config . || die "Cannot move temp directory to its final position."
+
+ # Installation fails if version is 1.55-git
+ sed -e 's/-git//' \
+ -i webapp-config/WebappConfig/version.py \
+ -i WebappConfig/version.py || die "Cannot fix version."
+ fi
+
+ distutils-r1_python_prepare_all
+ eprefixify WebappConfig/eprefix.py config/webapp-config
+}
+
+python_compile_all() {
+ emake -C doc/
+}
+
+python_test() {
+ PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
+ die "Testing failed with ${EPYTHON}"
+}
+
+python_install() {
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # distutils-r1 installs the scripts in /usr/bin in PEP517 mode
+ mv "${ED}"/usr/bin "${ED}"/usr/sbin || die "Cannot rename scripts directory to /usr/sbin"
+
+ insinto /etc/vhosts
+ doins config/webapp-config
+
+ keepdir /usr/share/webapps
+ keepdir /var/db/webapps
+
+ dodoc AUTHORS
+ doman doc/*.[58]
+}
+
+pkg_postinst() {
+ elog "Now that you have upgraded webapp-config, you **must** update your"
+ elog "config files in /etc/vhosts/webapp-config before you emerge any"
+ elog "packages that use webapp-config."
+}
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 9aad95348cfe..76caefb23e6d 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1 prefix
if [[ ${PV} = 9999* ]]
then
- EGIT_REPO_URI="https://anongit.gentoo.org/proj/${PN}.git"
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/${PN}.git"
inherit git-r3
else
- SRC_URI="https://dev.gentoo.org/~blueness/${PN}/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+ SRC_URI="https://dev.gentoo.org/~ceamac/${CATEGORY}/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
DESCRIPTION="Gentoo's installer for web-based applications"
@@ -30,6 +30,18 @@ RDEPEND="
portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
python_prepare_all() {
+ # make the source from svn mirror the one in the tarball
+ if [[ ${PV} == 9999* ]]; then
+ mkdir ../webapp-config || die "Cannot create temp directory."
+ cp -r * ../webapp-config || die "Cannot copy all into the temp directory."
+ mv ../webapp-config . || die "Cannot move temp directory to its final position."
+
+ # Installation fails if version is 1.55-git
+ sed -e 's/-git//' \
+ -i webapp-config/WebappConfig/version.py \
+ -i WebappConfig/version.py || die "Cannot fix version."
+ fi
+
distutils-r1_python_prepare_all
eprefixify WebappConfig/eprefix.py config/webapp-config
}
@@ -55,6 +67,9 @@ python_install() {
python_install_all() {
distutils-r1_python_install_all
+ # distutils-r1 installs the scripts in /usr/bin in PEP517 mode
+ mv "${ED}"/usr/bin "${ED}"/usr/sbin || die "Cannot rename scripts directory to /usr/sbin"
+
insinto /etc/vhosts
doins config/webapp-config
diff --git a/dev-python/ntlm-auth/Manifest b/dev-python/ntlm-auth/Manifest
deleted file mode 100644
index 40131a38fa80..000000000000
--- a/dev-python/ntlm-auth/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ntlm-auth-1.5.0.tar.gz 41826 BLAKE2B fb313cdb4f1022e0cbc1ffcb048a587baca400a75e053ea8943d960f21746e847080db20169f55e6a3060a8b8502637ce7dc269b66bdaffe98c3f769b2b22358 SHA512 cf08b23e49d45c528404b70b6be88f6c3edee9fd0d4584f3962931a08a0982cdad4089963a95aea911b6eb4db32a932536cf6d9c02c292cd447e0a9c6b3b802b
diff --git a/dev-python/ntlm-auth/metadata.xml b/dev-python/ntlm-auth/metadata.xml
deleted file mode 100644
index 17656002a5da..000000000000
--- a/dev-python/ntlm-auth/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>voyageur@gentoo.org</email>
- <name>Bernard Cafarelli</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="pypi">ntlm-auth</remote-id>
- <remote-id type="github">jborean93/ntlm-auth</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/ntlm-auth/ntlm-auth-1.5.0.ebuild b/dev-python/ntlm-auth/ntlm-auth-1.5.0.ebuild
deleted file mode 100644
index 7441d4b35cf1..000000000000
--- a/dev-python/ntlm-auth/ntlm-auth-1.5.0.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Calculates NTLM Authentication codes"
-HOMEPAGE="https://github.com/jborean93/ntlm-auth"
-SRC_URI="https://github.com/jborean93/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~riscv ~x86"
-
-RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-BDEPEND="test? ( dev-python/requests[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
diff --git a/media-gfx/mcomix/files/mcomix-2.1.1-pillow_version.patch b/media-gfx/mcomix/files/mcomix-2.1.1-pillow_version.patch
new file mode 100644
index 000000000000..b4e51d230292
--- /dev/null
+++ b/media-gfx/mcomix/files/mcomix-2.1.1-pillow_version.patch
@@ -0,0 +1,15 @@
+--- a/mcomix/run.py 2023-07-03 21:39:35.146479272 +0300
++++ b/mcomix/run.py 2023-07-03 21:40:16.742507561 +0300
+@@ -122,7 +122,11 @@
+ try:
+ import PIL.Image
+
+- if PIL.__version__ < '6.0.0':
++ try:
++ pil_major_version = int(PIL.__version__[0:PIL.__version__.index('.')])
++ except (ValueError, IndexError):
++ pil_major_version = 0
++ if pil_major_version < 6:
+ log.error( _("You don't have the required version of the Python Imaging Library Fork (Pillow) installed."))
+ log.error( _('Installed Pillow version is: %s') % PIL.__version__ )
+ log.error( _('Required Pillow version is: 6.0.0 or higher') )
diff --git a/media-gfx/mcomix/mcomix-2.1.1-r1.ebuild b/media-gfx/mcomix/mcomix-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..899761314205
--- /dev/null
+++ b/media-gfx/mcomix/mcomix-2.1.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1 optfeature xdg
+
+DESCRIPTION="GTK image viewer for comic book archives"
+HOMEPAGE="https://mcomix.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=dev-python/pillow-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pycairo-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.36.0[${PYTHON_USEDEP}]
+ media-libs/libjpeg-turbo:0
+ x11-libs/gtk+:3[introspection]"
+BDEPEND="sys-devel/gettext"
+# Most tests are quite old and do not run
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${P}-pillow_version.patch )
+
+src_prepare() {
+ default
+
+ # Uncompress man page
+ gunzip mcomix.1.gz || die
+ sed -e "s/mcomix.1.gz/mcomix.1/" -i setup.py || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "RAR (.cbr) archives" app-arch/unrar
+ optfeature "7Zip archives" app-arch/p7zip
+ optfeature "LHA/LZA archives" app-arch/lha
+ optfeature "PDF files" app-text/mupdf
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 2c6d1adb8635..4f19fde68ead 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -282,11 +282,6 @@ dev-java/netty
# Removal on 2023-07-04.
sci-mathematics/flintqs
-# Michał Górny <mgorny@gentoo.org> (2023-06-03)
-# Obsoleted by dev-python/pyspnego. No revdeps left.
-# Removal on 2023-07-03. Bug #895004.
-dev-python/ntlm-auth
-
# Bernd Waibel <waebbl-gentoo@posteo.net> (2023-05-31)
# Mask this version for uptime soversion issue. There will be an updated release
# shortly which fixes this.