summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-libs/libhandy/Manifest1
-rw-r--r--gui-libs/libhandy/libhandy-0.0.9.ebuild61
-rw-r--r--gui-libs/libhandy/metadata.xml13
-rw-r--r--profiles/package.mask5
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-3.32.4.ebuild84
-rw-r--r--www-client/epiphany/files/var-tmp-tests.patch13
-rw-r--r--x11-plugins/wmmon+smp/Manifest2
-rw-r--r--x11-plugins/wmmon+smp/wmmon+smp-1.0-r3.ebuild6
-rw-r--r--x11-plugins/wmswallow/Manifest2
-rw-r--r--x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild33
11 files changed, 205 insertions, 16 deletions
diff --git a/gui-libs/libhandy/Manifest b/gui-libs/libhandy/Manifest
new file mode 100644
index 000000000000..e5c93a20fa45
--- /dev/null
+++ b/gui-libs/libhandy/Manifest
@@ -0,0 +1 @@
+DIST libhandy-v0.0.9.tar.bz2 110100 BLAKE2B c1abf60b37d76a0b2f0ed82152decc9a87c9feff664af8df91ede192018a70003ac7ff3c1307668e7196089f59bb5dc21d1449ccc1deb3e2e362f32ff8f9f30b SHA512 d3256c2ff49a7fd0ccfec14ba3e34ed51577841c1670902d25f2a0166e63820428e689c722dddbccf787e1380c7f9a8ddc5b9042a1632b688b151ecce0f6d262
diff --git a/gui-libs/libhandy/libhandy-0.0.9.ebuild b/gui-libs/libhandy/libhandy-0.0.9.ebuild
new file mode 100644
index 000000000000..06eafda4c3dc
--- /dev/null
+++ b/gui-libs/libhandy/libhandy-0.0.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg vala virtualx
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="Library with GTK widgets for mobile phones"
+HOMEPAGE="https://source.puri.sm/Librem5/libhandy/"
+SRC_URI="https://source.puri.sm/Librem5/libhandy/-/archive/v${PV}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.0/0" # It may or may not break ABI in future versions at this point; if new
+# SLOT happens, it'll likely file conflict on gtk-doc and glade library and catalog
+KEYWORDS="~amd64"
+
+IUSE="examples glade gtk-doc +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.24.1:3[introspection?]
+ glade? ( dev-util/glade:3.10= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ vala? ( $(vala_depend) )
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofiling=false # -pg passing
+ -Dstatic=false
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ $(meson_use examples)
+ $(meson_feature glade glade_catalog)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
diff --git a/gui-libs/libhandy/metadata.xml b/gui-libs/libhandy/metadata.xml
new file mode 100644
index 000000000000..65bbdf40f15f
--- /dev/null
+++ b/gui-libs/libhandy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <use>
+ <flag name="glade">Install module and catalog for <pkg>dev-util/glade</pkg></flag>
+ </use>
+ <longdescription>libhandy is a collection of GTK+ widgets for applications
+ targeting mobile phones.</longdescription>
+</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 4f3e47ee1a34..c9e7edbcbb21 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -30,6 +30,11 @@
#--- END OF EXAMPLES ---
# Aaron Bauman <bman@gentoo.org> (2019-08-17)
+# Outstanding sec vuln bug #544228. No releases from upstream
+# Upstream still has not addressed the bug. Removal in 30 days.
+dev-python/restkit
+
+# Aaron Bauman <bman@gentoo.org> (2019-08-17)
# Unmaintained, outstanding sec vuln bug #540360
# Lots of new versions upstream. Removal in 30 days.
dev-embedded/bitbake
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 4cbd9fc3fa2e..cfbb3ae297b6 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1 +1,2 @@
DIST epiphany-3.30.4.tar.xz 4531732 BLAKE2B a4741d353800517c0233456e513a974ecd7641799395df7cafe6940cbfa49402836484010634ef3c59e36bd3bb2ced331d19a4ed05d1630c00d7ee385961227b SHA512 8574a26a22a24db7e65254f65723f6e4405fccd783bb7e122f8a5f6aff62d3ef1dd0b3ce903eb1f750e7ae28c2f1154a2c1c15970892216211d51edee318bd47
+DIST epiphany-3.32.4.tar.xz 5468576 BLAKE2B 8d9ed9f522a7f18c1e9b0fa6aea043c11e69eda8ee779e8cb05cbef1920154ee7e307ea92eac713c74f7a81a08d9fc31dfd3ba8fad59d5697f4aa652e12a6e8e SHA512 34f9f4267862b494cbeb225ce63cd7767851f1cca16b4c8e03057b074999954477f2ed891c60f20910abcc7a553371f8f03e59fc9da4cf459dd5cbfde8a6d67c
diff --git a/www-client/epiphany/epiphany-3.32.4.ebuild b/www-client/epiphany/epiphany-3.32.4.ebuild
new file mode 100644
index 000000000000..c69aaaf7987a
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.32.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=dev-libs/nettle-3.4:=
+ >=net-libs/webkit-gtk-2.24.1:4=
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ gnome-base/gsettings-desktop-schemas
+ dev-libs/icu:=
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.2.4
+ >=dev-libs/libdazzle-3.31.90
+ >=gui-libs/libhandy-0.0.9:0.0=
+ >=x11-libs/libnotify-0.5.1
+ >=app-crypt/libsecret-0.14
+ >=net-libs/libsoup-2.48.0:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ dev-db/sqlite:3
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Allow /var/tmp prefixed recursive delete (due to package manager setting TMPDIR)
+ "${FILESDIR}"/var-tmp-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/www-client/epiphany/files/var-tmp-tests.patch b/www-client/epiphany/files/var-tmp-tests.patch
new file mode 100644
index 000000000000..f2a0d97aaf96
--- /dev/null
+++ b/www-client/epiphany/files/var-tmp-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/tests/ephy-file-helpers-test.c b/tests/ephy-file-helpers-test.c
+index b3139b67e..10c884ea5 100644
+--- a/tests/ephy-file-helpers-test.c
++++ b/tests/ephy-file-helpers-test.c
+@@ -87,7 +87,7 @@ test_ephy_file_helpers_init (void)
+ if (keep_dir) {
+ /* As a safety measure, only try recursive delete on paths
+ * prefixed with /tmp. */
+- if (g_str_has_prefix (tmp_dir, "/tmp"))
++ if (g_str_has_prefix (tmp_dir, "/tmp") || g_str_has_prefix (tmp_dir, "/var/tmp"))
+ g_assert_true (ephy_file_delete_dir_recursively (tmp_dir, NULL));
+ else
+ g_warning ("INIT: dangerous path returned as tmp_dir: %s", tmp_dir);
diff --git a/x11-plugins/wmmon+smp/Manifest b/x11-plugins/wmmon+smp/Manifest
index fd5b8aef3ebe..ef5b773998ed 100644
--- a/x11-plugins/wmmon+smp/Manifest
+++ b/x11-plugins/wmmon+smp/Manifest
@@ -1 +1 @@
-DIST wmmon+smp.tar.gz 15807 BLAKE2B e58ad4a1a6f9deb33e031f20674cd6ad4d0a558e84906a470a2b2802df1736dfac4f6a9ae0bfc5f36192684f59374d5cd1d5186ef505f9b4da26082d31f9c728 SHA512 9565815c30642a3d12a23960bf6123eafa9379d24a69b2a75794757e89a3b056669fc47a898a5e756871a74502dcab8b76abe5508f2c5474a1fbfc8bdd4e6a94
+DIST wmmon+smp-1.0.tar.gz 15807 BLAKE2B e58ad4a1a6f9deb33e031f20674cd6ad4d0a558e84906a470a2b2802df1736dfac4f6a9ae0bfc5f36192684f59374d5cd1d5186ef505f9b4da26082d31f9c728 SHA512 9565815c30642a3d12a23960bf6123eafa9379d24a69b2a75794757e89a3b056669fc47a898a5e756871a74502dcab8b76abe5508f2c5474a1fbfc8bdd4e6a94
diff --git a/x11-plugins/wmmon+smp/wmmon+smp-1.0-r3.ebuild b/x11-plugins/wmmon+smp/wmmon+smp-1.0-r3.ebuild
index 45c4bc627777..8c90cc0ff0cb 100644
--- a/x11-plugins/wmmon+smp/wmmon+smp-1.0-r3.ebuild
+++ b/x11-plugins/wmmon+smp/wmmon+smp-1.0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,10 +7,10 @@ inherit toolchain-funcs
DESCRIPTION="Dockapp CPU monitor resembling Xosview, support for smp"
HOMEPAGE="http://www.ne.jp/asahi/linux/timecop/"
-SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/wmmon+smp.tar.gz"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/wmmon+smp.tar.gz -> ${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 ppc64 x86"
RDEPEND="
diff --git a/x11-plugins/wmswallow/Manifest b/x11-plugins/wmswallow/Manifest
index ed945a89292c..a43de4916d9f 100644
--- a/x11-plugins/wmswallow/Manifest
+++ b/x11-plugins/wmswallow/Manifest
@@ -1 +1 @@
-DIST wmswallow.tar.Z 28567 BLAKE2B 3fb5c39fd07c4cce329f0b60abea72d0c42203bedd36f55994bc16f36412843aef81bc985a6acb9cea0b279f900f84ffc99bc088b5343e2997f6d3951bca4bba SHA512 24ef61a4084bda49afd6a7168600d99c60fe85daab6d16733fd208a905966433ca3d031a1d991676f3e73cb8a3a552c49fe69cfb4e1271e7c9a09d9247c21cdc
+DIST wmswallow-0.6.1.tar.Z 28567 BLAKE2B 3fb5c39fd07c4cce329f0b60abea72d0c42203bedd36f55994bc16f36412843aef81bc985a6acb9cea0b279f900f84ffc99bc088b5343e2997f6d3951bca4bba SHA512 24ef61a4084bda49afd6a7168600d99c60fe85daab6d16733fd208a905966433ca3d031a1d991676f3e73cb8a3a552c49fe69cfb4e1271e7c9a09d9247c21cdc
diff --git a/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild b/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
index d5ab7c82a729..5821727229a1 100644
--- a/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
+++ b/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
@@ -1,34 +1,45 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="A dock applet to make any application dockable"
HOMEPAGE="https://www.dockapps.net/wmswallow"
-SRC_URI="https://www.dockapps.net/download/${PN}.tar.Z"
+SRC_URI="https://www.dockapps.net/download/${PN}.tar.Z -> ${P}.tar.Z"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXext"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
-S=${WORKDIR}/wmswallow
+S="${WORKDIR}/${PN}"
+PATCHES=( "${FILESDIR}"/${P}-format-security.patch )
src_prepare() {
- epatch "${FILESDIR}"/${P}-format-security.patch
- sed -e "s:\${OBJS} -o:\${OBJS} \${LDFLAGS} -o:" \
- -e "/LIBS/s/-lXext/-lX11 \0/"\
- -i Makefile || die
+ default
+
+ # the Makefile is a mess, just
+ # rely on implicit rules instead
+ rm Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags x11 xext)
+ export LDLIBS="$($(tc-getPKG_CONFIG) --libs x11 xext)"
}
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" xfree
+ emake wmswallow
}
src_install() {