summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/elfutils/Manifest1
-rw-r--r--dev-libs/elfutils/elfutils-0.181.ebuild86
-rw-r--r--dev-libs/elfutils/files/elfutils-0.181-CC-in-tests-p2.patch34
3 files changed, 121 insertions, 0 deletions
diff --git a/dev-libs/elfutils/Manifest b/dev-libs/elfutils/Manifest
index f8c5896077eb..f54bc77fa62c 100644
--- a/dev-libs/elfutils/Manifest
+++ b/dev-libs/elfutils/Manifest
@@ -1 +1,2 @@
DIST elfutils-0.180.tar.bz2 9079640 BLAKE2B bd7863b82a71d2932a23c9d125d5eb6485977a3256a8a0b25980183d33f7345c3d9fae78277de5c955eb0ceeb955f8fa71d209f4f39bcf6dd49e46a8bbd7efcf SHA512 62e96035ccfe8928baca2285decbe8b8703a2daa956df81ece18fecf643272fb68955806b3e807a514141a7a9bf44520bf09461672aa580bd6807485fb604d25
+DIST elfutils-0.181.tar.bz2 9088984 BLAKE2B 3f35f1a494986ff23d755188aab2b8f5ca9729927dd0e01725abf8477ac09721f751ff79686aafeff3878cf52e0c3f3e06d794fdf6371382a1bffc85c0de3411 SHA512 d565541d5817f409dc89ebb1ee593366f69c371a1531308eeb67ff934b14a0fab0c9009fd7c23240efbaa1b4e04edac5c425e47d80e3e66ba03dcaf000afea36
diff --git a/dev-libs/elfutils/elfutils-0.181.ebuild b/dev-libs/elfutils/elfutils-0.181.ebuild
new file mode 100644
index 000000000000..e0947ea4dfd8
--- /dev/null
+++ b/dev-libs/elfutils/elfutils-0.181.ebuild
@@ -0,0 +1,86 @@
+# Copyright 2003-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multilib-minimal toolchain-funcs
+
+DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
+HOMEPAGE="http://elfutils.org/"
+SRC_URI="https://sourceware.org/elfutils/ftp/${PV}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2+ LGPL-3+ ) utils? ( GPL-3+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 lzma nls static-libs test +threads +utils valgrind"
+
+RDEPEND=">=sys-libs/zlib-1.2.8-r1[static-libs?,${MULTILIB_USEDEP}]
+ bzip2? ( >=app-arch/bzip2-1.0.6-r4[static-libs?,${MULTILIB_USEDEP}] )
+ lzma? ( >=app-arch/xz-utils-5.0.5-r1[static-libs?,${MULTILIB_USEDEP}] )
+ !dev-libs/libelf"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )
+"
+BDEPEND="nls? ( sys-devel/gettext )
+ >=sys-devel/flex-2.5.4a
+ sys-devel/m4"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.175-disable-biarch-test-PR24158.patch
+ "${FILESDIR}"/${PN}-0.177-disable-large.patch
+ "${FILESDIR}"/${PN}-0.180-PaX-support.patch
+ "${FILESDIR}"/${PN}-0.179-CC-in-tests.patch
+ "${FILESDIR}"/${PN}-0.181-CC-in-tests-p2.patch
+)
+
+src_prepare() {
+ default
+
+ if ! use static-libs; then
+ sed -i -e '/^lib_LIBRARIES/s:=.*:=:' -e '/^%.os/s:%.o$::' lib{asm,dw,elf}/Makefile.in || die
+ fi
+ # https://sourceware.org/PR23914
+ sed -i 's:-Werror::' */Makefile.in || die
+}
+
+src_configure() {
+ use test && append-flags -g #407135
+
+ # Symbol aliases are implemented as asm statements.
+ # Will require porting: https://gcc.gnu.org/PR48200
+ filter-flags '-flto*'
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable nls) \
+ $(use_enable threads thread-safety) \
+ $(use_enable valgrind) \
+ --disable-debuginfod \
+ --program-prefix="eu-" \
+ --with-zlib \
+ $(use_with bzip2 bzlib) \
+ $(use_with lzma)
+}
+
+multilib_src_test() {
+ # CC is a workaround for tests using ${CC-gcc}
+ env LD_LIBRARY_PATH="${BUILD_DIR}/libelf:${BUILD_DIR}/libebl:${BUILD_DIR}/libdw:${BUILD_DIR}/libasm" \
+ LC_ALL="C" \
+ CC="$(tc-getCC)" \
+ emake check VERBOSE=1
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dodoc NOTES
+ # These build quick, and are needed for most tests, so don't
+ # disable their building when the USE flag is disabled.
+ if ! use utils; then
+ rm -rf "${ED}"/usr/bin || die
+ fi
+}
diff --git a/dev-libs/elfutils/files/elfutils-0.181-CC-in-tests-p2.patch b/dev-libs/elfutils/files/elfutils-0.181-CC-in-tests-p2.patch
new file mode 100644
index 000000000000..63c0ed0cb608
--- /dev/null
+++ b/dev-libs/elfutils/files/elfutils-0.181-CC-in-tests-p2.patch
@@ -0,0 +1,34 @@
+--- a/tests/run-test-includes.sh
++++ b/tests/run-test-includes.sh
+@@ -3,24 +3,24 @@
+ . $srcdir/test-subr.sh
+
+ echo '#include "libelf.h"' \
+- | gcc -c -o /dev/null -I ${abs_srcdir}/../libelf -xc -
++ | ${CC-gcc} -c -o /dev/null -I ${abs_srcdir}/../libelf -xc -
+ echo '#include "gelf.h"' \
+- | gcc -c -o /dev/null -I ${abs_srcdir}/../libelf -xc -
++ | ${CC-gcc} -c -o /dev/null -I ${abs_srcdir}/../libelf -xc -
+
+ echo '#include "dwarf.h"' \
+- | gcc -c -o /dev/null -I ${abs_srcdir}/../libelf \
++ | ${CC-gcc} -c -o /dev/null -I ${abs_srcdir}/../libelf \
+ -I ${abs_srcdir}/../libdw -xc -
+ echo '#include "libdw.h"' \
+- | gcc -c -o /dev/null -I ${abs_srcdir}/../libelf \
++ | ${CC-gcc} -c -o /dev/null -I ${abs_srcdir}/../libelf \
+ -I ${abs_srcdir}/../libdw -xc -
+
+ echo '#include "libdwfl.h"' \
+- | gcc -c -o /dev/null -I ${abs_srcdir}/../libelf \
++ | ${CC-gcc} -c -o /dev/null -I ${abs_srcdir}/../libelf \
+ -I ${abs_srcdir}/../libdw -I ${abs_srcdir}/../libdwfl -xc -
+ echo '#include "libdwelf.h"' \
+- | gcc -c -o /dev/null -I ${abs_srcdir}/../libelf \
++ | ${CC-gcc} -c -o /dev/null -I ${abs_srcdir}/../libelf \
+ -I ${abs_srcdir}/../libdw -I ${abs_srcdir}/../libdwelf -xc -
+
+ echo '#include "libasm.h"' \
+- | gcc -c -o /dev/null -I ${abs_srcdir}/../libelf \
++ | ${CC-gcc} -c -o /dev/null -I ${abs_srcdir}/../libelf \
+ -I ${abs_srcdir}/../libasm -xc -