summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/grantlee/files/grantlee-5.1.0-cxx11.patch24
-rw-r--r--dev-libs/grantlee/grantlee-5.1.0.ebuild9
2 files changed, 29 insertions, 4 deletions
diff --git a/dev-libs/grantlee/files/grantlee-5.1.0-cxx11.patch b/dev-libs/grantlee/files/grantlee-5.1.0-cxx11.patch
new file mode 100644
index 000000000000..d049d6c96f81
--- /dev/null
+++ b/dev-libs/grantlee/files/grantlee-5.1.0-cxx11.patch
@@ -0,0 +1,24 @@
+From 3a5fc7662da3261be6496611900c095844e56ab1 Mon Sep 17 00:00:00 2001
+From: Albert Astals Cid <aacid@kde.org>
+Date: Sat, 20 Jul 2019 17:35:30 +0200
+Subject: [PATCH] Fix compile with newer Qt/cmake combination
+
+Without this i get huge errors about Qt needing C++11 support
+---
+ CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6d51110..0859788 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -11,6 +11,9 @@ endif()
+
+ project(Grantlee)
+
++set (CMAKE_CXX_STANDARD 11)
++set (CMAKE_CXX_EXTENSIONS OFF)
++
+ # Workaround for http://public.kitware.com/Bug/view.php?id=12301
+ if (MINGW)
+ if(NOT CMAKE_BUILD_TYPE)
diff --git a/dev-libs/grantlee/grantlee-5.1.0.ebuild b/dev-libs/grantlee/grantlee-5.1.0.ebuild
index d8de4e45a9f6..8bcda9a613cb 100644
--- a/dev-libs/grantlee/grantlee-5.1.0.ebuild
+++ b/dev-libs/grantlee/grantlee-5.1.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
VIRTUALX_REQUIRED="test"
inherit cmake-utils virtualx
@@ -15,25 +15,26 @@ SLOT="5"
KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
IUSE="debug doc test"
+BDEPEND="
+ doc? ( app-doc/doxygen[dot] )
+"
RDEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtscript:5
"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )
test? ( dev-qt/qttest:5 )
"
# bug 682258
RESTRICT="test"
-DOCS=( AUTHORS CHANGELOG README.md )
-
PATCHES=(
"${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
"${FILESDIR}/${P}-slot.patch"
"${FILESDIR}/${P}-qt-5.13.patch"
+ "${FILESDIR}/${P}-cxx11.patch"
)
src_prepare() {