summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/waylandpp/Manifest1
-rw-r--r--dev-cpp/waylandpp/waylandpp-0.1.6.ebuild41
-rw-r--r--sys-power/powertop/Manifest4
-rw-r--r--sys-power/powertop/powertop-1.13.ebuild43
-rw-r--r--sys-power/powertop/powertop-2.6.ebuild106
-rw-r--r--sys-power/powertop/powertop-2.8.ebuild10
6 files changed, 45 insertions, 160 deletions
diff --git a/dev-cpp/waylandpp/Manifest b/dev-cpp/waylandpp/Manifest
index 2bf3409846ba..64ae534e52cc 100644
--- a/dev-cpp/waylandpp/Manifest
+++ b/dev-cpp/waylandpp/Manifest
@@ -2,3 +2,4 @@ DIST waylandpp-0.1.0.tar.gz 166427 BLAKE2B eef7f14df491e053f2c8cb63aaafc9e9251af
DIST waylandpp-0.1.2.tar.gz 166624 BLAKE2B 8136fb8c7ece2a2ce9d93bd833dbc9c604c47dfd27b17cda60b0c5894d4aada7761e220d9cabf8e5107115e00d2d16fd99a098dac9be6614926b428ea234d788 SHA512 2304390be26134561fb69e208a6bafd0e9789e6b212ff2f46384c6ed50ae1c9eca3f06a3b4958c8e710cc1a0be61ed84c7ff292ec7011dbb0396cd2d83363f7f
DIST waylandpp-0.1.4.tar.gz 168409 BLAKE2B 43811051f1c4cf8795c63d24c54f6f3fac59bf4a482b9dd0f3e2645272475abc732a44330e08449e34f67aa90224382d18ffb0e6f52d9f250685813186ad6e97 SHA512 3f2e9bca0776c02ec3b7a4f76a34214333e0663e2ab81d81cfbc37e1f14bda47e16b3840386b961d47ca993207b0b9f4d4859b621f22fe4e3653c4b14842e001
DIST waylandpp-0.1.5.tar.gz 168432 BLAKE2B 0d3efcb489a713be1ae9db0366b47436b0789468b956ac781f981b3bf1feaebdf2be083f6d1263190e202a45e4416d2d972ffc67d8b87115146f14a5c4af41a5 SHA512 bce1f29607fe61f4b8464abc6111121e3c18777d2e982f143b33087d53af58e9d3a61e412c46dbe73d8cbbaa889da806978e9b3854ce01db8feb53d777625a6f
+DIST waylandpp-0.1.6.tar.gz 180123 BLAKE2B 552dbea6b6d9c3f937aa56a69c90485f6946366589793e53817bada7b2dc1eca0c58a741b22f5f0f7fac04bb14d668f01a1c2418343ebf32845dc1bf02656957 SHA512 93ed7157017394f7df0d7cdf2f56e1d8621893cc8cb77b01206534b8ca40528aba6bd2b922b359809bdca7831fa45668f85903e9e3dd6f0759839c7318349c94
diff --git a/dev-cpp/waylandpp/waylandpp-0.1.6.ebuild b/dev-cpp/waylandpp/waylandpp-0.1.6.ebuild
new file mode 100644
index 000000000000..e8100f35eb98
--- /dev/null
+++ b/dev-cpp/waylandpp/waylandpp-0.1.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils versionator
+
+DESCRIPTION="Wayland C++ bindings"
+HOMEPAGE="https://github.com/NilsBrause/waylandpp"
+
+LICENSE="MIT"
+IUSE="doc"
+SLOT="0/$(get_major_version)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/NilsBrause/waylandpp.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ >=dev-libs/wayland-1.11.0
+ media-libs/mesa[wayland]
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ "
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/sys-power/powertop/Manifest b/sys-power/powertop/Manifest
index 80fbb4f41e22..25ec6b5378fb 100644
--- a/sys-power/powertop/Manifest
+++ b/sys-power/powertop/Manifest
@@ -1,3 +1 @@
-DIST powertop-1.13.tar.gz 104675 SHA256 2bc866089496877dd26d2d316ad5763ab8ecb5e28aefba44bc5d355dcdc58d98 SHA512 0c22a903da64798d987492336d57260372e03eab067ad94cf30b7640e9ee05e759a2fe9fa48fbdc35404cd2782b6b29d705e11e68452653b08f7f9df1a52be44 WHIRLPOOL 5ba44b84f49609f67c32563f75e20f6576c21a93fcb1ca99ebfe064475397602aa0f0fb9575e05b5a0290983791e7cf6ebae0139b39158b962e4b51027a6f5aa
-DIST powertop-2.6.tar.gz 3024009 SHA256 3024c2b13c8f32cdac0b0ea9359eb5668dc9bd11776cf063481daa878533d1ee SHA512 7c44b9c49f74d0f415d0332b60629940e05cf1c9170a9a7b98427da630c25c0cc9c8ece49e059ec8c665847ff03fa8a341e0cf8f7ca792d889f2c52a39ddbb62 WHIRLPOOL eaa6e05d2fdb3050eb3a37f39fb5d760a8d3d91461b8c6f0ae825138080a0dd8a532e490a71246d62d2e340e3820b402d761a1331a6e7b6bc23db116c98cf0d9
-DIST powertop-2.8.tar.gz 670000 SHA256 a87b563f73106babfa3e74dcf92f252938c061e309ace20a361358bbfa579c5a SHA512 253d0e15f0972cf8639735c510f4884d49a0da76c31dd2f39603e2297e6c6f0b9fa283c7b3cb04a431c91f8296275c0adaecc4c3e9ea132c0c31064f7f432c80 WHIRLPOOL 87b859b76395d6b1b380c7459b0d918713e94e8fc4ac40fde8b82f2112dec2df3caffb645b082cedd0bba5c232555de26e81fbe8dd3041875c32c864650ef132
+DIST powertop-2.8.tar.gz 670000 BLAKE2B 4259f462d36fe0cbb157859d6e1d3e1face67f7232fe8d4112d77f844b545f49e9cf486e21bcbc34f64ffb0c891c1864141784dde14e3a96647d6535641a840a SHA512 253d0e15f0972cf8639735c510f4884d49a0da76c31dd2f39603e2297e6c6f0b9fa283c7b3cb04a431c91f8296275c0adaecc4c3e9ea132c0c31064f7f432c80
diff --git a/sys-power/powertop/powertop-1.13.ebuild b/sys-power/powertop/powertop-1.13.ebuild
deleted file mode 100644
index 2ed77ddd6c55..000000000000
--- a/sys-power/powertop/powertop-1.13.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=3
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="tool that helps you find what software is using the most power"
-HOMEPAGE="http://www.lesswatts.org/projects/powertop/"
-SRC_URI="http://www.lesswatts.org/projects/powertop/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ppc sparc x86 ~amd64-linux ~x86-linux"
-IUSE="unicode"
-
-DEPEND="sys-libs/ncurses[unicode?]
- sys-devel/gettext"
-RDEPEND="sys-libs/ncurses[unicode?]
- virtual/libintl
- sys-apps/pciutils"
-
-src_prepare() {
- sed -i '/${CFLAGS}/s:$: ${LDFLAGS}:' Makefile
- use unicode || sed -i 's:-lncursesw:-lncurses:' Makefile
-}
-
-src_configure() {
- tc-export CC
-}
-
-src_install() {
- emake install DESTDIR="${ED}" || die
- dodoc Changelog README
- gunzip "${ED}"/usr/share/man/man1/powertop.1.gz
-}
-
-pkg_postinst() {
- echo
- einfo "For PowerTOP to work best, use a Linux kernel with the"
- einfo "tickless idle (NO_HZ) feature enabled (version 2.6.21 or later)"
- echo
-}
diff --git a/sys-power/powertop/powertop-2.6.ebuild b/sys-power/powertop/powertop-2.6.ebuild
deleted file mode 100644
index 05849a56292b..000000000000
--- a/sys-power/powertop/powertop-2.6.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils linux-info autotools
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/fenrus75/powertop.git"
- inherit git-2 autotools
- SRC_URI=""
-else
- SRC_URI="https://01.org/sites/default/files/downloads/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 arm ppc sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="tool that helps you find what software is using the most power"
-HOMEPAGE="https://01.org/powertop/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="unicode X"
-
-COMMON_DEPEND="
- dev-libs/libnl:3
- sys-apps/pciutils
- sys-libs/ncurses:*[unicode?]
-"
-
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- sys-devel/gettext
-"
-RDEPEND="
- ${COMMON_DEPEND}
- X? ( x11-apps/xset )
- virtual/libintl
-"
-
-DOCS=( TODO README )
-
-S="${WORKDIR}/${PN}"
-
-pkg_setup() {
- CONFIG_CHECK="
- ~X86_MSR
- ~DEBUG_FS
- ~PERF_EVENTS
- ~TRACEPOINTS
- ~NO_HZ
- ~HIGH_RES_TIMERS
- ~HPET_TIMER
- ~CPU_FREQ_STAT
- ~CPU_FREQ_GOV_ONDEMAND
- ~FTRACE
- ~BLK_DEV_IO_TRACE
- ~TIMER_STATS
- ~TRACING
- "
- ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
- ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
- ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_TRACEPOINTS="TRACEPOINTS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_NO_HZ="NO_HZ should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_HIGH_RES_TIMERS="HIGH_RES_TIMERS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
- ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
- ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_TRACING="TRACING should be enabled in the kernel for full powertop function"
- linux-info_pkg_setup
- if linux_config_exists; then
- if kernel_is -lt 3 7 0; then
- if linux_chkconfig_present SND_HDA_INTEL; then
- CONFIG_CHECK="~SND_HDA_POWER_SAVE"
- ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
- check_extra_config
- fi
- fi
- if kernel_is -lt 3 9 0; then
- CONFIG_CHECK="~EVENT_POWER_TRACING_DEPRECATED"
- ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
- check_extra_config
- fi
- if kernel_is -lt 3 19; then
- CONFIG_CHECK="~PM_RUNTIME"
- ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
- check_extra_config
- else
- CONFIG_CHECK="~PM"
- ERROR_KERNEL_PM="PM should be enabled in the kernel for full powertop function"
- check_extra_config
- fi
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/powertop-2.4-tinfo.patch
- eautoreconf
-}
-
-src_configure() {
- export ac_cv_search_delwin=$(usex unicode -lncursesw -lncurses)
- default
-}
diff --git a/sys-power/powertop/powertop-2.8.ebuild b/sys-power/powertop/powertop-2.8.ebuild
index d3d8039ade6e..ab67bbf8ed91 100644
--- a/sys-power/powertop/powertop-2.8.ebuild
+++ b/sys-power/powertop/powertop-2.8.ebuild
@@ -4,14 +4,8 @@
EAPI="5"
inherit eutils linux-info
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/fenrus75/powertop.git"
- inherit git-2 autotools
- SRC_URI=""
-else
- SRC_URI="https://01.org/sites/default/files/downloads/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 arm ppc sparc x86 ~amd64-linux ~x86-linux"
-fi
+SRC_URI="https://01.org/sites/default/files/downloads/${PN}/${P}.tar.gz"
+KEYWORDS="amd64 arm ppc sparc x86 ~amd64-linux ~x86-linux"
DESCRIPTION="tool that helps you find what software is using the most power"
HOMEPAGE="https://01.org/powertop/"