summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/mujs/mujs-1.3.3.ebuild2
-rw-r--r--eclass/distutils-r1.eclass27
-rw-r--r--eclass/python-utils-r1.eclass6
-rw-r--r--gui-wm/hyprland/hyprland-0.25.0.ebuild3
-rw-r--r--x11-misc/xpad/xpad-5.8.0-r1.ebuild2
5 files changed, 24 insertions, 16 deletions
diff --git a/dev-lang/mujs/mujs-1.3.3.ebuild b/dev-lang/mujs/mujs-1.3.3.ebuild
index 6c8aa130e526..a4c0c10c9f34 100644
--- a/dev-lang/mujs/mujs-1.3.3.ebuild
+++ b/dev-lang/mujs/mujs-1.3.3.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://mujs.com/downloads/${P}.tar.gz"
LICENSE="ISC"
# The subslot matches the SONAME
SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
RDEPEND="sys-libs/readline:="
DEPEND="${RDEPEND}"
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index ec1dd08b197c..0ccd59fb6c78 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -220,7 +220,7 @@ _distutils_set_globals() {
;;
hatchling)
bdep+='
- >=dev-python/hatchling-1.12.2[${PYTHON_USEDEP}]
+ >=dev-python/hatchling-1.17.0[${PYTHON_USEDEP}]
'
;;
jupyter)
@@ -230,7 +230,7 @@ _distutils_set_globals() {
;;
maturin)
bdep+='
- >=dev-util/maturin-0.14.10[${PYTHON_USEDEP}]
+ >=dev-util/maturin-0.14.17[${PYTHON_USEDEP}]
'
;;
no)
@@ -239,7 +239,7 @@ _distutils_set_globals() {
;;
meson-python)
bdep+='
- >=dev-python/meson-python-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/meson-python-0.12.1[${PYTHON_USEDEP}]
'
;;
pbr)
@@ -249,23 +249,23 @@ _distutils_set_globals() {
;;
pdm)
bdep+='
- >=dev-python/pdm-pep517-1.0.6[${PYTHON_USEDEP}]
+ >=dev-python/pdm-pep517-1.1.4[${PYTHON_USEDEP}]
'
;;
poetry)
bdep+='
- >=dev-python/poetry-core-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/poetry-core-1.5.2[${PYTHON_USEDEP}]
'
;;
setuptools)
bdep+='
- >=dev-python/setuptools-67.2.0[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.38.4[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-67.7.2[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.40.0[${PYTHON_USEDEP}]
'
;;
sip)
bdep+='
- >=dev-python/sip-6.7.5-r1[${PYTHON_USEDEP}]
+ >=dev-python/sip-6.7.8[${PYTHON_USEDEP}]
'
;;
standalone)
@@ -600,7 +600,7 @@ distutils_enable_tests() {
test_pkg=">=dev-python/nose-1.3.7_p20221026"
;;
pytest)
- test_pkg=">=dev-python/pytest-7.2.1"
+ test_pkg=">=dev-python/pytest-7.3.1"
;;
setup.py)
;;
@@ -925,6 +925,11 @@ _distutils-r1_print_package_versions() {
dev-python/gpep517
dev-python/installer
)
+ if [[ ${DISTUTILS_EXT} ]]; then
+ packages+=(
+ dev-python/cython
+ )
+ fi
case ${DISTUTILS_USE_PEP517} in
flit)
packages+=(
@@ -1828,6 +1833,10 @@ distutils-r1_run_phase() {
if [[ ${DISTUTILS_EXT} ]]; then
local -x CPPFLAGS="${CPPFLAGS} $(usex debug '-UNDEBUG' '-DNDEBUG')"
+ # always generate .c files from .pyx files to ensure we get latest
+ # bug fixes from Cython (this works only when setup.py is using
+ # cythonize() but it's better than nothing)
+ local -x CYTHON_FORCE_REGEN=1
fi
# How to build Python modules in different worlds...
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index 40792714cc56..52e9e061d6bd 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -441,13 +441,13 @@ _python_export() {
local d
case ${impl} in
python3.10)
- PYTHON_PKG_DEP=">=dev-lang/python-3.10.9-r1:3.10";;
+ PYTHON_PKG_DEP=">=dev-lang/python-3.10.11:3.10";;
python3.11)
- PYTHON_PKG_DEP=">=dev-lang/python-3.11.1-r1:3.11";;
+ PYTHON_PKG_DEP=">=dev-lang/python-3.11.3:3.11";;
python3.12)
PYTHON_PKG_DEP=">=dev-lang/python-3.12.0_beta1:3.12";;
pypy3)
- PYTHON_PKG_DEP='>=dev-python/pypy3-7.3.11-r1:0=';;
+ PYTHON_PKG_DEP='>=dev-python/pypy3-7.3.11_p1:0=';;
*)
die "Invalid implementation: ${impl}"
esac
diff --git a/gui-wm/hyprland/hyprland-0.25.0.ebuild b/gui-wm/hyprland/hyprland-0.25.0.ebuild
index 923882538f0e..bf62573979c1 100644
--- a/gui-wm/hyprland/hyprland-0.25.0.ebuild
+++ b/gui-wm/hyprland/hyprland-0.25.0.ebuild
@@ -6,8 +6,7 @@ EAPI=8
inherit meson toolchain-funcs
DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
-HOMEPAGE="https://github.com/hyprwm/Hyprland/releases"
-
+HOMEPAGE="https://github.com/hyprwm/Hyprland"
SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${PF}.gh.tar.gz"
S="${WORKDIR}/${PN}-source"
diff --git a/x11-misc/xpad/xpad-5.8.0-r1.ebuild b/x11-misc/xpad/xpad-5.8.0-r1.ebuild
index 4c5b67b4ce67..167db33db01b 100644
--- a/x11-misc/xpad/xpad-5.8.0-r1.ebuild
+++ b/x11-misc/xpad/xpad-5.8.0-r1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
+KEYWORDS="amd64 ~arm ~x86"
RDEPEND="
>=app-accessibility/at-spi2-core-2.46.0:2