summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyglet/Manifest2
-rw-r--r--dev-python/pyglet/pyglet-2.0.2.1.ebuild81
-rw-r--r--dev-python/pyglet/pyglet-2.0.3.ebuild81
-rw-r--r--eclass/desktop.eclass6
-rw-r--r--media-sound/abcmidi/abcmidi-2023.01.21.ebuild2
-rw-r--r--media-sound/mpd/mpd-0.23.12.ebuild2
-rw-r--r--media-video/pipewire/pipewire-0.3.65-r3.ebuild2
-rw-r--r--profiles/arch/arm64/package.use.stable.mask7
-rw-r--r--sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild2
-rw-r--r--sys-devel/clang/clang-16.0.0.9999.ebuild3
-rw-r--r--sys-devel/clang/clang-17.0.0.9999.ebuild3
-rw-r--r--sys-firmware/sof-firmware/sof-firmware-2.2.3.ebuild4
-rw-r--r--x11-wm/qtile/qtile-0.22.1-r1.ebuild4
-rw-r--r--x11-wm/qtile/qtile-9999.ebuild8
14 files changed, 24 insertions, 183 deletions
diff --git a/dev-python/pyglet/Manifest b/dev-python/pyglet/Manifest
index 87193dea8c3d..8fce3498b75f 100644
--- a/dev-python/pyglet/Manifest
+++ b/dev-python/pyglet/Manifest
@@ -1,4 +1,2 @@
DIST pyglet-1.5.27.gh.tar.gz 6532179 BLAKE2B f1dc668530a69e275860befe11f4c86003c5de2dadede706df7abac9eb6fb1729ea030c7053f0149926f3ffdd12985d9abea4afac65de3b6b7541fe871eda369 SHA512 98896dab06873cbf3cdd0d4015cb0b9e062cffb1110908bd422ecdc4f0e16943adc8a4986e7dbfdae4392e82ac115bad6f937896e166989ad2c4d73a0f45c8be
-DIST pyglet-2.0.2.1.gh.tar.gz 6206090 BLAKE2B e671e1800f8f9e80ff301692973e6085c63b751944d221added744edf3910dd13c15f741637b23f04777b64bfe2865698410be1859009bc1455cf51458e8916a SHA512 4b6d4883025b55d7e1515c65c0b18a5b24d152a5e7f547379329388046c2f1818f9e203d2913825a1156eb3271100b6257f334310959c2e7a1b4ba2b61f2d398
-DIST pyglet-2.0.3.gh.tar.gz 6213542 BLAKE2B 7a47df69761d718e6b1a700105ca7e75b650109d37bea340cae147885ea2158da9af45c9c5733cd6cdc41e17800471921457dda281285e4c6836191200a92be2 SHA512 7617c34dfc65d8a957e6e4093c467d2debcd36e053ef0e1b350cc63fa886e59a6e8cfa0bbbc9db163c736f5ec975c0a105f7ccb0c8bb193744b692d550e0f757
DIST pyglet-2.0.4.gh.tar.gz 6172461 BLAKE2B aa52844336b2fa34c6d75c8ee45070b7d8b85c283e374daeffa21367d6ddefaf39c22258eb00c666dad1f5ee8d157c0b1716a5cd1329942e98538e8172ed6137 SHA512 c26c59b9f7e6f2b1bd20456917ed50d6b70169dd2af5b92cc61d0e0515dc7c989eba9b41e00a106510d53e8ea218cde185f8b5038428490f3b9b3623a2f40207
diff --git a/dev-python/pyglet/pyglet-2.0.2.1.ebuild b/dev-python/pyglet/pyglet-2.0.2.1.ebuild
deleted file mode 100644
index acb6828c1351..000000000000
--- a/dev-python/pyglet/pyglet-2.0.2.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 virtualx xdg-utils
-
-DESCRIPTION="Cross-platform windowing and multimedia library for Python"
-HOMEPAGE="
- https://pyglet.org/
- https://github.com/pyglet/pyglet/
- https://pypi.org/project/pyglet/
-"
-SRC_URI="https://github.com/pyglet/pyglet/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86 ~amd64-linux ~x86-linux"
-IUSE="examples image +sound"
-
-BDEPEND="
- test? (
- dev-python/pillow[${PYTHON_USEDEP}]
- media-libs/fontconfig
- )
-"
-RDEPEND="
- virtual/glu
- virtual/opengl
- image? ( || (
- dev-python/pillow[${PYTHON_USEDEP}]
- x11-libs/gtk+:2
- ) )
- sound? ( || (
- media-libs/openal
- media-sound/pulseaudio
- ) )
-"
-# ffmpeg? ( media-libs/avbin-bin )
-
-distutils_enable_tests pytest
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- xdg_environment_reset
-
- local EPYTEST_DESELECT=(
- # lacking device/server permissions
- tests/unit/media/test_listener.py::test_openal_listener
- tests/unit/media/test_listener.py::test_pulse_listener
- # fragile to load
- tests/unit/test_clock_freq.py::test_elapsed_time_between_tick
- )
- if [[ ${EPYTHON} == python3.11 ]]; then
- EPYTEST_DESELECT+=(
- # broken test
- # https://github.com/pyglet/pyglet/issues/606
- tests/unit/test_events.py::test_push_handlers_instance
- )
- fi
-
- # Specify path to avoid running interactive tests
- # We could add in integration tests, but they're slow
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- nonfatal epytest tests/unit || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyglet/pyglet-2.0.3.ebuild b/dev-python/pyglet/pyglet-2.0.3.ebuild
deleted file mode 100644
index 9128e56e22ef..000000000000
--- a/dev-python/pyglet/pyglet-2.0.3.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 virtualx xdg-utils
-
-DESCRIPTION="Cross-platform windowing and multimedia library for Python"
-HOMEPAGE="
- https://pyglet.org/
- https://github.com/pyglet/pyglet/
- https://pypi.org/project/pyglet/
-"
-SRC_URI="https://github.com/pyglet/pyglet/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples image +sound"
-
-BDEPEND="
- test? (
- dev-python/pillow[${PYTHON_USEDEP}]
- media-libs/fontconfig
- )
-"
-RDEPEND="
- virtual/glu
- virtual/opengl
- image? ( || (
- dev-python/pillow[${PYTHON_USEDEP}]
- x11-libs/gtk+:2
- ) )
- sound? ( || (
- media-libs/openal
- media-sound/pulseaudio
- ) )
-"
-# ffmpeg? ( media-libs/avbin-bin )
-
-distutils_enable_tests pytest
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- xdg_environment_reset
-
- local EPYTEST_DESELECT=(
- # lacking device/server permissions
- tests/unit/media/test_listener.py::test_openal_listener
- tests/unit/media/test_listener.py::test_pulse_listener
- # fragile to load
- tests/unit/test_clock_freq.py::test_elapsed_time_between_tick
- )
- if [[ ${EPYTHON} == python3.11 ]]; then
- EPYTEST_DESELECT+=(
- # broken test
- # https://github.com/pyglet/pyglet/issues/606
- tests/unit/test_events.py::test_push_handlers_instance
- )
- fi
-
- # Specify path to avoid running interactive tests
- # We could add in integration tests, but they're slow
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- nonfatal epytest tests/unit || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/eclass/desktop.eclass b/eclass/desktop.eclass
index aa1b9ac68d85..780971342ba1 100644
--- a/eclass/desktop.eclass
+++ b/eclass/desktop.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: desktop.eclass
@@ -311,7 +311,7 @@ _iconins() {
size=${2}
fi
case ${size} in
- 16|22|24|32|36|48|64|72|96|128|192|256|512)
+ 16|22|24|32|36|48|64|72|96|128|192|256|512|1024)
size=${size}x${size};;
symbolic|scalable)
;;
@@ -369,7 +369,7 @@ _iconins() {
# !!! must specify to install into /usr/share/icons/... !!!
# size of the icon, like 48 or 48x48
# supported icon sizes are:
-# 16 22 24 32 36 48 64 72 96 128 192 256 512 scalable
+# 16 22 24 32 36 48 64 72 96 128 192 256 512 1024 scalable
# -c, --context
# defaults to "apps"
# -t, --theme
diff --git a/media-sound/abcmidi/abcmidi-2023.01.21.ebuild b/media-sound/abcmidi/abcmidi-2023.01.21.ebuild
index 636c9619449a..3ca144cfe9f4 100644
--- a/media-sound/abcmidi/abcmidi-2023.01.21.ebuild
+++ b/media-sound/abcmidi/abcmidi-2023.01.21.ebuild
@@ -13,7 +13,7 @@ S="${WORKDIR}"/${PN}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="examples"
BDEPEND="app-arch/unzip"
diff --git a/media-sound/mpd/mpd-0.23.12.ebuild b/media-sound/mpd/mpd-0.23.12.ebuild
index 4e3c7f3a3c39..b3eb078ef3b7 100644
--- a/media-sound/mpd/mpd-0.23.12.ebuild
+++ b/media-sound/mpd/mpd-0.23.12.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://www.musicpd.org/download/${PN}/${PV%.*}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ppc64 ~riscv ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 ~riscv ~x86"
IUSE="+alsa ao +audiofile bzip2 cdio chromaprint +cue +curl doc +dbus
+eventfd expat faad +ffmpeg +fifo flac fluidsynth gme +icu +id3tag +inotify
jack lame libmpdclient libsamplerate libsoxr +mad mikmod mms
diff --git a/media-video/pipewire/pipewire-0.3.65-r3.ebuild b/media-video/pipewire/pipewire-0.3.65-r3.ebuild
index 7e07410dfab4..25e528688b6c 100644
--- a/media-video/pipewire/pipewire-0.3.65-r3.ebuild
+++ b/media-video/pipewire/pipewire-0.3.65-r3.ebuild
@@ -29,7 +29,7 @@ else
SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.bz2"
fi
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ KEYWORDS="~amd64 arm arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
DESCRIPTION="Multimedia processing graphs"
diff --git a/profiles/arch/arm64/package.use.stable.mask b/profiles/arch/arm64/package.use.stable.mask
index 99fa2c94bc8e..364b7b9b0867 100644
--- a/profiles/arch/arm64/package.use.stable.mask
+++ b/profiles/arch/arm64/package.use.stable.mask
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Sam James <sam@gentoo.org> (2022-07-06)
@@ -127,11 +127,6 @@ media-libs/opencv contribcvv contribhdf contribsfm glog gstreamer
# Respective x11-drivers/ not tested and stable yet
x11-base/xorg-drivers input_devices_elographics input_devices_joystick input_devices_void video_cards_dummy video_cards_fbdev video_cards_nouveau
-# Mart Raudsepp <leio@gentoo.org> (2018-05-29)
-# dev-libs/xapian, app-text/texlive not stable yet
-# USE=doc requires USE=latex
-app-doc/doxygen doxysearch doc
-
# Michał Górny <mgorny@gentoo.org> (2018-04-15)
# Non-stable dependencies.
app-admin/syslog-ng spoof-source
diff --git a/sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild b/sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild
index 7cb34a8756d3..28312cad9867 100644
--- a/sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild
+++ b/sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
DOCS_BUILDER="sphinx"
DOCS_DEPEND="dev-python/sphinx-rtd-theme"
DOCS_DIR="docs/source"
diff --git a/sys-devel/clang/clang-16.0.0.9999.ebuild b/sys-devel/clang/clang-16.0.0.9999.ebuild
index 6a4c9a3aefe0..4bc824e6a52a 100644
--- a/sys-devel/clang/clang-16.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-16.0.0.9999.ebuild
@@ -277,6 +277,9 @@ multilib_src_configure() {
# disable using CUDA to autodetect GPU, just build for all
-DCMAKE_DISABLE_FIND_PACKAGE_CUDA=ON
+ # disable linking to HSA to avoid automagic dep,
+ # load it dynamically instead
+ -DCMAKE_DISABLE_FIND_PACKAGE_hsa-runtime64=ON
-DCLANG_DEFAULT_PIE_ON_LINUX=$(usex pie)
diff --git a/sys-devel/clang/clang-17.0.0.9999.ebuild b/sys-devel/clang/clang-17.0.0.9999.ebuild
index 6a4c9a3aefe0..4bc824e6a52a 100644
--- a/sys-devel/clang/clang-17.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-17.0.0.9999.ebuild
@@ -277,6 +277,9 @@ multilib_src_configure() {
# disable using CUDA to autodetect GPU, just build for all
-DCMAKE_DISABLE_FIND_PACKAGE_CUDA=ON
+ # disable linking to HSA to avoid automagic dep,
+ # load it dynamically instead
+ -DCMAKE_DISABLE_FIND_PACKAGE_hsa-runtime64=ON
-DCLANG_DEFAULT_PIE_ON_LINUX=$(usex pie)
diff --git a/sys-firmware/sof-firmware/sof-firmware-2.2.3.ebuild b/sys-firmware/sof-firmware/sof-firmware-2.2.3.ebuild
index b51c9026bd32..82f72de46998 100644
--- a/sys-firmware/sof-firmware/sof-firmware-2.2.3.ebuild
+++ b/sys-firmware/sof-firmware/sof-firmware-2.2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -10,7 +10,7 @@ S="${WORKDIR}"/sof-bin-v${PV}
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
# Needed for sof-ctl
RDEPEND="media-libs/alsa-lib"
diff --git a/x11-wm/qtile/qtile-0.22.1-r1.ebuild b/x11-wm/qtile/qtile-0.22.1-r1.ebuild
index b977e32eec6b..558b0bda0dee 100644
--- a/x11-wm/qtile/qtile-0.22.1-r1.ebuild
+++ b/x11-wm/qtile/qtile-0.22.1-r1.ebuild
@@ -23,6 +23,8 @@ LICENSE="MIT"
SLOT="0"
IUSE="pulseaudio wayland"
+# See bug #895722 and https://github.com/qtile/qtile/pull/3985 regarding
+# pywlroots-0.15 dep.
RDEPEND="
>=dev-python/cairocffi-0.9.0[${PYTHON_USEDEP}]
>=dev-python/cffi-1.1.0[${PYTHON_USEDEP}]
@@ -37,7 +39,7 @@ RDEPEND="
media-sound/pulseaudio
)
wayland? (
- dev-python/pywlroots[${PYTHON_USEDEP}]
+ =dev-python/pywlroots-0.15*[${PYTHON_USEDEP}]
)
"
BDEPEND="
diff --git a/x11-wm/qtile/qtile-9999.ebuild b/x11-wm/qtile/qtile-9999.ebuild
index 871b161d1af7..02efe955cdc0 100644
--- a/x11-wm/qtile/qtile-9999.ebuild
+++ b/x11-wm/qtile/qtile-9999.ebuild
@@ -16,13 +16,15 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/qtile/qtile.git"
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~riscv ~x86"
fi
LICENSE="MIT"
SLOT="0"
IUSE="pulseaudio wayland"
+# See bug #895722 and https://github.com/qtile/qtile/pull/3985 regarding
+# pywlroots-0.15 dep.
RDEPEND="
>=dev-python/cairocffi-0.9.0[${PYTHON_USEDEP}]
>=dev-python/cffi-1.1.0[${PYTHON_USEDEP}]
@@ -37,7 +39,7 @@ RDEPEND="
media-sound/pulseaudio
)
wayland? (
- dev-python/pywlroots[${PYTHON_USEDEP}]
+ =dev-python/pywlroots-0.15*[${PYTHON_USEDEP}]
)
"
BDEPEND="
@@ -83,7 +85,7 @@ python_test() {
# Force usage of built module
rm -rf "${S}"/libqtile || die
- # TODO: remove "-p no:xdist" when https://github.com/qtile/qtile/issues/1634 will be resolved.
+ # TODO: remove "-p no:xdist" for next release when https://github.com/qtile/qtile/issues/1634 will be resolved.
epytest -p no:xdist --backend=x11 $(usev wayland '--backend=wayland') || die "Tests failed with ${EPYTHON}"
}