summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/mpv/mpv-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index bbc72b9d5470..21f1b6bab92b 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -33,6 +33,7 @@ IUSE="+alsa aqua archive bluray cdda +cli coreaudio cplugins cuda doc drm dvb
luajit openal +opengl oss pulseaudio raspberry-pi rubberband samba sdl
selinux test tools +uchardet v4l vaapi vdpau vf-dlopen wayland +X xinerama
+xscreensaver +xv zsh-completion"
+IUSE+=" cpu_flags_x86_sse4_1"
REQUIRED_USE="
|| ( cli libmpv )
@@ -143,6 +144,9 @@ mpv_check_compiler() {
if ( use opengl || use egl ) && ! tc-has-tls; then
die "Your compiler lacks C++11 TLS support. Use GCC>=4.8 or Clang>=3.3."
fi
+ if use vaapi && use cpu_flags_x86_sse4_1 && ! tc-is-gcc; then
+ die "${PN} requires GCC for SSE4.1 intrinsics."
+ fi
fi
}