summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/flag-o-matic.eclass4
-rw-r--r--mail-mta/postfix/postfix-3.9.1.ebuild2
-rw-r--r--net-mail/tpop3d/tpop3d-1.5.5-r5.ebuild8
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild4
-rw-r--r--sys-process/numad/numad-9999.ebuild17
5 files changed, 15 insertions, 20 deletions
diff --git a/eclass/flag-o-matic.eclass b/eclass/flag-o-matic.eclass
index 3e67e3b4c11f..9590192bb1f4 100644
--- a/eclass/flag-o-matic.eclass
+++ b/eclass/flag-o-matic.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: flag-o-matic.eclass
@@ -201,7 +201,7 @@ _filter-hardened() {
continue
fi
- is-flagq -fno-stack-protector-all || append-flags $(test-flags -fno-stack-protector-all)
+ is-flagq -fno-stack-protector || append-flags $(test-flags -fno-stack-protector)
;;
-fno-strict-overflow)
gcc-specs-nostrict || continue
diff --git a/mail-mta/postfix/postfix-3.9.1.ebuild b/mail-mta/postfix/postfix-3.9.1.ebuild
index 9be1f4697c8e..1d6f2ef8823a 100644
--- a/mail-mta/postfix/postfix-3.9.1.ebuild
+++ b/mail-mta/postfix/postfix-3.9.1.ebuild
@@ -16,7 +16,7 @@ S="${WORKDIR}/${MY_SRC}"
LICENSE="|| ( IBM EPL-2.0 )"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~mips ppc ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="+berkdb cdb dovecot-sasl +eai ldap ldap-bind lmdb mbox memcached mongodb mysql nis pam postgres sasl selinux sqlite ssl"
diff --git a/net-mail/tpop3d/tpop3d-1.5.5-r5.ebuild b/net-mail/tpop3d/tpop3d-1.5.5-r5.ebuild
index 546c0f2a23ed..b74d5ddaf8e4 100644
--- a/net-mail/tpop3d/tpop3d-1.5.5-r5.ebuild
+++ b/net-mail/tpop3d/tpop3d-1.5.5-r5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic autotools
+inherit autotools
DESCRIPTION="An extensible POP3 server with vmail-sql/MySQL support"
HOMEPAGE="https://savannah.nongnu.org/projects/tpop3d/"
@@ -76,10 +76,6 @@ src_configure() {
use tcpd && myconf="${myconf} --enable-tcp-wrappers"
econf ${myconf}
-
- # Causes crash with "stack smashing attack" on connect, because of bug in
- # SSP (bug #115285)
- filter-flags -fstack-protector
}
src_install() {
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 9622057c7724..3d994649ea35 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -492,10 +492,6 @@ setup_flags() {
# https://sourceware.org/glibc/wiki/FAQ#Why_do_I_get:.60.23error_.22glibc_cannot_be_compiled_without_optimization.22.27.2C_when_trying_to_compile_GNU_libc_with_GNU_CC.3F
replace-flags -O0 -O1
- # glibc handles this internally already where it's appropriate;
- # can't always have SSP when we're the ones setting it up, etc
- filter-flags '-fstack-protector*'
-
# Similar issues as with SSP. Can't inject yourself that early.
filter-flags '-fsanitize=*'
diff --git a/sys-process/numad/numad-9999.ebuild b/sys-process/numad/numad-9999.ebuild
index fffe3f4192c1..453dd705cae3 100644
--- a/sys-process/numad/numad-9999.ebuild
+++ b/sys-process/numad/numad-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit flag-o-matic linux-info systemd toolchain-funcs
+inherit linux-info systemd toolchain-funcs
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://pagure.io/numad.git"
@@ -25,13 +25,16 @@ SLOT="0"
CONFIG_CHECK="~NUMA ~CPUSETS"
+PATCHES=(
+ # https://pagure.io/numad/pull-request/3
+ "${FILESDIR}/${PN}-0.5-fix-sparse-node-ids.patch"
+
+ # from debian/ubuntu: https://sources.debian.org/patches/numad
+ "${FILESDIR}/${PN}-0.5-fix-build-for-no-NR-migrate-pages.patch"
+)
+
src_configure() {
tc-export AR CC RANLIB
-
- # FIXME: https://bugs.gentoo.org/890985
- # temp workaround
- filter-flags -D_FORTIFY_SOURCE=3
- append-cppflags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
}
src_compile() {