summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dns/libidn2/libidn2-0.10-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-dns/libidn2/libidn2-0.10-r1.ebuild b/net-dns/libidn2/libidn2-0.10-r1.ebuild
new file mode 100644
index 000000000000..6290b07978da
--- /dev/null
+++ b/net-dns/libidn2/libidn2-0.10-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools multilib-minimal
+
+DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
+HOMEPAGE="https://www.gnu.org/software/libidn/#libidn2"
+SRC_URI="mirror://gnu-alpha/libidn/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-examples.patch
+ "${FILESDIR}"/${P}-Werror.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}