summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/xmlcopyeditor/files/xmlcopyeditor-1.2.1.3-no-automagic-enchant.patch19
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3-r1.ebuild (renamed from app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3.ebuild)15
2 files changed, 28 insertions, 6 deletions
diff --git a/app-editors/xmlcopyeditor/files/xmlcopyeditor-1.2.1.3-no-automagic-enchant.patch b/app-editors/xmlcopyeditor/files/xmlcopyeditor-1.2.1.3-no-automagic-enchant.patch
new file mode 100644
index 000000000000..435b777b43d7
--- /dev/null
+++ b/app-editors/xmlcopyeditor/files/xmlcopyeditor-1.2.1.3-no-automagic-enchant.patch
@@ -0,0 +1,19 @@
+--- xmlcopyeditor-1.2.1.3.orig/configure.ac
++++ xmlcopyeditor-1.2.1.3/configure.ac
+@@ -139,13 +139,9 @@
+ AC_CHECK_HEADER(expat.h, ,
+ AC_MSG_ERROR([Expat headers not found]))
+
+-# Check enchant is available
+-PKG_CHECK_MODULES(ENCHANT, [enchant], [CXXFLAGS="$CXXFLAGS -DUSE_ENCHANT"],
+- # otherwise Check ASPELL is available
+- [AC_CHECK_HEADER(aspell.h, [ASPELL_LIBS="-laspell"],
+- AC_MSG_ERROR([Aspell headers not found]))]
+-)
+-
++# Check Aspell is available
++AC_CHECK_HEADER(aspell.h, [ASPELL_LIBS="-laspell"],
++ AC_MSG_ERROR([Aspell headers not found]))
+ AC_SUBST(ASPELL_LIBS)
+
+ # Check gtk
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3-r1.ebuild
index f8f58ca6770f..d56c500752b8 100644
--- a/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3.ebuild
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3-r1.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-
+EAPI=6
WX_GTK_VER="3.0"
inherit autotools wxwidgets
@@ -23,14 +22,18 @@ RDEPEND="
dev-libs/xerces-c[icu]
dev-libs/libpcre
!aqua? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
- aqua? ( x11-libs/wxGTK:${WX_GTK_VER}[aqua] )"
+ aqua? ( x11-libs/wxGTK:${WX_GTK_VER}[aqua] )
+"
DEPEND="${RDEPEND}
dev-libs/boost
- dev-util/intltool"
+ dev-util/intltool
+"
-DOCS=( AUTHORS ChangeLog README NEWS )
+PATCHES=( "${FILESDIR}"/${P}-no-automagic-enchant.patch )
src_prepare() {
+ default
+
# bug #440744
sed -i -e 's/ -Wall -g -fexceptions//g' configure.ac || die
eautoreconf