summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/pecl-redis/Manifest1
-rw-r--r--dev-php/pecl-redis/pecl-redis-6.1.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/Manifest b/dev-php/pecl-redis/Manifest
index 09a00eb96549..86558e64c39d 100644
--- a/dev-php/pecl-redis/Manifest
+++ b/dev-php/pecl-redis/Manifest
@@ -1 +1,2 @@
DIST redis-6.0.2.tgz 365966 BLAKE2B d8baebb64e1a2b8799da151253b98d045beebcbdadae7b6081f3a8e29fe20ca0928cac027ebb74264b25b900d7c04ea2e15a07b20090aa529299808878fc45d0 SHA512 1918d15433d1b4d782a9fb0364f6dfeed8d9e6c2ae70c34e235be5f890992c73a40ef19842e0aabb181da86dd2cde28b9aebab8698b387738321298a2ab94aa6
+DIST redis-6.1.0.tgz 373740 BLAKE2B 9ad24fb1968a8873bcc38a53fa1f3f15b44b2423785c3c8d50c4ea4bdb7a5ddbb3148a579b8bf8676307c48adb319ffe78854e580ff034e21c0584f3501ea59f SHA512 731697b429f8070ae33f02b6a302904c6e8e79c8d6fd3d07b9fcdb50f55b52448292a936ca4050406d14b6db11669269a315c798ce52a80e4857427a65b01dff
diff --git a/dev-php/pecl-redis/pecl-redis-6.1.0.ebuild b/dev-php/pecl-redis/pecl-redis-6.1.0.ebuild
new file mode 100644
index 000000000000..84df442bf7cd
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-6.1.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PHP_EXT_NAME="redis"
+USE_PHP="php8-2 php8-3"
+PHP_EXT_NEEDED_USE="json(+)?,session(-)?"
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP extension for interfacing with Redis"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="igbinary +json lz4 +session zstd"
+
+DEPEND="
+ igbinary? ( >=dev-php/igbinary-3.0.1-r1[php_targets_php8-2(-)?,php_targets_php8-3(-)?] )
+ lz4? ( app-arch/lz4:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}
+ !dev-php/pecl-redis:7"
+
+# The test suite requires network access.
+RESTRICT=test
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-redis
+ --disable-redis-lzf
+ --disable-redis-msgpack
+ $(use_enable igbinary redis-igbinary)
+ $(use_enable json redis-json)
+ $(use_enable lz4 redis-lz4)
+ $(use_with lz4 liblz4)
+ $(use_enable session redis-session)
+ $(use_enable zstd redis-zstd)
+ $(use_with zstd libzstd)
+ )
+ php-ext-source-r3_src_configure
+}
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Run tests for Redis class
+ ${PHPCLI} -d extension=modules/redis.so \
+ tests/TestRedis.php \
+ --class Redis \
+ --host ${PECL_REDIS_HOST} || die 'test suite failed'
+ done
+}