summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-doc/doxygen/doxygen-1.8.11-r2.ebuild (renamed from app-doc/doxygen/doxygen-1.8.11-r1.ebuild)36
-rw-r--r--app-doc/doxygen/doxygen-9999.ebuild36
2 files changed, 0 insertions, 72 deletions
diff --git a/app-doc/doxygen/doxygen-1.8.11-r1.ebuild b/app-doc/doxygen/doxygen-1.8.11-r2.ebuild
index d7d281deeb07..6f49a8b2c2ab 100644
--- a/app-doc/doxygen/doxygen-1.8.11-r1.ebuild
+++ b/app-doc/doxygen/doxygen-1.8.11-r2.ebuild
@@ -24,13 +24,6 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="clang debug doc dot doxysearch latex qt5 sqlite userland_GNU"
-#missing SerbianCyrilic, JapaneseEn, KoreanEn, Chinesetraditional
-LANGS=(hy ar pt_BR ca zh cs de da eo es fa fi fr el hr hu id it ja ko lt mk
-nl nb pl pt ro ru sl sk sr sv tr uk vi af)
-for X in "${LANGS[@]}" ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
RDEPEND="app-text/ghostscript-gpl
dev-lang/perl
media-libs/libpng:0=
@@ -61,34 +54,6 @@ DEPEND="sys-apps/sed
RESTRICT="test"
EPATCH_SUFFIX="patch"
-get_langs() {
- # using only user set linguas also fixes #263641
- my_linguas=()
- for lingua in ${LINGUAS}; do
- if has ${lingua} "${LANGS[@]}"; then
- case ${lingua} in
- hy) lingua=am ;;
- pt_BR) lingua=br ;;
- zh*) lingua=cn ;;
- cs) lingua=cz ;;
- da) lingua=dk ;;
- el*) lingua=gr ;;
- ja*) lingua=jp ;;
- ko) lingua=kr ;;
- nb) lingua=no ;;
- sl) lingua=si ;;
- tr*) lingua=tr ;;
- uk) lingua=ua ;;
- af) lingua=za ;;
- esac
- has ${lingua} "${my_linguas[@]}" ||
- my_linguas+=(${lingua})
- fi
- done
- f_langs="${my_linguas[@]^^}"
- echo ${f_langs// /;}
-}
-
pkg_setup() {
use doc && python-any-r1_pkg_setup
}
@@ -126,7 +91,6 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DDOC_INSTALL_DIR="share/doc/${P}"
- -DLANG_CODES="$(get_langs)"
$(cmake-utils_use clang use_libclang)
$(cmake-utils_use doc build_doc)
$(cmake-utils_use doxysearch build_search)
diff --git a/app-doc/doxygen/doxygen-9999.ebuild b/app-doc/doxygen/doxygen-9999.ebuild
index fbd083eb686b..ec664ad6131d 100644
--- a/app-doc/doxygen/doxygen-9999.ebuild
+++ b/app-doc/doxygen/doxygen-9999.ebuild
@@ -25,13 +25,6 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="clang debug doc dot doxysearch latex qt5 sqlite userland_GNU"
-#missing SerbianCyrilic, JapaneseEn, KoreanEn, Chinesetraditional
-LANGS=(hy ar pt_BR ca zh cs de da eo es fa fi fr el hr hu id it ja ko lt mk
-nl nb pl pt ro ru sl sk sr sv tr uk vi af)
-for X in "${LANGS[@]}" ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
RDEPEND="app-text/ghostscript-gpl
dev-lang/perl
media-libs/libpng:0=
@@ -62,34 +55,6 @@ DEPEND="sys-apps/sed
RESTRICT="test"
EPATCH_SUFFIX="patch"
-get_langs() {
- # using only user set linguas also fixes #263641
- my_linguas=()
- for lingua in ${LINGUAS}; do
- if has ${lingua} "${LANGS[@]}"; then
- case ${lingua} in
- hy) lingua=am ;;
- pt_BR) lingua=br ;;
- zh*) lingua=cn ;;
- cs) lingua=cz ;;
- da) lingua=dk ;;
- el*) lingua=gr ;;
- ja*) lingua=jp ;;
- ko) lingua=kr ;;
- nb) lingua=no ;;
- sl) lingua=si ;;
- tr*) lingua=tr ;;
- uk) lingua=ua ;;
- af) lingua=za ;;
- esac
- has ${lingua} "${my_linguas[@]}" ||
- my_linguas+=(${lingua})
- fi
- done
- f_langs="${my_linguas[@]^^}"
- echo ${f_langs// /;}
-}
-
pkg_setup() {
use doc && python-any-r1_pkg_setup
}
@@ -125,7 +90,6 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DDOC_INSTALL_DIR="share/doc/${P}"
- -DLANG_CODES="$(get_langs)"
$(cmake-utils_use clang use_libclang)
$(cmake-utils_use doc build_doc)
$(cmake-utils_use doxysearch build_search)