summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/i3-gaps/Manifest1
-rw-r--r--x11-wm/i3-gaps/files/i3-gaps-4.15-musl.patch73
-rw-r--r--x11-wm/i3-gaps/i3-gaps-4.15.0.1.ebuild87
3 files changed, 0 insertions, 161 deletions
diff --git a/x11-wm/i3-gaps/Manifest b/x11-wm/i3-gaps/Manifest
index b401a04fccb8..4d3541756866 100644
--- a/x11-wm/i3-gaps/Manifest
+++ b/x11-wm/i3-gaps/Manifest
@@ -1,2 +1 @@
-DIST i3-gaps-4.15.0.1.tar.gz 3965631 BLAKE2B ea65886c40f377125bafbd80e2d56c1d66a4c5c06d942d645b2cb226323a0903e98aa58b67da9c31c60240b5d99d10ecc20864aeede95a5039ea0ffdff8dcb8b SHA512 76ff860e4ca0edd0e22bdff9ae9b1bc150df2b5bc15b0d7ea7a63d373e8d156a43bd91f8a40c48b4c771603f7de7c18c6d16c53fef582e53f51c53a197fa7a0a
DIST i3-gaps-4.16.1.tar.gz 3983420 BLAKE2B f0d5a85b06ce33e1cc177af6da29f9cdf42ed754bb767aa9eaa5ab52f3b9f4f688d251f2a16fb222fc8cf5052e79859891c4185b1325b2ef6c1a813aa220468c SHA512 904c2f63c6a35573f13fd216625c1349ac71de70ae8f0440667c9d76048cdaf30a398ab358f2366d5f46502d87e801713b625cb509a05f39dbca1371d2b8d0e9
diff --git a/x11-wm/i3-gaps/files/i3-gaps-4.15-musl.patch b/x11-wm/i3-gaps/files/i3-gaps-4.15-musl.patch
deleted file mode 100644
index 82ad6195b8e5..000000000000
--- a/x11-wm/i3-gaps/files/i3-gaps-4.15-musl.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-diff -urp i3-4.11/i3bar/src/main.c i3-4.11.new/i3bar/src/main.c
---- i3-4.11/i3bar/src/main.c 2015-09-30 07:55:10.000000000 +0100
-+++ i3-4.11.new/i3bar/src/main.c 2016-02-08 20:03:41.777392482 +0000
-@@ -45,14 +45,20 @@ void debuglog(char *fmt, ...) {
- *
- */
- char *expand_path(char *path) {
-- static glob_t globbuf;
-- if (glob(path, GLOB_NOCHECK | GLOB_TILDE, NULL, &globbuf) < 0) {
-- ELOG("glob() failed\n");
-- exit(EXIT_FAILURE);
-+ char *home, *expanded;
-+
-+ if (strncmp(path, "~/", 2) == 0) {
-+ home = getenv("HOME");
-+ if (home != NULL) {
-+ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
-+ expanded = scalloc(strlen(home)+strlen(path), 1);
-+ strcpy(expanded, home);
-+ strcat(expanded, path+1);
-+ return expanded;
-+ }
- }
-- char *result = sstrdup(globbuf.gl_pathc > 0 ? globbuf.gl_pathv[0] : path);
-- globfree(&globbuf);
-- return result;
-+
-+ return sstrdup(path);
- }
-
- void print_usage(char *elf_name) {
-diff -urp i3-4.11/libi3/resolve_tilde.c i3-4.11.new/libi3/resolve_tilde.c
---- i3-4.11/libi3/resolve_tilde.c 2015-09-30 07:55:10.000000000 +0100
-+++ i3-4.11.new/libi3/resolve_tilde.c 2016-02-08 20:03:47.849230953 +0000
-@@ -19,27 +19,18 @@
- *
- */
- char *resolve_tilde(const char *path) {
-- static glob_t globbuf;
-- char *head, *tail, *result;
-+ char *home, *expanded;
-
-- tail = strchr(path, '/');
-- head = sstrndup(path, tail ? (size_t)(tail - path) : strlen(path));
--
-- int res = glob(head, GLOB_TILDE, NULL, &globbuf);
-- free(head);
-- /* no match, or many wildcard matches are bad */
-- if (res == GLOB_NOMATCH || globbuf.gl_pathc != 1)
-- result = sstrdup(path);
-- else if (res != 0) {
-- err(EXIT_FAILURE, "glob() failed");
-- } else {
-- head = globbuf.gl_pathv[0];
-- result = scalloc(strlen(head) + (tail ? strlen(tail) : 0) + 1, 1);
-- strncpy(result, head, strlen(head));
-- if (tail)
-- strncat(result, tail, strlen(tail));
-+ if (strncmp(path, "~/", 2) == 0) {
-+ home = getenv("HOME");
-+ if (home != NULL) {
-+ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
-+ expanded = scalloc(strlen(home)+strlen(path), 1);
-+ strcpy(expanded, home);
-+ strcat(expanded, path+1);
-+ return expanded;
-+ }
- }
-- globfree(&globbuf);
-
-- return result;
-+ return sstrdup(path);
- }
diff --git a/x11-wm/i3-gaps/i3-gaps-4.15.0.1.ebuild b/x11-wm/i3-gaps/i3-gaps-4.15.0.1.ebuild
deleted file mode 100644
index a4357937c21a..000000000000
--- a/x11-wm/i3-gaps/i3-gaps-4.15.0.1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools eapi7-ver
-
-DESCRIPTION="i3 fork with gaps and some more features"
-HOMEPAGE="https://github.com/Airblader/i3"
-SRC_URI="https://github.com/Airblader/i3/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-CDEPEND="
- dev-libs/glib:2
- dev-libs/libev
- dev-libs/libpcre
- dev-libs/yajl
- x11-libs/cairo[X,xcb]
- x11-libs/libxcb[xkb]
- x11-libs/libxkbcommon[X]
- x11-libs/pango[X]
- x11-libs/startup-notification
- x11-libs/xcb-util
- x11-libs/xcb-util-cursor
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-wm
- x11-libs/xcb-util-xrm
-"
-DEPEND="${CDEPEND}
- virtual/pkgconfig
-"
-RDEPEND="${CDEPEND}
- dev-lang/perl
- dev-perl/AnyEvent-I3
- dev-perl/JSON-XS
- !x11-wm/i3
-"
-
-S=${WORKDIR}/i3-${PV}
-
-DOCS=( RELEASE-NOTES-$(ver_cut 1-2) )
-
-PATCHES=( "${FILESDIR}/${PN}-$(ver_cut 1-2)-musl.patch" )
-
-src_prepare() {
- default
- sed -e '/AC_PATH_PROG(\[PATH_ASCIIDOC/d' -i configure.ac || die
- eautoreconf
- cat <<- EOF > "${T}"/i3wm
- #!/bin/sh
- exec /usr/bin/i3
- EOF
-}
-
-src_configure() {
- # disable sanitizer: otherwise injects -O0 -g
- local myeconfargs=(
- --enable-debug=no
- --disable-sanitizers
- )
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- emake -C "${CBUILD}"
-}
-
-src_install() {
- emake -C "${CBUILD}" DESTDIR="${D}" install
- einstalldocs
-
- exeinto /etc/X11/Sessions
- doexe "${T}"/i3wm
-}
-
-pkg_postinst() {
- einfo "There are several packages that you may find useful with ${PN} and"
- einfo "their usage is suggested by the upstream maintainers, namely:"
- einfo " x11-misc/dmenu"
- einfo " x11-misc/i3lock"
- einfo " x11-misc/i3status"
- einfo "Please refer to their description for additional info."
-}