summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/chromium/Manifest2
-rw-r--r--www-client/chromium/chromium-69.0.3493.3.ebuild (renamed from www-client/chromium/chromium-69.0.3452.0.ebuild)33
-rw-r--r--www-client/chromium/files/chromium-compiler-r4.patch168
3 files changed, 178 insertions, 25 deletions
diff --git a/www-client/chromium/Manifest b/www-client/chromium/Manifest
index 41ac555615bb..16151f92e13e 100644
--- a/www-client/chromium/Manifest
+++ b/www-client/chromium/Manifest
@@ -2,5 +2,5 @@ DIST chromium-67.0.3396.87.tar.xz 591491608 BLAKE2B 9069c4b2e000e180a9b21bbdbb67
DIST chromium-67.0.3396.99.tar.xz 592170796 BLAKE2B c214f2feb911bd375849f1c69a67dad797111107be7d8c7b99f503e67a62212c0340c8c21b1922cf0a5bfdc32507dfe337a9cddeb29674067c08e6e21a8585a5 SHA512 b1cc7f5988d30efae0b3954232a402e2906bb27113f453a67d865a79afecf6a124c7833635d6083ea40f0cb7344e3cdb4a02f3b8ba4b1cd9798b5d2bccb23242
DIST chromium-68.0.3440.25.tar.xz 624353904 BLAKE2B 8ed052e5ad831499367ef1e6d40d08bb585e49855f4c6b820d5532c96f240ad312e66484b75b5b8398e737e2400b7ff1f9edd944b5f6a16d81ace019f6dd0952 SHA512 c82436dc42dd9ee1b87881d617f6c791a9dc04d85bb1d4588a3cf31009edd8aeb9d89c357581f705e3602580be1d70ab5fd85f629abf7c7f647fa8a5f06f3add
DIST chromium-68.0.3440.68.tar.xz 630241852 BLAKE2B c18ed31b87c8617f5776a63a4e7c816bf1ef5974ce74a662ba8bb35dde2aac7b4b1c23c52b4b6530d5998e0cc4cb42bcf88f07acbe8e4fc550257cfab536b86f SHA512 ca1458bd93425c77420ee991c6f9ab2624d9ae14dc457468146b0cecee097eb73bee8ee6c623aac67e8425713bde15f015094c96085086c084d924f5f25383c0
-DIST chromium-69.0.3452.0.tar.xz 627961940 BLAKE2B d7e910c746f485595e180b2733ac6bd012ef2a58b72107ce7e8f0a2d30a3b1fa1274b93a607cd05e9a86d4f68520af1cbe5b97b828a9d9d5dd6fde0837995880 SHA512 3dc005c8c93eced4275e5baf01e17582c95e4278a4497d2e1f0c95ab0dc426753bb6a6440d1cc654847d58524f01e4edd2a24f90c54e4202e96bb68b2b127df8
DIST chromium-69.0.3464.0.tar.xz 634891812 BLAKE2B 2cff114b4c6af03d3a6bc79df68876d38d9d8cc972faed2d3d0a3c565911fb2d32e467a4cff1ca8d5c234fece983ab1bb1b5be12bfdc1041d823fde645050f7e SHA512 d14414be553faa9d327dbb9348edcbc755f7f8346825c5144e65a25acb21eec07c34713180ed5701830ccadda99c171e279ae40a620c9babd187d0d093c8a87b
+DIST chromium-69.0.3493.3.tar.xz 622878800 BLAKE2B 46aabdf4032471db8c6b461ebce6cfbc4fe99be55b959134c950bbba63d2c303673f48bb10004698f79abd4e22aa8b8c390ff6a12210020cf6bd8cf6cf8d8060 SHA512 96393f8939fccc8514094f9215496883f416669e61feb45b706610f67ff90672a88f9154fb06e59dec9d363c5e9a072bf1f2ba562dd533345a493664dabcb19e
diff --git a/www-client/chromium/chromium-69.0.3452.0.ebuild b/www-client/chromium/chromium-69.0.3493.3.ebuild
index f6ce8e32881c..42156a1df106 100644
--- a/www-client/chromium/chromium-69.0.3452.0.ebuild
+++ b/www-client/chromium/chromium-69.0.3493.3.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="~amd64"
IUSE="component-build cups gnome-keyring +hangouts jumbo-build kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +system-icu +system-libvpx +tcmalloc widevine"
RESTRICT="!system-ffmpeg? ( proprietary-codecs? ( bindist ) )"
@@ -80,6 +80,7 @@ COMMON_DEPEND="
RDEPEND="${COMMON_DEPEND}
!=www-client/chromium-9999
!<www-plugins/chrome-binary-plugins-57
+ dev-util/gn
x11-misc/xdg-utils
virtual/opengl
virtual/ttf-fonts
@@ -130,15 +131,12 @@ GTK+ icon theme.
"
PATCHES=(
+ "${FILESDIR}/chromium-compiler-r4.patch"
"${FILESDIR}/chromium-widevine-r2.patch"
- "${FILESDIR}/chromium-compiler-r2.patch"
"${FILESDIR}/chromium-webrtc-r0.patch"
"${FILESDIR}/chromium-memcpy-r0.patch"
"${FILESDIR}/chromium-math.h-r0.patch"
"${FILESDIR}/chromium-stdint.patch"
- "${FILESDIR}/chromium-ffmpeg-r1.patch"
- "${FILESDIR}/chromium-libwebp-shim-r0.patch"
- "${FILESDIR}/chromium-disable_xml_catalogs.patch"
)
pre_build_checks() {
@@ -207,6 +205,7 @@ src_prepare() {
net/third_party/quic
net/third_party/spdy
third_party/WebKit
+ third_party/abseil-cpp
third_party/analytics
third_party/angle
third_party/angle/src/common/third_party/base
@@ -217,6 +216,9 @@ src_prepare() {
third_party/angle/third_party/glslang
third_party/angle/third_party/spirv-headers
third_party/angle/third_party/spirv-tools
+ third_party/angle/third_party/vulkan-headers
+ third_party/angle/third_party/vulkan-loader
+ third_party/angle/third_party/vulkan-tools
third_party/angle/third_party/vulkan-validation-layers
third_party/apple_apsl
third_party/blink
@@ -266,6 +268,7 @@ src_prepare() {
third_party/libXNVCtrl
third_party/libaddressinput
third_party/libaom
+ third_party/libaom/source/libaom/third_party/vector
third_party/libaom/source/libaom/third_party/x86inc
third_party/libjingle
third_party/libphonenumber
@@ -361,22 +364,6 @@ src_prepare() {
build/linux/unbundle/remove_bundled_libraries.py "${keeplibs[@]}" --do-remove || die
}
-bootstrap_gn() {
- if tc-is-cross-compiler; then
- local -x AR=${BUILD_AR}
- local -x CC=${BUILD_CC}
- local -x CXX=${BUILD_CXX}
- local -x NM=${BUILD_NM}
- local -x CFLAGS=${BUILD_CFLAGS}
- local -x CXXFLAGS=${BUILD_CXXFLAGS}
- local -x LDFLAGS=${BUILD_LDFLAGS}
- fi
- einfo "Building GN..."
- set -- tools/gn/bootstrap/bootstrap.py -s -v --no-clean
- echo "$@"
- "$@" || die
-}
-
src_configure() {
# Calling this here supports resumption via FEATURES=keepwork
python_setup
@@ -569,10 +556,8 @@ src_configure() {
popd > /dev/null || die
fi
- bootstrap_gn
-
einfo "Configuring Chromium..."
- set -- out/Release/gn gen --args="${myconf_gn} ${EXTRA_GN}" out/Release
+ set -- gn gen --args="${myconf_gn} ${EXTRA_GN}" out/Release
echo "$@"
"$@" || die
}
diff --git a/www-client/chromium/files/chromium-compiler-r4.patch b/www-client/chromium/files/chromium-compiler-r4.patch
new file mode 100644
index 000000000000..3fe73ef7fec2
--- /dev/null
+++ b/www-client/chromium/files/chromium-compiler-r4.patch
@@ -0,0 +1,168 @@
+From 777d166eec22c1894108dce985498f75ac5931e8 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Wed, 25 Apr 2018 13:22:49 -0400
+Subject: [PATCH] Disable various compiler configs
+
+---
+ build/config/compiler/BUILD.gn | 61 ++++++++++------------------------
+ 1 file changed, 18 insertions(+), 43 deletions(-)
+
+diff --git a/build/config/compiler/BUILD.gn b/build/config/compiler/BUILD.gn
+index 6e38ad782d38..87bbd423f67f 100644
+--- a/build/config/compiler/BUILD.gn
++++ b/build/config/compiler/BUILD.gn
+@@ -225,8 +225,6 @@ config("compiler") {
+
+ configs += [
+ # See the definitions below.
+- ":clang_revision",
+- ":compiler_cpu_abi",
+ ":compiler_codegen",
+ ]
+
+@@ -488,18 +486,6 @@ config("compiler") {
+ }
+ }
+
+- if (is_clang && !is_nacl && current_toolchain == host_toolchain &&
+- target_os != "chromeos") {
+- cflags += [
+- # TODO(hans): Remove this once Clang generates better optimized debug info
+- # by default. https://crbug.com/765793
+- "-Xclang",
+- "-mllvm",
+- "-Xclang",
+- "-instcombine-lower-dbg-declare=0",
+- ]
+- }
+-
+ # Print absolute paths in diagnostics. There is no precedent for doing this
+ # on Linux/Mac (GCC doesn't support it), but MSVC does this with /FC and
+ # Windows developers rely on it (crbug.com/636109) so only do this on Windows.
+@@ -1473,10 +1459,6 @@ config("default_warnings") {
+ cflags += [
+ # TODO(thakis): https://crbug.com/753973
+ "-Wno-enum-compare-switch",
+-
+- # Ignore warnings about MSVC optimization pragmas.
+- # TODO(thakis): Only for no_chromium_code? http://crbug.com/505314
+- "-Wno-ignored-pragma-optimize",
+ ]
+ }
+ }
+@@ -1518,22 +1500,6 @@ config("chromium_code") {
+ "__STDC_FORMAT_MACROS",
+ ]
+
+- if (!is_debug && !using_sanitizer &&
+- (!is_linux || !is_clang || is_official_build) &&
+- current_cpu != "s390x" && current_cpu != "s390" &&
+- current_cpu != "ppc64" && current_cpu != "ppc64" &&
+- current_cpu != "mips" && current_cpu != "mips64") {
+- # _FORTIFY_SOURCE isn't really supported by Clang now, see
+- # http://llvm.org/bugs/show_bug.cgi?id=16821.
+- # It seems to work fine with Ubuntu 12 headers though, so use it in
+- # official builds.
+- #
+- # Non-chromium code is not guaranteed to compile cleanly with
+- # _FORTIFY_SOURCE. Also, fortified build may fail when optimizations are
+- # disabled, so only do that for Release build.
+- defines += [ "_FORTIFY_SOURCE=2" ]
+- }
+-
+ if (is_mac || is_ios) {
+ cflags_objc = [ "-Wobjc-missing-property-synthesis" ]
+ cflags_objcc = [ "-Wobjc-missing-property-synthesis" ]
+@@ -1863,7 +1829,8 @@ config("default_stack_frames") {
+ }
+
+ # Default "optimization on" config.
+-config("optimize") {
++config("optimize") { }
++config("xoptimize") {
+ if (is_win) {
+ # TODO(thakis): Remove is_clang here, https://crbug.com/598772
+ if (is_official_build && full_wpo_on_official && !is_clang) {
+@@ -1897,7 +1864,8 @@ config("optimize") {
+ }
+
+ # Same config as 'optimize' but without the WPO flag.
+-config("optimize_no_wpo") {
++config("optimize_no_wpo") { }
++config("xoptimize_no_wpo") {
+ if (is_win) {
+ # Favor size over speed, /O1 must be before the common flags. The GYP
+ # build also specifies /Os and /GF but these are implied by /O1.
+@@ -1920,7 +1888,8 @@ config("optimize_no_wpo") {
+ }
+
+ # Turn off optimizations.
+-config("no_optimize") {
++config("no_optimize") { }
++config("xno_optimize") {
+ if (is_win) {
+ cflags = [
+ "/Od", # Disable optimization.
+@@ -1944,7 +1913,8 @@ config("no_optimize") {
+ # Turns up the optimization level. On Windows, this implies whole program
+ # optimization and link-time code generation which is very expensive and should
+ # be used sparingly.
+-config("optimize_max") {
++config("optimize_max") { }
++config("xoptimize_max") {
+ if (is_nacl && is_nacl_irt) {
+ # The NaCl IRT is a special case and always wants its own config.
+ # Various components do:
+@@ -1991,7 +1961,8 @@ config("optimize_max") {
+ #
+ # TODO(crbug.com/621335) - rework how all of these configs are related
+ # so that we don't need this disclaimer.
+-config("optimize_speed") {
++config("optimize_speed") { }
++config("xoptimize_speed") {
+ if (is_nacl && is_nacl_irt) {
+ # The NaCl IRT is a special case and always wants its own config.
+ # Various components do:
+@@ -2029,7 +2000,8 @@ config("optimize_speed") {
+ }
+ }
+
+-config("optimize_fuzzing") {
++config("optimize_fuzzing") { }
++config("xoptimize_fuzzing") {
+ cflags = [ "-O1" ] + common_optimize_on_cflags
+ ldflags = common_optimize_on_ldflags
+ visibility = [ ":default_optimization" ]
+@@ -2115,7 +2087,8 @@ config("afdo") {
+ # configs += [ "//build/config/compiler:symbols" ]
+
+ # Full symbols.
+-config("symbols") {
++config("symbols") { }
++config("xsymbols") {
+ if (is_win) {
+ if (use_goma || is_clang) {
+ # Note that with VC++ this requires is_win_fastlink, enforced elsewhere.
+@@ -2213,7 +2186,8 @@ config("symbols") {
+ # Minimal symbols.
+ # This config guarantees to hold symbol for stack trace which are shown to user
+ # when crash happens in unittests running on buildbot.
+-config("minimal_symbols") {
++config("minimal_symbols") { }
++config("xminimal_symbols") {
+ if (is_win) {
+ # Linker symbols for backtraces only.
+ cflags = []
+@@ -2244,7 +2218,8 @@ config("minimal_symbols") {
+ }
+
+ # No symbols.
+-config("no_symbols") {
++config("no_symbols") { }
++config("xno_symbols") {
+ if (!is_win) {
+ cflags = [ "-g0" ]
+ asmflags = cflags
+--
+2.18.0
+