summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/yadm/Manifest1
-rw-r--r--app-admin/yadm/metadata.xml26
-rw-r--r--app-admin/yadm/yadm-1.04.ebuild37
-rw-r--r--dev-util/bats/Manifest1
-rw-r--r--dev-util/bats/bats-0.4.0.ebuild24
-rw-r--r--dev-util/bats/metadata.xml26
-rw-r--r--eclass/ros-catkin.eclass4
-rw-r--r--profiles/package.mask2
8 files changed, 119 insertions, 2 deletions
diff --git a/app-admin/yadm/Manifest b/app-admin/yadm/Manifest
new file mode 100644
index 000000000000..227ed5581169
--- /dev/null
+++ b/app-admin/yadm/Manifest
@@ -0,0 +1 @@
+DIST yadm-1.04.tar.gz 27391 SHA256 a73aa51245866ce67aeb4322a62995ebbb13f29dc35508f486819dceb534968a SHA512 f3f909118f29382c6cbae565de336c27fd7d159955a231ac22b0d25e25e50c4c3e1bdc68b1629920904ad9353ee8ce8f7e5c5e50d289984447815a685a4132c9 WHIRLPOOL c74c2bfc89abb6955bb4e0d60b1cb0777c9f9ec43bc1919c130cd8470e44c090fba9003e473f4344ed92df23e399ea45ece6dafde80d575a8af491bb4c16b554
diff --git a/app-admin/yadm/metadata.xml b/app-admin/yadm/metadata.xml
new file mode 100644
index 000000000000..a5fe84884c09
--- /dev/null
+++ b/app-admin/yadm/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dev+gentoobugzilla@henriksen.is</email>
+ <name>Espen H</name>
+ <description>Proxy maintainer - set to assignee on bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">TheLocehiliosan/yadm</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ yadm is a dotfile manager that handles the hassle of synchronizing the
+ dotfiles in your home folder across different workstations. It has a
+ philosophy using git and getting out of git's way to ensure it does what it
+ does best. What sets it apart is that it supports encryption, which enables
+ you to add files like mutt configuration with passwords and host it
+ publicly. It also enables you to add suffixes to your files like
+ ##Linux.hostname, and yadm will automatically symlink the file if you are
+ on that hostname.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/yadm/yadm-1.04.ebuild b/app-admin/yadm/yadm-1.04.ebuild
new file mode 100644
index 000000000000..661af4e8814a
--- /dev/null
+++ b/app-admin/yadm/yadm-1.04.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A dotfile manager for the config files in your home folder"
+HOMEPAGE="https://github.com/TheLocehiliosan/yadm/"
+SRC_URI="https://github.com/TheLocehiliosan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DOCS=( CHANGES CONTRIBUTORS README.md )
+
+DEPEND="
+ test? (
+ dev-util/bats
+ dev-vcs/git
+ )"
+RDEPEND="dev-vcs/git
+ app-crypt/gnupg"
+
+src_test() {
+ # 109_accept_encryption tests are interactive, thus fail. Skip them
+ bats $(find test/ -type f -name '*.bats' -and -not -name '109_accept_encryption.bats') \
+ || die "Tests failed"
+}
+
+src_install() {
+ einstalldocs
+
+ dobin yadm
+ doman yadm.1
+}
diff --git a/dev-util/bats/Manifest b/dev-util/bats/Manifest
new file mode 100644
index 000000000000..f74b43f3eab0
--- /dev/null
+++ b/dev-util/bats/Manifest
@@ -0,0 +1 @@
+DIST bats-0.4.0.tar.gz 17258 SHA256 480d8d64f1681eee78d1002527f3f06e1ac01e173b761bc73d0cf33f4dc1d8d7 SHA512 83c6c0e3ceec149708a8db5d33e95cc84852d8189498c22131c00f4288a6c870f9d522bae9230157f442338dc101e1468451d78dfa274afb83a6f0dd614c8bdb WHIRLPOOL 9617418d6a288d6e57aa1d715498c9adcfbe80cd97a814382431203dab778f26139dc31a14aecfd6f2e71a51f11fe189fce6e3bb7174ce9d4ad25782a9a6fce0
diff --git a/dev-util/bats/bats-0.4.0.ebuild b/dev-util/bats/bats-0.4.0.ebuild
new file mode 100644
index 000000000000..3fa4d97e3843
--- /dev/null
+++ b/dev-util/bats/bats-0.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="An automated testing system for bash"
+HOMEPAGE="https://github.com/sstephenson/bats/"
+SRC_URI="https://github.com/sstephenson/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_test() {
+ bin/bats --tap test
+}
+
+src_install() {
+ einstalldocs
+
+ dobin libexec/*
+ doman man/bats.1 man/bats.7
+}
diff --git a/dev-util/bats/metadata.xml b/dev-util/bats/metadata.xml
new file mode 100644
index 000000000000..63003cd5ebcb
--- /dev/null
+++ b/dev-util/bats/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dev+gentoobugzilla@henriksen.is</email>
+ <name>Espen H</name>
+ <description>Proxy maintainer - set to assignee on bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sstephenson/bats</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Bats is a TAP-compliant testing framework for Bash. It provides a simple
+ way to verify that the UNIX programs you write behave as expected.
+
+ A Bats test file is a Bash script with special syntax for defining test
+ cases. Under the hood, each test case is just a function with a description.
+
+ Bats is most useful when testing software written in Bash, but you can use
+ it to test any UNIX program.
+ </longdescription>
+</pkgmetadata>
diff --git a/eclass/ros-catkin.eclass b/eclass/ros-catkin.eclass
index 412ff66e01c9..30132b70c4b9 100644
--- a/eclass/ros-catkin.eclass
+++ b/eclass/ros-catkin.eclass
@@ -202,7 +202,9 @@ ros-catkin_src_compile() {
# Decorator around cmake-utils_src_test to ensure tests are built before running them.
ros-catkin_src_test_internal() {
cd "${BUILD_DIR}" || die
- if nonfatal cmake-utils_src_make tests -n &> /dev/null ; then
+ # Using cmake-utils_src_make with nonfatal does not work and breaks e.g.
+ # dev-ros/rviz.
+ if nonfatal emake tests -n &> /dev/null ; then
cmake-utils_src_make tests
fi
cmake-utils_src_test "${@}"
diff --git a/profiles/package.mask b/profiles/package.mask
index e3c4db91fa74..750ff23514b7 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -34,7 +34,7 @@
# Packages merged upstream with app-text/blogc. Please install
# app-text/blogc with USE=git and USE=httpd instead. Removal in 30 days.
dev-vcs/blogc-git-receiver
-www-server/blogc-runserver
+www-servers/blogc-runserver
# James Le Cuirot <chewi@gentoo.org> (27 Apr 2016)
# Very very dead upstream and probably doesn't work any more like