summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/graphene/Manifest1
-rw-r--r--media-libs/graphene/graphene-1.8.2.ebuild59
-rw-r--r--media-libs/graphene/metadata.xml11
3 files changed, 71 insertions, 0 deletions
diff --git a/media-libs/graphene/Manifest b/media-libs/graphene/Manifest
new file mode 100644
index 000000000000..5a5e4e551695
--- /dev/null
+++ b/media-libs/graphene/Manifest
@@ -0,0 +1 @@
+DIST graphene-1.8.2.tar.xz 127436 BLAKE2B a22251db7cf4719c8a6cde49e6feb0a998d1ec7296fee549a4797d72fa575d4266e48fb5a6d9ebd204b93954a6278b4fa88dc56e5f86d7cf8625a5edc685a09b SHA512 8d250dccac345251081419f4ad7079c8035cb6225e10b23d25799386b067288831c23be667d608228ef44a2f6107ac47fc86bb495eda7881b1336598d6c43234
diff --git a/media-libs/graphene/graphene-1.8.2.ebuild b/media-libs/graphene/graphene-1.8.2.ebuild
new file mode 100644
index 000000000000..1c5ae38fb9bd
--- /dev/null
+++ b/media-libs/graphene/graphene-1.8.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+inherit meson multilib-minimal python-any-r1
+
+DESCRIPTION="A thin layer of types for graphic libraries"
+HOMEPAGE="https://ebassi.github.io/graphene/"
+SRC_URI="https://github.com/ebassi/graphene/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 doc +introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.30.0:2[${MULTILIB_USEDEP}]
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+# Python is only needed with USE=introspection or FEATURES=test, but not bothering with conditional python_setup
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( dev-util/gtk-doc )
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ # Disable installed-tests
+ sed -e 's/install: true/install: false/g' -i src/tests/meson.build || die
+}
+
+multilib_src_configure() {
+ # TODO: Do we want G_DISABLE_ASSERT as buildtype=release would do upstream?
+ local emesonargs=(
+ -Dgtk_doc=$(multilib_native_usex doc true false)
+ -Dgobject_types=true
+ -Dintrospection=$(multilib_native_usex introspection true false)
+ -Dgcc_vector=true # if built-in support tests fail, it'll just not enable vector intrinsics; unfortunately this probably means disabled on clang too, due to it claiming to be <gcc-4.9
+ $(meson_use cpu_flags_x86_sse2 sse2)
+ $(meson_use cpu_flags_arm_neon arm_neon)
+ $(meson_use test tests)
+ -Dbenchmarks=false
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}
diff --git a/media-libs/graphene/metadata.xml b/media-libs/graphene/metadata.xml
new file mode 100644
index 000000000000..46e32a119ea5
--- /dev/null
+++ b/media-libs/graphene/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ebassi/graphene</remote-id>
+ </upstream>
+</pkgmetadata>