summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/unison/unison-2.51.4_rc2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-misc/unison/unison-2.51.4_rc2.ebuild b/net-misc/unison/unison-2.51.4_rc2.ebuild
index 02f43dee92d9..db9797ada80a 100644
--- a/net-misc/unison/unison-2.51.4_rc2.ebuild
+++ b/net-misc/unison/unison-2.51.4_rc2.ebuild
@@ -28,11 +28,11 @@ RDEPEND="gtk? ( dev-ml/lablgtk:2=
DOCS=( BUGS.txt CONTRIB INSTALL NEWS README ROADMAP.txt TODO.txt )
src_prepare() {
+ default
# https://github.com/bcpierce00/unison/issues/416
sed -e "/ifdef\ HEVEA/,/endif/d" -i doc/Makefile || die
# https://github.com/bcpierce00/unison/pull/415
sed -e "/myName/d" -i doc/docs.ml || die
- default
}
src_compile() {
@@ -55,11 +55,11 @@ src_compile() {
use ocamlopt || myconf+=( NATIVE=false )
if use doc; then
- VARTEXFONTS="${T}/fonts" emake $myconf CFLAGS="" HEVEA=false docs
+ VARTEXFONTS="${T}/fonts" emake "${myconf[@]}" CFLAGS="" HEVEA=false docs
fi
# Discard cflags as it will try to pass them to ocamlc...
- emake $myconf CFLAGS="" src
+ emake "${myconf[@]}" CFLAGS="" src
}
src_test() {