summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-misc/kdiff3/files/kdiff3-1.8.2-crash-w-o-clipboard.patch36
-rw-r--r--kde-misc/kdiff3/kdiff3-1.8.2-r1.ebuild (renamed from kde-misc/kdiff3/kdiff3-1.8.2.ebuild)3
-rw-r--r--profiles/package.mask10
-rw-r--r--sci-libs/ceres-solver/Manifest1
-rw-r--r--sci-libs/ceres-solver/ceres-solver-1.12.0.ebuild97
-rw-r--r--sci-libs/ceres-solver/metadata.xml1
-rw-r--r--sci-libs/geos/Manifest1
-rw-r--r--sci-libs/geos/geos-3.8.0-r1.ebuild56
8 files changed, 48 insertions, 157 deletions
diff --git a/kde-misc/kdiff3/files/kdiff3-1.8.2-crash-w-o-clipboard.patch b/kde-misc/kdiff3/files/kdiff3-1.8.2-crash-w-o-clipboard.patch
new file mode 100644
index 000000000000..b1d00a12f47d
--- /dev/null
+++ b/kde-misc/kdiff3/files/kdiff3-1.8.2-crash-w-o-clipboard.patch
@@ -0,0 +1,36 @@
+From 643edc26bcc8f8e083a97e87c2686f62ffd01f31 Mon Sep 17 00:00:00 2001
+From: Christoph Feck <cfeck@kde.org>
+Date: Thu, 30 Apr 2020 18:27:58 -0400
+Subject: Fix crash when clipboard is not available
+
+Summary:
+QClipboard::mimeData() can be nullptr according to documentation.
+
+BUG: 419722
+FIXED-IN: 1.8.3
+
+Reviewers: mreeves
+
+Reviewed By: mreeves
+
+Differential Revision: https://phabricator.kde.org/D29248
+---
+ src/pdiff.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/pdiff.cpp b/src/pdiff.cpp
+index f3f2284..3588e3e 100644
+--- a/src/pdiff.cpp
++++ b/src/pdiff.cpp
+@@ -1577,7 +1577,7 @@ void KDiff3App::slotClipboardChanged()
+ {
+ const QClipboard* clipboard = QApplication::clipboard();
+ const QMimeData* mimeData = clipboard->mimeData();
+- if(mimeData->hasText())
++ if(mimeData && mimeData->hasText())
+ {
+ QString s = clipboard->text();
+ editPaste->setEnabled(!s.isEmpty());
+--
+cgit v1.1
+
diff --git a/kde-misc/kdiff3/kdiff3-1.8.2.ebuild b/kde-misc/kdiff3/kdiff3-1.8.2-r1.ebuild
index 64b665a240e6..114f5b83e868 100644
--- a/kde-misc/kdiff3/kdiff3-1.8.2.ebuild
+++ b/kde-misc/kdiff3/kdiff3-1.8.2-r1.ebuild
@@ -36,5 +36,6 @@ DEPEND="
"
RDEPEND="${DEPEND}
sys-apps/diffutils
- !kde-misc/kdiff3:4
"
+
+PATCHES=( "${FILESDIR}/${P}-crash-w-o-clipboard.patch" )
diff --git a/profiles/package.mask b/profiles/package.mask
index 3f79b12eeb92..9a08ae76d684 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -32,6 +32,16 @@
#--- END OF EXAMPLES ---
+# Andreas Sturmlechner <asturm@gentoo.org> (2020-05-01)
+# Currently packaged release from 2015, needs maintainer + bump. Bug #720346
+# Stuck on Python 2 and pygtk. Masked for removal in 30 days.
+app-mobilephone/ganyremote
+
+# Andreas Sturmlechner <asturm@gentoo.org> (2020-05-01)
+# Last release in 2018, wip/gtk3 branch untouched since 2017. Bug #598906
+# Stuck on Python 2 and pygtk. Masked for removal in 30 days.
+app-office/pybliographer
+
# Michał Górny <mgorny@gentoo.org> (2020-05-01)
# Wrongly adds '-*' to USE causing catastrophic system breakage.
# Bug #649416.
diff --git a/sci-libs/ceres-solver/Manifest b/sci-libs/ceres-solver/Manifest
index 0b1e2173e3d0..941bf4bbf4f1 100644
--- a/sci-libs/ceres-solver/Manifest
+++ b/sci-libs/ceres-solver/Manifest
@@ -1,2 +1 @@
-DIST ceres-solver-1.12.0.tar.gz 5008861 BLAKE2B 52b3954dde96386bd031543ab9d7370368f58f76f1dec9d24ef10803da787cc96f40a1c775626fde832b70ebd94cf4274c70a8fb4bd7e1bcf040e119cbec09f8 SHA512 485eece0471cf05d31b5dd7e133e23115a334a4ed557a3c1bd0b715a063f840738af8f507e935522a0dae90ce6851984c0002a25e9b445b90889792f68a05571
DIST ceres-solver-1.14.0.tar.gz 5450130 BLAKE2B cfcfe07cecb267528081dfc6deb5283bc5a04b79d4595e45365960895b84a6dca2a3024b046868f06709fc81e8514730cbc409ab01cb0cbee488b5bad5b9f7cc SHA512 a2af9918d2730709361ec971431a2b22e6ca3ca440081be87fa52729ec43702020b021837bfe5a42a58db1ab89ea6aada11f2d1888da66bef614ec1f27ab30c6
diff --git a/sci-libs/ceres-solver/ceres-solver-1.12.0.ebuild b/sci-libs/ceres-solver/ceres-solver-1.12.0.ebuild
deleted file mode 100644
index 05747c215b05..000000000000
--- a/sci-libs/ceres-solver/ceres-solver-1.12.0.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit cmake-multilib eutils python-any-r1 toolchain-funcs
-
-DESCRIPTION="Nonlinear least-squares minimizer"
-HOMEPAGE="http://ceres-solver.org/"
-SRC_URI="http://ceres-solver.org/${P}.tar.gz"
-
-LICENSE="sparse? ( BSD ) !sparse? ( LGPL-2.1 ) cxsparse? ( BSD )"
-SLOT="0/1"
-KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="cxsparse c++11 doc examples gflags lapack openmp +schur sparse test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="test? ( gflags ) sparse? ( lapack ) abi_x86_32? ( !sparse !lapack )"
-
-RDEPEND="
- dev-cpp/glog[gflags?,${MULTILIB_USEDEP}]
- cxsparse? ( sci-libs/cxsparse )
- lapack? ( virtual/lapack )
- sparse? (
- sci-libs/amd
- sci-libs/camd
- sci-libs/ccolamd
- sci-libs/cholmod[metis(+)]
- sci-libs/colamd
- sci-libs/spqr
- )"
-
-DEPEND="${RDEPEND}
- dev-cpp/eigen:3
- doc? ( dev-python/sphinx dev-python/sphinx_rtd_theme )
- lapack? ( virtual/pkgconfig )
- ${PYTHON_DEPS}"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- if [[ $(tc-getCXX) == *g++* ]] && ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected gcc"
- die "need openmp capable gcc"
- fi
- fi
-}
-
-pkg_setup() {
- use doc && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- # search paths work for prefix
- sed -e "s:/usr:${EPREFIX}/usr:g" \
- -i cmake/*.cmake || die
-
- # remove Werror
- sed -e 's/-Werror=(all|extra)//g' \
- -i CMakeLists.txt || die
-
- # respect gentoo doc install directory
- sed -e "s:share/doc/ceres:share/doc/${PF}:" \
- -i docs/source/CMakeLists.txt || die
- cmake-utils_src_prepare
-}
-
-src_configure() {
- # CUSTOM_BLAS=OFF EIGENSPARSE=OFF MINIGLOG=OFF CXX11=OFF
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -DBUILD_EXAMPLES=OFF
- -DENABLE_TESTING="$(usex test)"
- -DCXX11="$(usex c++11)"
- -DBUILD_DOCUMENTATION="$(usex doc)"
- -DGFLAGS="$(usex gflags)"
- -DLAPACK="$(usex lapack)"
- -DOPENMP="$(usex openmp)"
- -DSCHUR_SPECIALIZATIONS="$(usex schur)"
- -DCXSPARSE="$(usex cxsparse)"
- -DSUITESPARSE="$(usex sparse)"
- )
- use sparse || use cxsparse || mycmakeargs+=( -DEIGENSPARSE=ON )
- cmake-multilib_src_configure
-}
-
-src_install() {
- cmake-multilib_src_install
- dodoc README.md VERSION
-
- if use examples; then
- docinto /usr/share/doc/${PF}
- docompress -x /usr/share/doc/${PF}/examples
- doins -r examples data
- fi
-}
diff --git a/sci-libs/ceres-solver/metadata.xml b/sci-libs/ceres-solver/metadata.xml
index 42d1cafcb8bf..57c1a1394e07 100644
--- a/sci-libs/ceres-solver/metadata.xml
+++ b/sci-libs/ceres-solver/metadata.xml
@@ -29,6 +29,5 @@
<flag name="sparse">Enable support for sparse matrix algebra with various
packages from SuiteSparse</flag>
<flag name="gflags">Use <pkg>dev-cpp/gflags</pkg> for flag parsing</flag>
- <flag name="c++11">Build ceres-solver using the C++11 standard</flag>
</use>
</pkgmetadata>
diff --git a/sci-libs/geos/Manifest b/sci-libs/geos/Manifest
index 78ff40950806..1fc391846d55 100644
--- a/sci-libs/geos/Manifest
+++ b/sci-libs/geos/Manifest
@@ -1,2 +1 @@
-DIST geos-3.8.0.tar.bz2 2399403 BLAKE2B 0f9b6d7f9a4052b9b84e77d534be6e2909e5dc4995287f34e3b7e7c1537c9a73088d4a49f96f43034723eb37c88674aae469e26d7db3eb40efbcdf5551553a1a SHA512 c89b25b42092152ef261090f25ff64b229f30f67d42fdf44c2871e78b66bb2c42e23b9ae21f9aea0e48823bdb0267d609ab2ee77d310abcb76fa672c6614d8f1
DIST geos-3.8.1.tar.bz2 2505407 BLAKE2B 43053ea9e29d190f41c37d5d382b689ef477e0256cfd5705f4f2f316cac21a1674660bcf0900c51db72909c41d46be7a41d297958de48e108ae6d6bd1ca9d247 SHA512 1d8d8b3ece70eb388ea128f4135c7455899f01828223b23890ad3a2401e27104efce03987676794273a9b9d4907c0add2be381ff14b8420aaa9a858cc5941056
diff --git a/sci-libs/geos/geos-3.8.0-r1.ebuild b/sci-libs/geos/geos-3.8.0-r1.ebuild
deleted file mode 100644
index 53a956cfd2d4..000000000000
--- a/sci-libs/geos/geos-3.8.0-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PV=${PV/_/}
-
-DESCRIPTION="Geometry engine library for Geographic Information Systems"
-HOMEPAGE="http://trac.osgeo.org/geos/"
-SRC_URI="http://download.osgeo.org/geos/${PN}-${MY_PV}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
-IUSE="doc ruby static-libs"
-
-BDEPEND="
- doc? ( app-doc/doxygen )
- ruby? ( dev-lang/swig:0 )
-"
-RDEPEND="
- ruby? ( dev-lang/ruby:* )
-"
-DEPEND="${RDEPEND}"
-
-RESTRICT="test"
-
-S="${WORKDIR}"/${PN}-${MY_PV}
-
-src_prepare() {
- default
- echo "#!${EPREFIX}/bin/bash" > py-compile
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-python
- $(use_enable ruby)
- $(use_enable static-libs static)
- )
- use arm && myeconfargs+=( --disable-inline ) # bug 709368
-
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- default
- use doc && emake -C doc doxygen-html
-}
-
-src_install() {
- use doc && HTML_DOCS=( doc/doxygen_docs/html/. )
- default
-
- find "${D}" -name '*.la' -delete || die
-}